AKAI APC40 mkII Discussion

This is to discuss the AKAI APC40 mkII controller.

15replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • While I have the controller - the current functionality means I cannot really use it. Wirecast crashes multiple times per day if I have the midi controller active while editing shots. I've reset the preferences as suggested by your support team. But still not really useful.

    One other show stopper for me is the "random" allocation of audio to the faders. Every time you launch a shot, the fader allocations all play musical chairs and any of your existing fader settings are meaningless.

  • Greg Kuhnert

    Thank you for the feedback. We have already been looking at the musical faders issue, which we were aware of when we released it as a technical preview, which is also a first.


    I am curious if you can provide short repro steps for a consistent crash with that controller.


    I have only seen one, and it was a quite odd case, in which a phantom NDI source on the network locked up the controller some how when switched to it after it disappeared. Tried to repro, and never saw it happen again.


    Have you sent in a support log to support or just inquired as how to resolve? Logs and a case number would be helpful. A few of your reports have made it through triage, but I have not seen this one.

  • Hi Bryce.

    I wish I could give you more. It is unpredictable most of the time, but really frustrating. I have indeed sent in a number of crash logs. The case is currently owned by CraigS  - case number 00529848

    As you've seen with my other reports, I do like to give you enough data to reproduce - and even include how to reproduce videos - but this one is elusive. I'll try to document it more - but would appreciate your first reactions to the crash dump in the above ticket.

  • Actually Bryce. I have a question. As I am editing shots, I often get to a point where the AKAI is unresponsive... and later, Wirecast will crash on exit. My question - Before exiting wirecast, are there any debug or diagnostic details you require to help find this? I can replicate this - i just don't know which specific thing I am doing that causes the problem.


  • Greg Kuhnert You support logs have crash details in them, just needs to get looked at by engineer.

  • Hi,...i am a new user here. I was pumped to see the APC40 MKII coming out. Ditching the power cable was enough to warrant the upgrade. When it arrived in August I had a few days to get it ready for a wedding I was doing that weekend. I ported everything over and took advantage of the RGB buttons to add some more fun to the template. Life was even better because now I had a newer control surface to run my software with. By now I felt confident in what I was doing to provide my template as a product for sale. I recorded a demo video and posted it online with contact information to get at me.

  • Hello! First off thank all of you for taking the time to put information like this out on the web.

    Now for my problem. I hooked up my AKAI APC40 MK!! and all the pads light up accordingly. There are 4 cameras in the camera layer and 5 total lights show up (1 for the clear layer).

    However when I click anything on the controller itself nothing happens. I feel like I am probably missing some thing suuuuuuper simple. However I cannot figure it out. I am also using the newest version of Wirecast 8.3 I think. 

    Please advise. 



  • Mychael Clack said:
    I am also using the newest version of Wirecast 8.3 I think. 

     Please confirm that. Since it seems to be working for others you may want to try something simple like rebooting the computer. Also you may want to test in a New Document.

  • CraigS - This is one of the current symptoms. Randomly after doing edits in a document, it locks up and the controller becomes unresponsive. Later, there will be a crash.

    And for the record, I can say I have reset preferences and started with a new document. Same result. Still broken here.

  • Greg Kuhnert Does rebooting the computer help? Not that that would be a viable fix but it might indicate something.

  • CraigS reboot will fix for a time, but it will fail again if you do any serious shot editing.  If you are using an existing document making no changes, it won’t crash. 

  • Greg Kuhnert Thanks. So it's failing over time. That'll help us troubleshoot this.

  • Bryce Stejskal said:
    Thank you for the feedback. We have already been looking at the musical faders issue, which we were aware of when we released it as a technical preview, which is also a first.

    It is now a year since you talked about this problem as related to your "technical preview". Are there any plans to provide a finished product? The known issues in your "preview" still exist, and have not been addressed.

  • Greg Kuhnert

    Thank you for reaching out and asking about this.

    The MIDI functionality has been de-prioritized due to lack of interest from the wider customer base as a whole.

    As an "audio guy" and hobby-musician, I look forward to an Ableton-style custom midi mapping paradigm within Wirecast. However, the vast majority of users seeking control surface support in Wirecast have opted for the XKEYS custom controller we developed in tandem with XKEYS.

    With so little usage/interest of MIDI, the team has opted to focus efforts on other areas of the app that offer benefit to a wider subset of users.

    To date, I am not aware of any other reports similar to your crash regarding MIDI, though it sounds severe enough to not be isolated to your workflow.


    To truly make MIDI useful in Wirecast, I see a host of things needing to change:

    • Custom Mapping
    • UI shading for easy mapping like Ableton
    • Custom work around commands that are only accessible by menu bar and not primary UI.
    • Audio Mixer track pinning(or global/static audio mixer mode)
    • WIFI/Bluetooth MIDI (TouchOSC would be great)

    If enough interest comes from the community regarding this, I am certain the priorities would change to reflect.


    -Bryce Stejskal

  • Bryce Stejskal 

    Bryce Stejskal said:
    The MIDI functionality has been de-prioritized due to lack of interest from the wider customer base as a whole.

    Thanks for your candid answer. Let me provide a candid answer in response. With a half baked incomplete implementation, it is not surprising that your customer base is not interested. Why would they purchase midi hardware, when they know others who tried have been disappointed, with no light at the end of the tunnel.

    Sorry to be blunt, and I know it is not your decision personally, but it is the same reason why people don't use rendezvous. They don't trust it. This is why people use outboard mixers. The incomplete functionality in wirecast gives them no choice. Both are examples of rushed incomplete implementations, that have never been finished.

    And what is even more frustrating is that I purchased my controller device based on the marketing promises. I spent cash, and it still doesn't work. Who will cover the cost of devices where people purchased equipment, on the basis of promises made by Telestream?

Like3 Follow
  • 5 mths agoLast active
  • 15Replies
  • 1705Views
  • 8 Following