How To Deal With ScreenFlow Crashes

I've recorded lots of videos that worked fine. But a new one keeps crashing when I try to export (batch or regular) and also often crashes when I use the timeline to e.g. play back different parts of the video. I tried deleting everything on the timeline and then re-adding the original media files, but that didn't help. I only need minimal edits so I just redid them (adjust mic volume and remove background noise, and mute the computer recording – globally for the entire video, no edits to any specific parts). When trying to playback near the end of the file, it was especially glitchy: sometimes the playback video turned bright purple and there was no volume. Just now, after trying this for a while, Screenflow has crashed immediately the last 5 times I opened it. I finally managed to immediately hit cmd-w after opening, then it crashed anyway, but next time I opened it my project was no longer open so it didn't crash.


I already tried restarting my computer. I tried deleting screenflow caches in ~/Library/Caches. And I have successfully exported a different video (with similar length and content) after having this problem.


EDIT: I remembered this is the video where my startup disk got low on space while I was recording. (It had 100gb free but that got mostly used up by hidden files, maybe by screenflow. The space came back after restarting and I deleted more stuff.) I paused and deleted some stuff and the recording seemed to keep going and work fine. I didn't export right away. That was towards the end. So maybe that somehow resulted in some glitched recording data. If so, what should I do?


What troubleshooting steps should I do? It wouldn't be a big deal to lose a few seconds of the video if there's a glitch somewhere, but I do need to get it exported somehow.


iMac (Retina 5K, 27-inch, Late 2014)

4ghz i7

32gb 1600mhz ddr3

AMD Radeon R9 M295X 4096 MB


MacOS 10.13.5


Screenflow: 7.3.1 (31077) (NOT mac app store)


External devices recording from and how are they connected to computer: USB mic. Worked fine in two dozen other videos.

Scratch disk location in preferences if it's hard drive record or playback issue: Startup Volume

Free hard drive space: 225gb free on internal SSD (the startup volume), 1.7tb free on external HD (where the 21gb screenflow project file is saved)

Number of Monitors: 27" imac, and two 32" displays (which i'm not recording on, and not running screenflow on, except i usually put the recording monitor window on one of them)


Export settings: H.264, 60fps, 2000 kbits/sec, High profile, Hardware Accelerated, 300 keyframe interval, AAC Audio, 48khz, 256kbits/sec, Stereo. Scale to 50%.

Source files used in your project? Nothing extra, just the mic recording and the computer recording.


What you are recording? I don't think this matters but the screencast includes: TextEdit, Chrome, Ulysses, Dictionary.


Recording Length: 2.25 hours.

Error message: Screenflow Unexpectedly Quit

I can share the project file but it's 21 gigabytes. Let me know how/where to upload it if you want it (or I could zip and put it on my web server).


Below is the beginning of the latest Apple crash log. For this one, I opened Screenflow and then I tried to close the project but it crashed first. I also attached one of the crash logs from trying to export the video.


Process:               ScreenFlow [7866]
Path:                  /Applications/ScreenFlow.app/Contents/MacOS/ScreenFlow
Identifier:            net.telestream.screenflow7
Version:               7.3.1 (31077)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           ScreenFlow [7866]
User ID:               501

Date/Time:             2018-07-07 17:09:55.945 -0700
OS Version:            Mac OS X 10.13.5 (17F77)
Report Version:        12
Anonymous UUID:        76D475DF-CF8E-1B7A-84E3-6AF937D715D9

Time Awake Since Boot: 7900 seconds

System Integrity Protection: enabled

Crashed Thread:        8  Dispatch queue: net.telestream.screenflow.audiowaveformqueue (QOS: UNSPECIFIED)

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000221fc6810
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x221fc6810:
    MALLOC_LARGE (reserved 000000013ca79000-00000001b8f4b000 [  1.9G] rw-/rwx SM=NUL  reserved VM address space (unallocated)
    JS JIT generated code  000053ee5dc00000-000053ee5dc01000 [    4K] ---/rwx SM=NUL  

Application Specific Information:
Performing @selector(_close:) from sender _NSThemeCloseWidget 0x600000185550

Thread 0:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib            0x00007fff7be94a1e __psynch_cvwait + 10
1   libsystem_pthread.dylib           0x00007fff7c05d589 _pthread_cond_wait + 732
2   com.apple.Foundation              0x00007fff560fbdd0 -[__NSOperationInternal _waitUntilFinished:] + 896
3   com.apple.Foundation              0x00007fff560cc845 -[NSOperationQueue waitUntilAllOperationsAreFinished] + 296
4   net.telestream.screenflow7        0x00000001003b91ab 0x100000000 + 3903915
5   net.telestream.screenflow7        0x00000001002e9a6e 0x100000000 + 3054190
6   net.telestream.screenflow7        0x000000010027d292 0x100000000 + 2609810
7   com.apple.AppKit                  0x00007fff517683ef -[NSWindowController _windowDidClose] + 199
8   com.apple.AppKit                  0x00007fff51da04de -[NSWindow _finishClosingWindow] + 687
9   com.apple.QuickLookUIFramework    0x00007fff5f197ca3 -[QLSeamlessDocumentCloser closeWindow:contentFrame:withBlock:] + 89
10  com.apple.AppKit                  0x00007fff5173fec6 -[NSWindow _close] + 360
11  com.apple.AppKit                  0x00007fff51803270 -[NSDocument _something:didSomething:soContinue:] + 17
12  com.apple.AppKit                  0x00007fff51801c33 __75-[NSDocument canCloseDocumentWithDelegate:shouldCloseSelector:contextInfo:]_block_invoke + 179
13  com.apple.AppKit                  0x00007fff51ab2332 -[NSDocument(NSDocumentSerializationAPIs) performActivityWithSynchronousWaiting:usingBlock:cancellationHandler:] + 476
14  net.telestream.screenflow7        0x00000001004c287a 0x100000000 + 4991098
15  com.apple.AppKit                  0x00007fff51801b21 -[NSDocument canCloseDocumentWithDelegate:shouldCloseSelector:contextInfo:] + 286
16  net.telestream.screenflow7        0x0000000100278ba3 0x100000000 + 2591651
17  com.apple.AppKit                  0x00007fff517c14cb -[NSWindow __close] + 281
18  com.apple.AppKit                  0x00007fff51c66a43 -[NSApplication(NSResponder) sendAction:to:from:] + 312
19  com.apple.AppKit                  0x00007fff5170c53f -[NSControl sendAction:to:] + 86
20  com.apple.AppKit                  0x00007fff5170c467 __26-[NSCell _sendActionFrom:]_block_invoke + 136
21  com.apple.AppKit                  0x00007fff5170c36d -[NSCell _sendActionFrom:] + 183
22  com.apple.AppKit                  0x00007fff5174d688 -[NSButtonCell _sendActionFrom:] + 97
23  com.apple.AppKit                  0x00007fff5170abd6 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 2438
24  com.apple.AppKit                  0x00007fff5174d3cf -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 777
25  com.apple.AppKit                  0x00007fff51709670 -[NSControl mouseDown:] + 965

20replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Elliot Temple said:
    Crashed Thread:        8  Dispatch queue:

     Thread 8 would indicate info about the crash. 

    It's possible it's a settings issue. Use the following settings as a test. It's possible certain screen sizes and scaling result in "illegal" dimensions.


  • Elliot Temple said:
    1.7tb free on external HD (where the 21gb screenflow project file is saved)

     USB2 drives can be a problem. Make sure you're using USB3 or Thunderbolt.

  • It's USB 3.


    Screenflow crashed when I tried to export with the settings you suggest, before the export started. I think it crashes whenever it calculates the waveforms for the last 30min of the video. Deleting waveform caches seems to give me more time with the project open before it crashes. Is there a way to disable waveform calculations and other UI stuff like that which is automatically generated when I leave the project open over time? I can also batch export it without opening the project file, but then the automatic settings from your screenshot aren't available (and i've tried that with my settings and it crashed).


    i attached the crash report for today's export attempt and what I think is the crash report I previously pasted part of (i have 20 crash reports from this issue, so i found the one with the same Date/Time)


    EDIT: Also, btw, I managed to delete the last 30min of the video and then export the first 1hr 45min successfully. So at least I have most of the content :). (I have a separate project file for that, and did the test today with the full video.)

  • Elliot Temple You can disable waveform. Give that a try.
    I'm thinking that the issue might be memory/RAM. Perhaps waveform and related are filling up RAM.


  • Great, disabling the waveforms and thumbnails seems to have prevented a quick crash. I tried the export and it began exporting. But it crashed a while (maybe 5 or 10 minutes). Crash log is attached.


    I don't think it's a RAM issue. I have 32gb, I'm not seeing signs of running out of RAM in other apps or in Activity Monitor, and I've worked with videos this size before without problems. I suspect some of the recording data is corrupted.

  • Elliot Temple Thanks for testing. 
    Try one more thing. Create a New User Admin account. That will give you User and ScreenFlow Preferences in that account. Reboot and log into that account and try exporting the project from that account.

  • Elliot Temple Pending the results of that test, you can try creating a new blank document and copying the .scc file into that document. Save the new document. Quit the old document if it's open. Try exporting.

  • I made a blank project and disabled waveforms and thumbnails. did show package contents on the existing project and found the .scc file in the media folder. dragged that from finder into the media library in the new project. then dragged the mic recording to the timeline and exported with your suggested settings. crashed after a few minutes of exporting.


    tried again with just the screen recording, no mic. the export completed! however, the video is broken. for the last 27 minutes, the screen is frozen except that the mouse cursor moves. nothing else changes, including the system clock is stuck at 3:09pm.


    i can try the new user account later.

  • i exported just the mic with the new user account and it still crashed after a few minutes.

  • Elliot Temple It might be possible the .scc file is corrupt given the last 27 minutes were frozen. Try exporting in two parts.

  • As mentioned, I was able to export the first 1.75hrs without the ending.


    Are there any known issues that cause corrupt files? Anything to do to prevent future videos from being corrupt? Any way to possibly uncorrupt it and get a working video? (In this case, most of the value to me in the last 27min is in the mic recording, and the video doesn't matter that much.)

  • Elliot Temple It's always possible that some momentary background task controlled by another app, took priority over ScreenFlow's recording. A momentary drive issue would also be possible. We haven't seen any ongoing duration based issues. For example, generally I would not use any virus checkers or security software but that's just my personal opinion.

  • in general, for momentary issues, do you just get a little glitch in the video or audio, but you can still export the whole thing and the rest works fine, before and after?

  • Elliot Temple It depends on the cause and what happens to the .scc file. Try just an export of the last 27 minutes and see what happens.

  • OK I tried to export the last 15 minutes but it crashed before I could even start the export. Screenflow tends to crash whenever I put the playhead (whatever the current spot in the video is called) anywhere in the last 30min of the video. So when I went to select a range towards the end, the playhead went there and it crashed after a few seconds.

  • Elliot Temple At least that may indicate where the file went corrupted.

  • Does anyone have any updates On this. I’m having the same issue 

  • Steve Begg Sorry you're having an issue but if you'd like help you must report the details. Otherwise there's no way to know if you're actually having the same issue. There are many factors that can result in this.

  • CraigS I have been using SF for years with out an issue. Upgraded to SF8 two weeks ago and now everything has gone to ****. I am operating off a MBP (16gb men, 3.3GHZ I7). I have tried everything even installed a new version of SF8 on another clean machine and it does the same thing. The problem is that the software hangs and needs to be force quit to close. I am about to loose a $70,000 project all because of the upgrade to v8. I have been receiving the odd email from support but nothing to make me think that the support is outstanding. I started work on this problem this morning at 3am. At 6:30am I recorded my frustration and sent it to Abdul in support pleading for help and have got - nothing. To solve the problem I purchased Camtasia today to re-record some of the modules which is not what I want to do. Can you please help

  • Steve Begg Update to ScreenFlow 8.1. We fixed many issues. Make sure you're on macOS 10.13.6. You may want to hold off on Mojave if you haven't updated to it yet. Given the importance of your clients you may want to get Premium Support if you don't already have it.

Like Follow
  • 3 yrs agoLast active
  • 20Replies
  • 1320Views
  • 3 Following