1

Screenflow no longer recording iPhone screen (iOS 11)

Screenflow is no longer recording my iphone screen, though the iphone does appear as available and is selected.  I just upgraded to Screenflow 7 hoping this would solve the problem but it did not.

The iPhone is running iOS 11.0.2

The Mac is running MacOS Sierra 10.12.3

Is this a known issue with iOS 11? I know it now allows you to record your iPhone screen from Control Center, but it doesn't show finger taps so I need to continue to use Screenflow.

45replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Please test in Quicktime X since ScreenFlow uses the OS system for its iOS recording feature.

    I'd recommend you update to 10.12.6 first though given the OS's impact on this feature.

    I can record with my iPhone 7 iOS 11.0.2 in ScreenFlow 7.1 so it does work. My most recent tests are with 10.13 but it should work in 10.12.6 as well. Please test in Quicktime X though.

    Reply Like
  • I'm having same issue.

    Mac OS 10.12.6

    iOS 11.0.2

    It does seem to be a quicktime issue as I'm not able to record the iPhone in Quicktime. when I select a new screen recording, it doesn't show the iPhone as screen option, but does show it as a microphone option. When i record, and then end the recording it says unable to record or something like that. I've re-booted phone and computer.

    Reply Like
  • Steven Miori Try Reset iOS Settings > Network and see if that has any impact.

    Also the iPhone model may be a factor so do post the that information.

    Reply Like
  • I fixed it! Turning off my bluetooth on my iPhone (7+) made it work again. so weird. 

    Reply Like
  • Steven Miori Interesting observation. Glad you got it working.

    Reply Like
  • I have exactly the same issue and I'm running the latest versions fully updated at the time of this posting. 

    1 ) iPhone 6s plus with iOS 11.1

    2)  macOS HighSierra 10.13.1

    3) Screenflow 7.1.1

    Reply Like
  • macscreen my resolution was turning off Bluetooth on my iPhone

    Reply Like
  • Steven Miori My resolution was resetting the network settings 🙂

    Reply Like
  • macscreen Glad you caught and fixed the issue. Sometimes an iOS update does some things which require things like Network settings to be reset. Granted there's no easy way to know this but reseting Network settings is a good troubleshooting technique to remember. One good way to confirm the issue is to see if Quicktime Player can see the device. If it can't then it's usually a device settings issue.

    Reply Like
  • CraigS Yes, I'm glad and thankful to the community for providing nice suggestions, since it was pretty counter-intuitive that network settings of the iOS device were causing the problem with recording though I changed cables, restarted all the devices ... but finally found the solution here and it was as simple as resetting the network settings :) so I'm happy to be here on this forum and feel in future issues will be solved even earlier :) 

    Reply Like
  • macscreen said:
    it was pretty counter-intuitive that network settings of the iOS device were causing the problem

     Absolutely which is why these issues can be frustrating. There's no reason to thing this would impact recording.

    It's kinda like finding out that you need to open and close the refrigerator to turn on the living room lights. 😲

    Reply Like 1
  • Hey guys, pleased to read this thread as I'm having similar-ish problems recording.

    Screenflow 6.2.2, High Sierra, IOS 11.1.2 - iPhone 6s (and iPhone 6+)

    SF sees and records the home screen but not any of the subsequent changes, ie if I open an app.

    I've had the audio from the iPhone recorded (i.e. if playing a game) but nothing changes on the screen recording.

    Also, stranger still, the length of the clip (e.g. 10 seconds, 18 seconds, 2 minutes etc._ is not reflected in the bars on the desktop app of SF. For example, it may show the two bars (audio and screen clip) are 25 hours long in some instances. I know for sure I've not left the iPhone recording ;-)

     

    Here's what I've done to try to solve...

    1) Reset Network Settings

    2) Tried turning Bluetooth off

    3) Hard reset both iphones/mac

     

    All to no avail. Frustratingly, Quicktime seems to record both audio and screen (full screen recording, no delays, no 'sticking on the lock screen') with no problems.

    More irritating is the iPhone seemed to record fine for the first time, and then all these challenges.

     

    I want to upgrade to 7 but would like this resolving in 6 first so I'm not wasting money upgrading to no avail.

     

    Any ideas gratefully received, 


    Cheers

    Reply Like
  • ... ps if it's any help, here's a 1 min video of the issues I'm facing.

    I recorded approx. 10 seconds clip on iPhone, switching screens and opening an app. 

     

    https://www.dropbox.com/s/xbs5l7v2rvqvaft/Screenflow%20iPhone%20record%20issue.mov?dl=0

    As can be seen in the video, the clip length is over a hour, and the catch of the iPhone screen shows the front screen only.

     

    Cheers for any help :-)

    Reply Like
  • Shaun Clark ScreenFlow 6.2.2 is not fully compatible with High Sierra. Please update to 6.2.3, reboot the computer, and test with a new project.

    Reply Like 1
  • CraigS thanks for the help.

    How do I update? I've tried 'check for updates' and I get the window to Try 7 - and the button seems to just be for downloading ScreenFlow 7.

    In honesty, I did plan on upgrading, but I didn't want to have to do it to resolve this issue. I've checked on the site and there doesn't seem to be option to download 6.2.3 that I can see (but perhaps it's me of course...)

    Reply Like
  • Shaun Clark On this linked page go to Previous Versions on the top and you'll see 6.2.3.

    Reply Like
  • iOS 11, Screenflow Version 7.1.1 (29981), Mac OS 10.13 

    iPhone was not available to record. Downloaded 6.2.3. iOS available on this version. Relaunched V7 and iPhone was now available.

    Reply Like
  • Update...

    The above fix did NOT work on my 2015 13" MacBook Pro. It worked on my old 2012 MBA running 10.13.1.

    Also, on the 2015 MacBook every time I click the "Record Computer Audio" checkbox SF prompts me to install the audio driver. I install it and it comes back the next time I check the box. This behavior is not happening on the MacBook Air.

    Looks like you guys have a bug.

    Reply Like
  • jim arnold I'm sorry but I'm a bit confused by your last post. 
    If ScreenFlow is behaving differently on two different computers that wouldn't likely be a bug. It's more likely a system specific issue.

    ScreenFlow certainly records iPhone and iPad screens so there are other possible issues. Always test iOS screen recording in Quicktime X first (takes ScreenFlow out of the equation). 

    Regarding the ScreenFlow Audio Driver, macOS 10.13.x requires that you go to System Preferences, Security & Privacy and select Allow as per our FAQ. This is a change by Apple and there newly implemented "SIP" security. 
     

    Reply Like
  • For whatever reason Screenflow can now capture video from my iPhone. Previous to that I tested QT X and it worked there too. But I still get a prompt to install software  every time I click the "Record Computer Audio" checkbox. 

    Reply Like
  • jim arnold said:
    But I still get a prompt to install software  every time I click the "Record Computer Audio" checkbox. 

     Please read the FAQ I linked to and follow the instructions.

    Reply Like
  • I do not have a notice to allow for the Universal Audio from being blocked from loading on the Security & Privacy pref page. Another weird thing I've noticed; Every time I start SF recording my from iPhone, the time on the iPhone sets to 9:41 AM --every time. The correct time returns when I quit SF.

    Reply Like
  • jim arnold said:
    Another weird thing I've noticed; Every time I start SF recording my from iPhone, the time on the iPhone sets to 9:41 AM

     Check to make sure Quicktime X doesn't do the same. I've seen that as well in both Quicktime X and ScreenFlow so that would likely be an OS issue.

    Currently with iOS 11.2 and macOS 10.13.2 I'm seeing the correct time.

    Reply Like
  • jim arnold 
    Make sure you are in an Admin account (MUST be an Admin account)
    Go into ScreenFlow Preferences Advance
    Also open System Preferences Security & Privacy at the same time

     

     

    Uninstall Computer Audio Driver
    Quit ScreenFlow
    Start Screenflow
    Go to ScreenFlow Preferences Advanced
    Reinstall the Audio Driver
    Tell me what happens.

    If ScreenFlow Preferences says Install Driver just go right to that step and tell me what happens. 

    Reply Like
  • jim arnold If the driver doesn't install you should see

     

    Reply Like
Like1 Follow
  • 1 Likes
  • 4 mths agoLast active
  • 45Replies
  • 2184Views
  • 12 Following