0

Strange behavior when recording audio

Hey guys,

I am new in Screenflow and I try to figure out how to record with my microphone the best way.

I am wondering about the behavior when I record the microphone via my audio interface "Focusrite Saffire 6 USB", which has two inputs. In the recording settings at the beginning I only check the channel 1, where my microphone is plugged!

When I record without camera ("Test_without_webcam.screenflow"), the resulting Screenflow file has two layers: One desktop recording layer and one audio recording layer.

So now, when I record with camera ("Test_with_webcam.screenflow"), the resulting Screenflow file has two layers: One desktop layer, one camera layer (which includes the recorded microphone)? Why isn't there another third layer for the microphone??

But the strange behavior is even more:

After stopping recording, Screenflow opens automatically and shows me the layers mentioned above.. When I hit play, everything sounds fine.. I can here only the microphone.. But: When I close the file and reopen it, I can here buzzing of the second channel of my audio interface.. So, it seams to be recorded as well..
I only can fix that to get rid of the buzzing by right clicking on the camera (or audio) layer > extract audio > and then select channel 1. And then I have to mute the original layer where the sounds came from..

Thank you for your help!

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    ScreenFlow combing webcam and USB input as a single device. You can always Detach Audio but the assumption is that it's sync sound.

    In the Configure Recording pop up next to Record Audio From there's a Gear icon which will give you individual source channel control (level and pan).

    ScreenFlow itself wouldn't do anything to cause buzzing since USB audio input is digital.

    You may want to test your Focusrite in Garageband. 

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view
    Armin said:
    I can here only the microphone.. But: When I close the file and reopen it, I can here buzzing of the second channel of my audio interface.. So, it seams to be recorded as well..

    It's not clear what you're describing. If it sounds good immediately after recording then the recording is good. Perhaps there's a monitoring issue but it's not clear what you're describing.  

    Like
    • Armin
    • Armin
    • 3 yrs ago
    • Reported - view

    Hey CraigS ,

    take a look at my video. I hope that explains what I mean.

    Thanks for your help!

    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    Armin ScreenFlow 8.2.2?
    I can certainly hear the difference.
    Can you link to the document so I can download and look at it on my system? Zip it inside a folder so all the components are intact.

    Can you try the same thing with a USB mic or even webcam audio?
    The issue might be specific to the interface.

    Also I may want to see your Configure Recording window and the Gear icon so I can see what's coming in.


    There's noting about saving and opening the file that should impact the recording. Saving just moves the files from the temp location to the document. It's possible the sound is recorded in but not obvious until after saved for some reason.

    How are you monitoring the sound? In some cases it might impact recording.

    Like
Like Follow
  • 3 yrs agoLast active
  • 4Replies
  • 43Views
  • 2 Following