0

Audio output lost when recording with ScreenFlow

Issue Summary:
Configuration:

  • 2021 MacBook Pro M1 Pro - Monterey 12.1
  • ScreenFlow 10.0.04
  • Virtual Input Device (using Loopback) - Rougue Amoeba
  • Master Volume control (Using SoundSource) - Both apps are from Rogue Amoeba
  • Helix Audio Interface (Line6), XLR connected to studio monitors


Prior to starting screenflow, everything works fine, I can control master volume of my audio interface. ..etc

I start and configure Screenflow to capture/record the Virtual Input Device (which includes my audio interface and a USB mic) and my screen.

When I press record. I lose the sound (Can't monitor) and Screenflow records both the sound and video. I have no control over the master volume or any sound.

I stop the recording and press play and I get sound and video. There is no audio output monitoring when recording.

. I've also contacted Rouge Amoeba support as well but it happens when I specifically use Screenflow record function.

Any guidance would be greatly appreciated

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Shannon
    • Shannon
    • 7 mths ago
    • Reported - view

    I have this exact same issue, but happens when I'm trying to screen record a Zoom meeting. The sound works perfectly fine before I begin the screen recording, and then, once I start, I can't hear anything, yet when I playback the recording you can hear the sound just fine. I have the latest version of Screenflow, and I select 'Telestream audio' in both Zoom and on my own audio. How can I still HEAR a Zoom meeting and record it with sound at the same time???

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 7 mths ago
    • Reported - view
    Mark Levy said:
    lose the sound (Can't monitor) and Screenflow records both the sound and video. I have no control over the master volume or any sound.

     You may need to create an aggregate device in Apple's Audio Midi Setup. When ScreenFlow does its own "hijack" of the audio it then passes the audio out to whatever you have set up to monitor. It may not do that when using another virtual input. 

    Mark Levy said:
    but it happens when I specifically use Screenflow record function

     Probably because ScreenFlow has its own driver Telestream Audio Capture which is a system sound "hijack" utility.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 7 mths ago
    • Reported - view
    Shannon said:
    I have this exact same issue,

     Actually not because you're using our driver not a third party. Please make sure you're using ScreenFlow 10. Make sure you're monitoring ScreenFlow and not Zoom. Zoom "Speakers" is being sent to ScreenFlow and not the monitoring system. To test monitoring use a hard-wired connection such as speakers or headphones with a standard headphone jack (not Bluetooth)

    Like
Like Follow
  • 7 mths agoLast active
  • 3Replies
  • 23Views
  • 4 Following