0

NDI 5

I have installed the NDI Tools 5 from Newtek on the Wirecast Gear 420. Now the NDI output no longer works from Wirecast. What could be the reason? Is there a workaround?

58replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Jean-Pierre Kousz
    • Computer scientist / producer live streams
    • JeanPierre_Kousz
    • 1 yr ago
    • Reported - view
    CraigS said:
    Reset Preferences button

     Even after pressing the button "Reset Preferences" nothing has changed. NDI output still does not work.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz Thanks. That lets us know the issue is not corrupt preferences.
      When sending the Report make sure you used Create Support Ticket (unless you linked to an already existing support ticket). With that, you may be able to ask for Team Viewer so the Gear technician can check your system remotely.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS When do you think someone will contact me?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz If you filled out the form and received a case number, post your case number here and I'll track it for you.

      I do know we've installed NDI 5 Tools on one of our own Gear 420 units and have confirmed that Tools has no impact on Wirecast Pro 14.2.1 NDI Out. We also turned Firewall off on our unit and tested and confirmed NDI Out works (as it should when no ports are blocked). So we may be doing some tests on our own unit so we can compare our settings to yours when they make contact.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

       CraigS I filled out the form and unfortunately did not receive a case number.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz Please do it again ASAP. It's the only way to assure you'll be scheduled.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS I have filled out the form again. I have also purchased GearCare for the system. 

      Telestream Case #00836847

      I hope that helps.

      Like
  • Hi Jean-Pierre. To clarify, is it just the NDI output from Wirecast that you are unable to view? Are you able to view any other NDI signals generated by applications on the Wirecast Gear unit? For example if you ran the NDI Test Patterns application from the NDI 5 toolset are you able to view the Test Patterns in NDI Studio Monitor or Wirecast as a "Network->NDI Source"?
     

    Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      Robert P Hi Robert

      Yes, everything works fine. I actually use NDI a lot. But now it just
      doesn't work with Wirecast. Namely, only NDI output doesn't work
      anymore.

      I already made a video for GraigS (on the forum).

      Look:
      https://vimeo.com/577895673/d9545e90dd

      The system now also works with many sources.
      You are welcome to just take a quick view on it!

      I had sent the access data by mail to support!
      jpk

      Like
    • Jean-Pierre Kousz
    • Computer scientist / producer live streams
    • JeanPierre_Kousz
    • 1 yr ago
    • Reported - view

    Robert: Should I reboot the system and then start Teamviewer again?

    I had also already uninstalled the tools and Wirecast, and only Wirecast reinstalled again, even then it does not work!

    Like
    • Jean-Pierre Kousz If you don't mind, please try reinstalling NDI 4 Tools. I've sent you a download link for it through the support case if needed.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      Robert P Tools 4 installed. Rebooted, unfortunately still no NDI out with Wirecast!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz 
      It seems as if there's a system setting impacting Wirecast NDI specifically.

      With Wirecast NDI Out running Wirecast should see its ow Live Output as a source like this.
       

      As your video shows, your system is certainly seeing other sources but not Wirecast.
       

       

      Yet apparently this worked for you up until recently (changed around the time you installed NDI 5 Tools although, given the above and roll back to NDI 4 Tools, that seems to be only a correlate but not the cause.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS And now what? How to solve it?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz 
      Let's see if NDI is actually sending (encoding an output).

      In a New Blank Document with NDI Out OFF you should see a very low App CPU (click on it to toggle it from System to App as that will make sure nothing else is being checked.

       

       

      Then set NDI out to 1080p60 (to generate the most pronounced difference and see if the stats change.

      As you can see it's now showing 60fps and (for me) 8% App CPU so NDI is encoding even if it's just "blanK" content 0 kbps.

       

      If you see that it would mean Wirecast is at least encoding the NDI Out. If it sits at a lower App CPU and no frame rate or kbps then that will let us know the encoding itself isn't happening. 

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS NDI out off: 1% / NDI out on: 1%
      So NDI output does not work ...

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz 

      Jean-Pierre Kousz said:
      So NDI output does not work ...

       Thanks. That could be a big clue. Investigating.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS It seems to be a big mystery!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz our detectives are hard at work.

      If you're willing, can you roll back to Wirecast 14.1.1?
      At least that would confirm it's recent Wirecast and not a system issue itself.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS Unfortunately, it does not work with the previous version either.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Jean-Pierre Kousz Since the issue seems specific to Output, we'd like you to check the other Output finctions.

      If you enable Wirecast Virtual Camera Out does it work (again you will see numbers reflecting use in the lower right Wirecast stats area) and will it show in Zoom as a working source for example.

      If you have a Blackmagic Video Out device is that working?

      Please post back those results and we may have something else for you to try.

      Like
      • Jean-Pierre Kousz
      • Computer scientist / producer live streams
      • JeanPierre_Kousz
      • 1 yr ago
      • Reported - view

      CraigS But now i see also that ...

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    Jean-Pierre Kousz said:
    it does not work with the previous version either.

     Thanks for confirming. Since it's not specific to a version of Wirecast or NDI perhaps something is preventing Wirecast from encoding out NDI. We'll be discussing this with the developers and may come back with some tests or thoughts about this.

    Like 1
    • Jean-Pierre Kousz
    • Computer scientist / producer live streams
    • JeanPierre_Kousz
    • 1 yr ago
    • Reported - view
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    Jean-Pierre Kousz said:
    But now i see also that ...

     I'm not sure what you're showing here. I see test signal and Video Inputs.

    Is it the Rendezvous connection error?

    Like
Like
  • 1 yr agoLast active
  • 58Replies closed
  • 183Views
  • 3 Following