0

Runtime Error Detected

I have a video layer (it's a quicktime movie file) with a video effect applied for the duration, where the scale is being adjusted from the start to finish.

Now every time I click on the clip I get this error:

ScreenFlow has encountered a runtime error that can affect its ability to continue operating.  Please save your work and relaunch the application.  If the issue persists, please contact technical support and quote the message:

 

-[NSNull isEqualToNumber:]: unrecognized selector sent to instance 0x1eb378340

I have quit and tried again, not sure how to proceed.  The clip will play, but I cannot make any changes to it.

ScreenFlow 10.0.6, macOS 12.12.1, 16" MacBookPro M1Max, 32GB, 2TB.

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Mike BW
    • Mike_BW
    • 1 mth ago
    • Reported - view

    Update- I was able to somehow select the Video Action (effect) on that layer and then delete it.

    However, now I am attempting to again add a Video Action to a different layer, this time a Nest with a separate quicktime movie file, and I immediately get this error, as soon as I click the +Action button, and then again whenever I click on the video action:
     

    ScreenFlow has encountered a runtime error that can affect its ability to continue operating.  Please save your work and relaunch the application.  If the issue persists, please contact technical support and quote the message:

     

    Cannot update for observer <SCAnnotationsInspectorController 0x11dee4d20> for the key path "selections.AnnotationsAction" from <SCSelectionManager 0x60000360cd80>, most likely because the value for the key "selections" has changed without an appropriate KVO notification being sent. Check the KVO-compliance of the SCSelectionManager class.

    Is there anything I can do to avoid these runtime errors?

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW Sorry about that. 
      We'd need two or three things from you ASAP for us to work on the fix.

      1. Please attach the document or create a simple document that results in the same runtime error. Either attach to the forum or send a dropbox or similar link to me using Forum Private Message System.
      2. Create a diagnostics file by holding the Shift key and going to the Help menu and selected Gather Support Diagnostics and the Gather button and again either attach here or use Forum Private Message System
      3. If possible make a screen recording of you going through the steps and causing the issue and again either attach or send via Forum Private Message. This will help the developers reproduce the steps using your document.


      It may be related to the Quicktime Movie so we'd need to know how it was created and the codec (it might be related to codec or GOP structure). Files from Zoom for example may result in some odd issues. 
       

      Like
      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS Private Message sent.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW There seems to be a number of files missing. I was able to cause the runtime error though. Please watch my attached video to ensure I see something similar to what you're experiencing.
       

      Started investigation FLOW-11556 on runtime error

      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS Not sure why the files are missing as they should be saved within the .screenflow file, right?

      Regardless, yes that is what I am doing to generate the error.  The code at the end is different though.

      I should point out that I was able to continue working in spite of these errors and get the project done.  Not sure if it's worth it for you to continue pursuing the cause of this or not.  Thanks for your efforts.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW I was able to continue despite the runtime error as well so this might be close enough for the developers to work with. The same clip caused the runtime error.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 7 days ago
      • Reported - view

      Mike BW We believe we have the runtime error fixed and should have the fix in an upcoming update.

      Like
      • Mike BW
      • Mike_BW
      • 7 days ago
      • Reported - view

      CraigS Good news! Thanks for the update. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 7 days ago
      • Reported - view

      Mike BW 👍

      Like
Like Follow
  • 7 days agoLast active
  • 9Replies
  • 13Views
  • 2 Following