Terrible motion blur. . .

just upgraded from v6.0.8 to 8.0 and am VERY sorry that i did.

 

Tried 8.0 then 8.1, than 8.2 -- all the v8 iterations have the same terrible motion blur -- fast motion causes "tearing"  in both the preview and the output monitor -- recorded video has moving body parts blurred with rainbow auras.

we are basically broadcasting "talking heads" but any motion by the speaker causes moving body parts to break into "slices" for lack of a better term. 

we are using Matrox VS4 card for ingest from two cameras -- the problem occurs from either camera.

Full equipment list:

I7-5820K

32GB RAM

256GB M.2 SSD

NVIDIA GTX960

Matrox VS4 SDI

There is no scaling.  We have tried changing the frame rate from 30 to 50 to 60 with zero effect on the problem.  The signal coming from both cameras is 1080i.

 

Running v6.0.8 on this same equipment had perfect output. 

any help would be appreciated.

thanks

tim

21replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Can you send a video example or screenshots?

    Reply Like
  • Since the Matrox card is used in our Wirecast Gear successfully I suspect there may be an issue with your config. As Matthew mentions, a screenshot would help.
    Keep in mind you're just seeing a scaled representation in Preview and Live Area. 
    You should do a local recording to see what's actually happening to the image. If that looks fine, the issue might be related to the GPU (for example) displaying the image.

    In order to best optimize performance, Preview will often show at a lower frame rate than Live area.

    Reply Like
  • thanks for the suggestions guys -- 

    Matthew:

    yes, if i can get a snippet attached to this thread i will do it tomorrow when i am on site.

     

    To CraigS.:

    2 things:  1) i mentioned that the local recording is terrible i will add a snippet tomorrow if possible.  and 2) this config is the same used on the 6.0.8.  Literally the same -- the upgrade opened and used the same files.

    to address the possibility of a problem with the "upgraded" config files, i created some new shots and layers to see of that was a solution.  It made no difference.

    Reply Like
  • tim morgan There's no changes between 6.0.8 and 8.x that would cause motion blur issues. There's been no other reports like that. Perhaps you're not describing the problem in a way I understand. 

    tim morgan said:
    to address the possibility of a problem with the "upgraded" config files, i created some new shots and layers to see of that was a solution.  It made no difference.

     You would need to create an entirely new document. Many features have changed since 6.0.8 and it's possible in some cases a document created in a previous version can have issues.

    Reply Like
  • finally got to a place where I can access the recording. . .

    Reply Like
  • this is a short recording -- notice the edges of the lapels (basically any edge) and the hands

    Reply Like
  • here is a second short video.  as noted by CraigS, I created an entirely new document and shot.  Notice about the 2 - 6 second range where the speaker leans back and forth a couple of times.  His entire body and face lose focus during the motion.  also attached is the settings for the recording.

    Reply Like
  • tim morgan I’m seeing a lot of interlacing in that video. Check that you’re de-interlacing your input or confirm that you’re using the highest frame rate on your camera. 

    Reply Like
  • Sorry… to add to that last point, highest frame rate you can (60 if possible) and your capture card input too. It looks like the camera / capture card is causing major interlacing within the feed and you’ve likely just not disabled the deinterlace source within the shot config… sorry… I’m at home right now so I can’t provide a screenshot of the deinterlace option. But it is in the last tab of the config inspector panel.

    Reply Like
  • will check, but if memory serves the camera outputs 1080i and we are running the highest framerate, i cannot recall the deinterlacing config on either the input or within the shot.  will check as soon as possible.

    Reply Like
  • tim morgan based on your card specs, you’re probably running 1080i59.94 coming in. You’ll need to deinterlace that down to a 30 to get rid of that. If you’re camera can run in 1080p60, your Matrox is spec’d to use that which would give you a better quality input quality altogether, or even maintain 60fps throughout (Wirecast preferences performance tab) if you can, giving a higher quality throughput throughout. A bit more on the rendering GPU side but that GTX960 should be able to breeze through that without issue.

    Reply Like
  • tim morgan In short I agree with Matthew. There's nothing in 8 that causes blur. Look at interlacing and camera settings. 

    Reply Like 1
  • CraigS Matthew Potter  seems to have solved the issue.  It is interesting that v6 gave us a good monitor and outstanding output without deinterlaceing  Will do more testing, but the improvement is dramatic.

     

    thanks for your patience and help.

     

    tim

    Reply Like 1
  • this is a sample of video after activating the deinterlace setting.  there is still some motion blur, but much less obnoxious.  Any other suggestions?  our current setting is keyframe every 240, would there be any advantage to closer keyframes? or is that another topic.

    thanks again,

     

    tim

    Reply Like
  • tim morgan What camera do you have? Can it do 1080p60? I’ve got a new Sony PXW-X70 that I can set an internal frame rate to 30, 60, 90, and even 120… the output is the same via SDI or HDMI but the signal is drastically better with each subsequent jump. It seems like you have really good lighting in the shot, if you can raise the frame rate in the camera higher with a little gain added to compensate then switch to a full progressive 60fps input instead of interlaced, that shot would likely be far better than you’ve seen before.

    Reply Like
  • tim morgan Good to hear you're getting improved results.

    One thing to be mindful of is that some cameras can send either Interlaced or PsF. The latter is progressive frames split so they can sent over interlace. This can be a factor. For testing I would do a local recording using MJPEG MOV. This eliminates any  potential GOP structure (b-frames) and bit rate settings having an impact.

    Reply Like
  • Matthew Potter I have a Sony PXW-X70 as well. Although you mention 120fps so I'm wondering if you have the new V90. The X70 can send 1080p (which may be PsF).

    Reply Like
  • CraigS I have no idea… I’ll check tomorrow. I know the thing can send 1080p but working with the mini recorders, they can only take in 1080p30 or i60 standards… (and the various ones around that) not the p60 or PsF60… Looking at when I replace my MacBook Pro… I’m likely going to need to invest into something like the Io 4K or something. Granted, I’m still waiting to see the results of the blurry video bug I’ve got listed for Wirecast. I’ll stick to 30fps for now if I can get clearer, cleaner video.

    Reply Like
  • Matthew Potter I believe Magewell and Epiphan have HDMI to USB3 dongles that can handle 1080p60, even UHD (4K). Alternatively you could get a Sonnet Echo PCIe to Thunderbolt 3 chassis which can handle a variety of 4 input PCIe cards, some of which can handle 1080p60.

    Reply Like 1
  • CraigS Matthew

    I am certain neither camera can output p60.  I will check on the PsF, and test recording with the MjPEG MOV.  The primary camera is a prosumer level Canon, but I cannot remember the model number.  The secondary camera is a consumer model Vixia 100 or 200. our next upgrade, sometime in the misty future, will probably be a 4k model, but that is an uncertainty.  I am happy with the current results, post "deinterlace" but will continue to tinker.  

    I do appreciate your help and service to the Wirecast community.

    Updates as i can.

    Reply Like
  • tim morgan I've been told the newer Vixias only output progressive. The older ones are interlace and maybe PsF. A lot of the prosumer cameras support 30p which may output PsF in some cases. Keep in mind Output is often a separate setting than recording.

    Reply Like
reply to topic
Like Follow
  • 3 days agoLast active
  • 21Replies
  • 161Views
  • 3 Following