Can't install Wirecast Go on iPhone 5S with iOS 10.3.3

Am I missing something here? In the description for Wirecast Go, it says it requires iOS 10.3 and iPhone 5s compatible... yet I get the error 'Cannot download: This app is not compatible with your device.'

 

Any ideas?

Thanks

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • It's possible Wirecast Go 2.0.2 has a compatibility issue and the specs haven't been updated.
    Would you be willing to upgrade to iOS 11.1.1 and test?

    Reply Like
  • Do fill out the form and report this issue though as we may need to update the specs.

    Wirecast Go Support Form

    Reply Like
  • I've filled out the form - but I don't really want to upgrade my phone.. so in the meantime I'll just live without it I guess.

    Reply Like
  • Tim Collins Thanks for reporting. On our end we may need to see whether it's iOS 10.3.x  at issue or something about the iPhone 5S. 

    Reply Like
reply to topic
Like Follow
  • 1 mth agoLast active
  • 4Replies
  • 50Views
  • 2 Following