Black screen when playing the video file

Hello,

I have an issue with playing a media file.

I imported this mp4 file (*) to Wirecast and started playing it. However the screen is just black in Live and Preview areas and only audio comes out. The progress indicator progresses and everything seems to be working fine except the visual. I tested with several resolutions (e.g. 720p, 1080p, 4K) but am having the same problem.

My environment is as follows:

OS: Windows 2012 R2
Version: Wirecast 8.0.0 (32276) 64-bit

I'd appreciate any help with this problem.

Thanks,
Michi

(*) https://drive.google.com/open?id=0B7AbuuVydBBKV2dCYlhDS29HN28

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Wirecast 8, Windows 10, Plays back without issue.
    It may be because you're on Windows 2012 R2. You may need to download Media Pack. We don't officially support the Server versions but it can work if you download the appropriate utilities.

     

     

    Reply Like
  • CraigS 

    Thanks for the suggestion. I just tested with the following environment and am getting the same problem, although it appears server 2016 already has media pack baked in (*).

    Windows Server 2016
    - with Desktop Experience
    - with Windows Server Essentials Experience

    Any ideas what specific utilities might help?

    (*) https://docs.microsoft.com/en-us/windows-server-essentials/manage/manage-digital-media-in-windows-server-essentials
     

    Reply Like
  • Michi Yamamoto You need media specific features. This possibly.

    Reply Like
  • CraigS Thanks for the information.

    The weird thing is that in this environment the file can be played by any of the other applications such as Windows Media Player, VLC media player, or Google Chrome, but not by Wirecast.

    Reply Like
  • Michi Yamamoto Please test in our trial version of Telestream Switch application as well.

    We don't officially support the Windows Server editions for Wirecast. It does work in Windows 10 so there may still be a specific OS component missing that Wirecast depends on. 

    Reply Like
  • Hi CraigS ,

     

    I just was testing my setup with the new Wirecast 8 and I'm having the exact problem.  I had an MP4 movie (a commercial produced by one of our sponsors) in the shots, and now I get black screen with only audio coming from it.  I can open the file no problem using VLC and Quicktime, but Wirecast just gets a black screen.  This is not the case for all MP4 videos though, as I have a number that I recorded myself with my iPhone, they all still play.  I'm a bit puzzled as to why this particular video won't play.  Any suggestions? Thanks as always.

     

    -Tim

     

    Specs:

    Wirecast 8.1.1

    MacBook Pro (Sierra 10.126) 15" Mid 2014

    2.5 GHz Intel Core i7

    16 GB, 1600 MHz DDR3

    NVIDIA GeForce GT 750M 2048 MB

    Intel Iris Pro 1536 MB

    Reply Like
  • Tim Collins If you link to the file I'll test on my system. If you can, send me one of the files that you have no problem playing also and I'll analyze and compare.

    Reply Like
  • CraigS 

    Here's a link to the file that stopped working after upgrading to Wirecast 8: https://www.dropbox.com/s/rtkohoprmkox6gf/WE-StarCar-2011%20Kopie.mp4?dl=0

     

    Here's a link to a file that does work:

    https://www.dropbox.com/s/n10kyz7swp9u7ne/Disciples%20Banners.mp4?dl=0

     

    Thanks!

    Reply Like
  • Tim Collins Confirmed. Tested on my Late 2013 15" MBP which only has integrated  GPU so it's not related to that. Wirecast 8.1.1 macOS 10.12.6

     

    Reply Like
  • Tim Collins Nothing too unusual about the problem file.
    PAL 25fps, H.264 High Profile Level 3.1.
    GOP structure is only I and P frames, no B frames. But that's not uncommon to with some recording devices. 

     

     

    and the good file
    30FPS, H.264 Main Profile Level 3.1. GOP Structure is IBP.
     

    Both play in Quicktime X (and our Telestream Switch QC tool which I took these screen shots from.

    Reply Like
  • Tim Collins Thanks for providing the files.
    Do please fill out the form, note that I confirmed the issue specific to Wirecast and link to this forum thread so they can see my analysis of the files. You may want to include the links to your source files as well so the engineers can check further.
    Looks like we need to fix playback compatibility. It might be related to the GOP structure.

    Wirecast Support Form

    Reply Like
  • CraigS Done - thanks.

    Reply Like
  • Tim Collins You're welcome of course. You should receive a case number while we work on the file compatibility issue. You can contact us by email with case number (or we may contact you if we have some questions) as we work on this.

    Reply Like
reply to topic
Like Follow
  • 3 wk agoLast active
  • 13Replies
  • 212Views
  • 3 Following