ffmpeg generated WMV files don't load in Switch ("No usable audio or video could be found" error)

I'm having issues with WMV files that were encoded using ffmpeg not playing in Switch (both version 3.1 and 3.2).

All WMV files load in Switch with an error that says "An error occurred while trying to open the file. No usable audio or video could be found"

These same WMV files play just fine in VLC on macOS, as well as in Windows Media Player on a PC.

This is the ffmpeg command I am using to encode the WMV files:

ffmpeg -i "SOURCE_PRORES_FILE.MOV" -ss 7.0 -t 30 -mbd 2 -vf scale=1280:720 -sws_flags lanczos -q:v 3 -vcodec wmv2 -acodec wmav2 "OUTPUT_FILE.WMV"

The source ProRes file is a 1920x1080, 23.98 ProRes HQ file. 

I tried using both msmpeg4v2 as well as Windows Media 8 (WMV2) as the video codec in ffmpeg, but both result in the same error

Here's a representative sample .WMV file that results in the error:

http://d.pr/v/cUlC/5ml5N9NB

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Thanks for providing the file. It's Windows Media 8 video as you note. It opens and plays in our Flip Player (Flip4Mac) 
    I confirmed that it does not open in Switch 3.2 with the error you report.

    Please do fill out the form and include the above information and the link to the file. Note that I've confirmed that while it plays in our Flip Player it does not play in Switch.

    Switch Support Form
    We'll send you a case number and investigate compatibility with Switch.

    Reply Like
login to reply
Like Follow
  • 5 mths agoLast active
  • 1Replies
  • 135Views
  • 2 Following