0

Screenflow is recording a black screen when it should be the Display of my computer.

I'm have a problem with my screenflow. I have never had this problem, I just upgraded my Macbook to the 2020 M1 (previously I had a 2015) and I transfered everything over to this mac of 2020. However when i shot a video slide recording the video didn't capture it just captured as a black screen with the audio.

I've attached a loom video to give you guys come context. I have already confirmed the privacy setting. 

https://www.loom.com/share/cc4d25b65cdf467da764645df0541460

Let me know what would be the next steps. 

Talk soon, 

14replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view

    I'd like to help but it's not clear what version of ScreenFlow you're using. The current version is 10.0.3 and at least 9.0.7 is required for M1.
    What version of Big Sur? Ideally, it should be 11.5.2.

    I have MBP, ScreenFlow 10.0.3, macOS 11.5.2
    And my Configure Recording looks like:
     
    Which does not look like the version of ScreenFlow you're using in the Loom video.
    And the MBP display says Built-in Retina Display but yours just says Display.
    You don't have the "+" to add more recording sources so it doesn't look like you're on ScreenFlow 10.
     

    Like
    • CraigS So i've been on screenflow 8.2.3 I'm upgrading it right now to see. That's likely what happened. I'm also on Big Sur 11.5.2. 

      Like
    • Renato Antonio Fabri Oliveira Just upgraded & now I'm all set, it's working! Thank you!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Renato Antonio Fabri Oliveira You're welcome of course. 👍

      Like
    • Cam
    • Cam
    • 8 mths ago
    • Reported - view

    I'm having this same problem. Got a new Mac and installed Screenflow and now I can only record an all black screen. Screenflow Version 8.2.6 + OS version 12.0.1. I've given both Screenflow and Screenflow helper access to screensharing in settings as well.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 8 mths ago
    • Reported - view
    Cam said:
    Screenflow Version 8.2.6 + OS version 12.0.1.

     Not compatible. You need to update to ScreenFlow 10.0.3.

    Like
    • t st
    • t_st
    • 8 mths ago
    • Reported - view

    I am having the same issue. macOS 12.0.1 on Screenflow 10.0.3. I can record my whole screen if I use the tool to select the entire area, otherwise I get a black recording if I just hit record.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 8 mths ago
      • Reported - view

      t st Please update to ScreenFlow 10.0.4. You may want to update Monterey to 12.1 as well.

      Like
      • t st
      • t_st
      • 8 mths ago
      • Reported - view

      CraigS Didn't notice the available update, but same issue on 10.0.4 FYI. Won't be able to move to 12.1 for now but I will report back when I do.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 8 mths ago
      • Reported - view

      t st What's your monitoring setup?
      I have no issue selecting a region on 13" MBP M1 built in monitor with 12.1 (and 12.0.1 before it).
      If you're using an external monitor it may be impacted by how it's connected. Keep in mind ScreenFlow gets its information from the OS and certain third party setups, especially if a driver is involved, might present issues.

      Please describe in a way someone could repeat your steps on the exact same Mac and experience this issue. 

      In ScreenFlow you select the entire monitor or a region so it's not clear what you're doing. Record isn't going to record the screen if you don't do one or the other.

      Like
  • Same problem, i am recording and randomly getting black screens, VERY VERY frustrating

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 4 mths ago
    • Reported - view
    DARREL WILSON said:
    Same problem,

     keep in mind no one has posted to this thread in four months. Both ScreenFlow and macOS have been updated.

    In order to investigate your issue please first update to ScreenFlow 10.0.5 and Monterey 12.4.
    Then you need to describe your mac model and monitor configuration including how they are connected, and testing after you've updated and rebooted.
     

    Like
    • CraigS this error randomly happens. Im current mac is up to date and i am running the latest version of screenflow ( 10.0.5). I will hit record, and it works, than i hit record and it doesnt work sometimes. This only happens through the camera. I am using camlink. The error is just at random which makes me have to believe there is a technical issue here.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 4 mths ago
    • Reported - view
    DARREL WILSON said:
    . This only happens through the camera. I am using camlink.

     Perhaps it's an issue with the Camlink. The cable. A dock or hub if you're using one. These are especially possible if it's intermittent.

    Like
Like Follow
  • 4 mths agoLast active
  • 14Replies
  • 252Views
  • 5 Following