0

Sony Imaging Edge and Screenflow

Hey there,

I just installed Sony Imaging Edge software to use my Sony A7Riii as a video recording device via USB. It works in all other applications, except Screenflow (I have version 9.07).

I can see the Sony camera in the devices list, but when I select it, the screen remains blank and recording isn't possible. 

Is there a solution for this, and if there isn't, will it work when I install Screenflow 10? 

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You may want to install the trial version of ScreenFlow 10.0.2 (you can keep 9 in another folder in Applications to make sure it isn't overwritten). We have another update to 10 coming out soon which may further improve this. 

    Like
  • ScreenFlow 10.0.3 has just been released. Please install reboot and test.

    Like
  • Hey, folks! I'm having a similar issue with my Sony A7iii camera.  All other applications in macOS Big Sur can utilize the A7iii (Zoom, Microsoft Teams, and the Imaging Edge software), but Screenflow doesn't provide my Sony camera as an available option within the "configure recording" screen. 

    Some specs:

    • macOS Big Sur
    • Screenflow v. 10.0.3
    • Apple M1 Chip, 13-inch, 2020 Macbook Pro
    • All possible permissions are checked in System Preferences for both Screenflow and Screenflow Helper

    Any advice or suggestions are appreciated--thank you!

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view

      Cary Joice In our testing in 10.0.3 you may not see the camera in Preview but it should record.
       

      Cary Joice said:
      macOS Big Sur

       Please update to 11.5.1.
       

       

      Cary Joice said:
      Zoom, Microsoft Teams,

      Please test in Apple Quicktime as well.

       

      Cary Joice said:
      All possible permissions are checked in System Preferences

       Please check the Camera permissions specifically.

      Try rebooting the computer. Sometimes it takes that for the System Permissions to take.

      Example showing it does show as available and does record in 10.0.3 even though there is no preview.

       

      Like
      • Cary Joice
      • Cary_Joice
      • 5 mths ago
      • Reported - view

      CraigS Thank you! I'll check this afternoon.

      I did discover that the firmware on my A7iii needed updated, and I also updated Big Sur to 11.5.1, so I'm hoping those corrected the issue. Thank you for the quick response! I'll edit in an update when I know if it worked or not.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view

      Cary Joice Thank you for reporting that.

      Like
      • Cary Joice
      • Cary_Joice
      • 5 mths ago
      • Reported - view

      CraigS School started--so sorry for the delay!

      Update: Screenflow still does not detect the Sony A7iii as a recording device. It's not in preview, nor is it in the dropdown menu to select devices.  I've revoked permission and then given permission again.  Still no luck in getting Imaging Edge to show up as a possible camera for either Screenflow or Quicktime.  

      I'll still look around and mess with settings to see what might be the issue; any other suggestions or help is appreciated. Thanks!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view
      Cary Joice said:
      t's not in preview, nor is it in the dropdown menu to select devices.

      Are you using our webstore version of ScreenFlow or Mac App Store version?

      I notice that Sony says not Apple Silicon so I'm wondering if they just need to update their driver. That could explain why it's not working in Quicktime either.

       

      Supported OSes

      Windows10 64bit
      macOS 10.13 - 10.15, macOS 11 (Excluding Macs with Apple silicon)

      Like
      • Cary Joice
      • Cary_Joice
      • 4 mths ago
      • Reported - view

      CraigS I saw that, but I can use the camera with Imaging Edge Remote, Viewer, etc.  But, it makes sense that somethings would work and some things wouldn't, I guess.

       

      Thanks for looking that up! Whenever it does work again some day, I'll update this thread. Appreciate your help, CraigS

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 mths ago
      • Reported - view

      Cary Joice If the apps are Intel-based (use Rosetta) they will be compatible with drivers that use Rosetta. If the app is Universal or Apple Silicon specific the driver would have to also be Unisveral or Apple Silicon specific.

      Have you updated to Big Sur 11.5.2? Just in case that may make a difference.
      Try that one last thing and reboot and test. Make sure the camera is attached directly to the Thunderbolt 2 (USC-C) port and no dock.

      Like
  • CraigS  Any plans for an update that fixes the preview issue? Screenflow records from my A7 II, but not been able to control the position and the frame in the preview window before recording is not "very helpful". 

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 mths ago
      • Reported - view

      Mario Peischl We're investigating but part of the issue is how their driver is written which makes this difficult to implement.

      Like
    • CraigS Would a solution like Elgato Cam Link (instead of the clunky Sony Imaging SW) be better? 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 mths ago
      • Reported - view

      Mario Peischl Much more reliable to go through an HDMI to USB device. These days CamLink has some good competition too in a similar price range.

      Like
    • Mario Peischl CraigS  In the end I switched to the CamLink, because Sony imaging edge didn't work... The CamLink works great, also on a higher resolution. The image quality is great too (a bit better than the (overall) cheaper competition, I checked several comparison video's on YouTube). I would recommend the CamLink for sure. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 mths ago
      • 1
      • Reported - view

      Rob de Winter Thanks for reporting that.

      Like 1
Like Follow
  • 3 mths agoLast active
  • 16Replies
  • 53Views
  • 5 Following