0

Out-of-sync in Stream Web

I've noticed that there is a lot of audio delay in any stream played in stream web source.

Same stream, played in VLC, hasn't delay...

Please try you too...

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view

    Please make sure you've updated to Wirecast 14.1.1
    Please describe in more detail with a specific workflow example so we can troubleshoot.
    We actually use the same technology as VLC.
    Please explain whether you are using Web Page or Web Stream plugin since your description is not clear.
    Please understand for the fastest and most accurate troubleshooting you must describe in a way we can exactly reproduce the issue.
     

    Like
  • Hi Craig...it's simple: same url, played in VLC and in Wirecast by Web Stream plugin.

    In VLC perfect lip-sync, in Wirecast about 0.8 sec of video delay.

    Get me a perfect streaming url to try again!

    And try you too...is it possible that I have changed some settings that cause this issue?

    (Wirecast 14.1)

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Emmanuel De Donato Can you provide us the link you were using to test or another of your choosing?

      Our Web Stream plugin allows for offsets to fix sync but if it's in sync in VLC but not in Web Stream, we'd like to check that.

       

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Emmanuel De Donato Hmm, for me the link isn't working at all. 

      Can you adjust the sync in Wirecast Web Stream Audio Delay?
      The feature is there to fix sync issues.

      Like
    • CraigS Yes I can...but is strange this huge delay (about 1 second).

      Until version 13, I don't remember this issue...

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Emmanuel De Donato Just to confirm can you uninstall 14 and reinstall 13.1.3 and check again?

      BTW it's possible the latency is new because it there's improved "resiliency" to the plugin (more buffered data to ensure stable connection) but I can't say that for certain.

      You could try changing the Web Stream Properties Buffer (defaults to 0.25) and reconnect to the stream and see if that has an impact.
      The other new feature that may have an impact is Timestamps (default provided by source) so you may try changing that as well and reconnecting.

      Like
  • Hi CraigS ...excuse me for silence! I have noticed that audio delay issue is more evident in HLS stream than RTMP's... can you test this with any HLS stream available for you?

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    Emmanuel De Donato said:
    have noticed that audio delay issue is more evident in HLS stream than RTMP's.

    HLS can introduce more latency.
    Please check the settings I asked for previously and see if you can compensate or otherwise impact the results.
     

    Like
    • CraigS Yes I can! Wirecast can compensate HLS audio out-of-sync audio...but is strange that this issue doesn't happen in VLC playing same stream... Has VLC an internal sync system?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Emmanuel De Donato We should have a beta you can test very soon. We've made some improvements so test that to see if it's improved when the beta is released. That will let us know if there's more work we need to look at.

      Like 1
Like Follow
  • 1 yr agoLast active
  • 11Replies
  • 63Views
  • 2 Following