Should I be able to hear ALL guests when in the Rendevous Dashboard?

I can't seem to hear any of my guests when they've joined and I have the Rendevous Dashboard window open.  The docs and best practices say that I should be able to hear them until I close the window, then I can only hear the guests when they are added to a shot and that shot is active.

Do I have this right?  If so, then I need to continue looking into my settings because I don't hear any guests when they are in the rendevous dashboard.  It is only when I create the shot and add them that I hear them (which is what the docs say should happen if the window is closed, which it isn't).

The idea is for me to be able to monitor all guests in the session even though they are not live because I need to be able to hear if they say something off camera or want to join in the conversation.  I want to leave the dashboard window open so I can do that, but I don't hear anything.

If someone can confirm that I should hear ALL guests while in Rendevous Dashboard, then I'll keep plugging away at my settings although I don't know what else I can try.  This is on a Windows 10 laptop running an i7 processor with 16GB ram.  Wirecast Pro version 9.0.1.

Thanks for any help!

Tony

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Tony Darnell .

    Agree with your comments. Rendezvous audio is broken, and always has been.

    On OSX, rendezvous audio is sent to the default audio device, not to the device configured in wirecast. If for example you start a show with that set (by accident) to default speakers, you will get echo / feedback as soon as a guest joins.

    So then you try to change it. Bzzt. That doesn't work. Once wirecast is loaded, it ignores changes to the default system output.

    So - lets pretend you get it right. and you send output to a different output monitored by headphones. That wont give you feedback... but what if you are also doing system audio capture? Bzzt. You get an echo/reverb effect because the system audio capture also captures the rendezvous output.

    Lets pretend you are not using any system audio capture. Its still going to work. You can hear your guests, and they can hear the same thing as you. Right? Bzzt. You cannot assign a virtual mic or any other program audio output to Rendezvous to send to your guests. If you are doing any video playout - and you have a guest live, they will tend to talk over the audio in the clip - not knowing where they can or cannot talk.

    The recommendation previously from Telestream was to use Dante VIA. I purchased that... and it fixes the problems? Bzzt. When using VIA, I have been unable to hear my remote guests before they connect. But at least now I can capture system audio without the echo/reverb using VIA.

    But while we are on the topic of audio - let me share one more fact. If you're mixing audio via Wirecast virtual mixer - and have a remote Midi controller like the Akai APC40 MkII - every time you change a shot that has audio in it, the audio assignment to fader channels changes in what appears to be a totally random manner. So if you want to turn a Rendezvous guest audio up or down mid stream using the controller? Forget it. Its random. Try playing the lottery instead. Better odds.

    Yes, this has been a bit of a rant about Wirecast audio. I had been waiting for Telestream to do that spot on Audio at the Wirecast Live stream, but that got postponed for now.

    The only viable solution: Don't use Rendezvous. Its broken. Use an external mixing console, and perhaps use Skype routed via that console. Anything else just doesn't work. Sorry for being critical again Telestream team. I want this to work - but we're still a long way from the mark.

    GK

    Reply Like
  • Rendezvous audio works for me when everything is set up correctly for monitoring (and you don't use the host mic in the Shot).

    Start by making sure Wirecast is using the default audio device and test before adding any shots to eliminate a potential issue there.

    If you get echo make sure you disable Wirecast Headphones (monitor) icon.

    Keep things simple for testing (don't create shots, don't use screen capture).

    Reply Like
  • CraigS  - Yes, rendezvous works perfectly if your monitor is setup correctly, and you dont use host mic in the rendezvous input, and you dont use screen capture, and you dont actually create any shots. In that regard, it is fine as a video conference facility. But try to use it in a broadcast? All of the issues I listed have been around for a long time.

    Previously, the inability to use video from modern phones was the number one issue. Thats been resolved. Now, we'd like to have audio that works reliably:

    • With guests able to hear program audio
    • With screen capture not capturing rendezvous dashboard audio (causing echo)
    • With the ability to set (and update during broadcast) where Rendezvous Dashboard monitor audio goes to.
    • With allocation of audio to faders in USB mixer (and midi mixer) that do not randomly change every time you change active shots.

    All of the above have been captured many times before and submitted as tickets etc. I think if your product/dev team could publish their plans for these items, it would help to restore confidence in this sub-component of Wirecast. It has great potential, but until these are addressed - using Rendezvous is extremely difficult unless you mix audio externally from Wirecast.

    GK

    Reply Like
  • Greg Kuhnert As long as it's all been reported it's being investigated.

    Reply Like
  • CraigS Yes I've been doing that.  I've only setup a Rendezvous session with nothing else, connected locally from another computer and I can't hear the audio from the connected computer.  I an hear it from a Mac so that answers my initial question, I can (or at least I'm supposed to) hear all guests from the Dashboard window.  Since I had never heard anything ever, I wasn't sure.

    I've tried every audio device available to me, including the default, and things are still silent.  I even changed devices, restarted Wirecast (sometimes that helps with video devices) and tried again with no success.

    My theory is that my drivers for audio aren't compatible with Wirecast since the audio works just fine in Zoom meetings, but wirecast just isn't picking them up.

    Using Rendezvous is a dream for me now anyway since it is not very dependable (I have to figure out why some guests cannot connect - I suspect it's because they are behind a firewall since they work for NASA) but I am trying to learn how it works.

    Thanks!

    Tony

    Reply Like
  • Tony Darnell said:
    My theory is that my drivers for audio aren't compatible with Wirecast since the audio works just fine in Zoom meetings, but wirecast just isn't picking them up.

    I'd need a more detailed description because it's not clear if you're talking about input or monitoring. USB Mic as a source would work. Anything coming in from guests depends on their browser and sources being fed it and processed through the Rendezvous server going to the Dashboard. Guests hear back through the server so that's not driver related unless they're having an issue in how they're monitoring on their end.

    Reply Like
  • CraigS Yes of course, but I think it's my system.  As I said, I can hear the guests in the Rendezvous Dashboard on a mac so that answered my initial question.  Unfortunately my Macbook is old and not up to the task of streaming an entire show so I can't use it. I upgraded to a Windows 10 laptop with much better hardware (or so I thought) but the audio is silent.  I can hear the guests once I add them to a shot and monitor it, but that's not what I need.  Off camera guests need monitoring too.

    I'm sure I'll figure it out eventually.  I can't really use Rendezvous anyway, I'm sticking with capturing a Zoom meeting.

    Thanks for all the help,

    Tony

    Reply Like
  • Tony Darnell said:
    I can hear the guests once I add them to a shot and monitor it, but that's not what I need.  Off camera guests need monitoring too.

     Do check various settings. Off camera monitoring should work by default unless there's some odd situation with the computer's sound card and monitoring.

    Reply Like
  • Hi Tony Darnell 

    This last 24 hours, I got to a better place with Rendezvous, and I'll be doing more documentation on how to make it work successfully soon, but let me share a few quick points now. My requirements:

    1. I want to hear guests before being added to a shot. Wirecast does not send audio output to the audio device that is configured in Wirecast. Instead, it will send this audio to the default audio output destination in the operating system. Before loading wirecast, make sure you can just double click on say a sound file or mp4 file and hear the audio. NOTE: Any changes to output device once wirecast is loaded are ignored... so get it working before you start wirecast.
    2. I want to have a guest and screen capture (and audio capture) without guest echo. I am using Dante VIA to capture audio from VLC, which I use for playout. The built in system audio capture is incompatible with rendezvous, if you have audio from the rendezvous dashboard in #1 above active.
    3. I want my guests to hear play-out audio for any content I am playing. Again, I used Dante VIA to achieve this. But, there was a trick. I used the 16 channel audio sound card for #2, and the stereo sound card as an input for Rendezvous. But even then, there is another trick. For some reason - after starting the rendezvous session - you have to remove and re-add your inputs in Dante VIA before this works correctly.

    With the extra software, I am now 90% of where i want to be. The remaining problem is that audio level settings in Wirecast happen after Dante VIA, so remote guests will hear VLC at full volume, even if I have changed the levels. But its better than them hearing nothing.

    GK

    Reply Like
  • CraigS I’m late to this dance, but the way I route all my audio is to create a Layer for audio on let’s say Layer 4 and I put my MixPre 3 ( My Mic) and all my Rendezvous or Skype guest on that layer send it to program and it stays live. I then turn off any audio from Rendezvous or Skype guest shots that way I don’t need to worry about any audio loop or feedback. I control muting or such from the virtual mixer. My MixPre 3 is used to monitor Wirecast, with my device I can listen to my mic or just program audio. 

    Reply Like
  • George E. Kennedy, Jr - I do exactly the same using an audio layer. Otherwise, if you change shots to for example share a clip, audio for your guest drops out. But my comments still stand.

    Monitor audio for the rendezvous dashboard is not configurable to go to a specific destination in Wirecast. It uses the default system output, which is only read during wirecast initial load. If you make a mistake and send default audio to the wrong place in the OS... start a show, and then invite a rendezvous guest... you're stuffed. You cannot change that setting without restarting Wirecast... which is totally undesirable in the middle of a broadcast.

    GK

    Reply Like
  • George E. Kennedy, Jr That description might make a great tutorial if you were to do a walk through. 😉

    Reply Like
  • George E. Kennedy, Jr Do you have a single audio shot on layer 4 with all rendezvous guests and your mic input on layers within that one shot?  Just a clarification because if you add all guests plus your mic to layer four as separate shots on that layer, you can only use one audio shot at a time.  That would work for me, not sure why I didn't think of that.  In that situation, all guests can be heard regardless of the shots that are active above it.

    Greg Kuhnert Yes I found that out.  But if I use the default audio (windows 10) I should hear something from the dashboard yet I do not.  I DO hear something with identical circumstances on a Mac, so I think my laptop audio isn't compatible with the dashboard for some reason.  Absolutely nothing I do brings up audio when the dashboard is up.

    Reply Like
reply to topic
Like Follow
  • 2 mths agoLast active
  • 13Replies
  • 275Views
  • 5 Following