0

WC7 - Screen Capture gives me a black box

So far everything has been working great with our equipment and Wirecast 7, however we recently put a beefier pc together to handle our live streaming and whenever we try to add any window in the screen capture setup all we get is a black box.  If we enable the cursor we can see the cursor, but I can't find a single setting that gives us anything we are trying to show.

 

Apparently it is only on web browsers too, skype seems to be working just fine.

17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • There's an issue with Windows 10 with some Microsoft products and some browsers which impact Screen Capture. We're investigating but I suspect this is something Microsoft may have to fix as well as the respective browsers.

    Do post the specific programs/browser you've tried capturing here so other users may be informed as well and perhaps note changes as there are updates.

    Since you mention Skype is working this would generally mean that Wirecast Screen Capture is working so the issue is specific to certain programs. Thanks for the observations.

    Like
  • I just hit this problem after doing a Clean Install of Windows 10 to solve some other problems (see below). Before the clean install, Chrome, Edge, etc. worked OK in a Capture Type: Window. And by "OK" I meant that I had to have Chrome open before launching Wirecast, or I'd have to go through the Configure settings to get Chrome to appear, but it always would.

    Now, any open application shows up when I select it for the Capture Window except Chrome, Edge and Opera browsers. 

    The browsers do show up in a Capture Type: Monitor. Alas, I really need it in a Window.

     

    Other problems:

    Wirecast was becoming sluggish when going through menu items, then freezing. I'd call it 'unstable'. Resetting Prefs would help for a short time, but the instability/freezing would return. After the rebuild, I had trouble getting Wirecast Toolbox working (the app that lets you 'take' shots using the keypad). I was in a User account (recommended for security), but Toolbox wanted both Wirecast and Toolbox to Run As Administrator. When I set that up, everything worked (in the User account).

    Like
  • Microsoft has made changes in Windows 10 that result in some programs and browsers unable to be screen capture. Microsoft is aware of this. They need to fix it as it's an OS based issue.

    You should be on Wirecast 7.3. We can't guarantee compatibility of third party utilities. Wirecast is best run in Administrator mode.

    Like
  • CraigS  I still have this problem in version 7.4 of Wirecast

    [Is this still a on going problem or has it be resolved?]

    Like
  • Alexis Rivera This is a Microsoft issue which they have to address. You should test with the current version of Wirecast though which is 7.5.

    Like
  • All of a sudden, this past week, I've been experiencing this problem in Wirecast 7.7.  When I tried to do a window screen capture using either Chrome or Firefox browsers, I was only getting a black box in Wirecast (I have done screen captures of browsers many times previously without issue).   

    I called Telestream support and reported this issue and was told they could not replicate the issue on their computer and that it appeared to be local to my own computer.  The Telestream support rep accessed my computer via TeamViewer and after experimenting with work-arounds, first he found that when selecting the screen capture of  Window of the browser, the small preview image of the browser appeared in the popup window to setup the screen capture as normal.  But when he checked the "capture audio" box, the preview image in that window disappeared.  He then found that if he selected "monitor" when setting up the screen capture, it would capture the content from my second monitor.    He also experimented with not choosing the "capture audio" box so as to not have the preview image disappear in the screen capture window.  That didn't help either, because we still ended up with a black box for the shot in Wirecast.  Only by selecting "Monitor" did the screen capture appear in the shot in Wirecast.

    And then in the shot properties area, we found that we could change the properties of the shot from "monitor" to "window" in order to get Wirecast to recognize the content in a window.  This is very frustrating and time-consuming, and, based on what I'm reading on this forum, it appears that it may not be limited to my own computer.  

    I also found later the same day that when I tried to set up a screen capture of a Zoom call, once again, I had to select "monitor" instead of "window".  And when I tried to switch to Window in the shot properties box, I couldn't get Wirecast to "see" the Zoom content in a window.  It would only see that content if Monitor was selected.  Later that same day, after my show, when I called back Telestream support again and had another rep take access of my computer with TeamViewer to show the Zoom screen capture issue, we could not replicate the problem.  In both cases, I had reset my preferences in Wirecast, shut down my computer and restarted and opened a brand new document.  This was very frustrating as I was trying to produce a show and having these difficulties in the hour before the show while setting up my shots.

    I tried again today and the screen capture problem is reoccuring, both with the browsers and with Zoom.  I find that when I try to set up a screen capture and select window in the screen capture popup box, I only get a black screen so I select Monitor instead of window.  I then have to go to the shot properties of the specific shot and select Window there and then the application appears (Firefox or Chrome browser).

    I had opened a case number on this with Support and will update them this coming week on the recurring problem -- but this is time consuming and very frustrating.

    Like
  • Mike Grayeb Windows 10? You may want to include the version number of the browsers as well (and Zoom). It's also possible the GPU is impacting this in some way. I've seen issues with certain browsers (and a few other programs) in Window mode on Windows 10. It seems to specific to certain programs/browsers though so it's not random.

    Like
  • Windows 10

    Firefox 54.0.1 (64 Bit)

    Chrome 59.0.3071.115 (64 Bit)

    Zoom 4.0.36525.0619

    Wirecast 7.7

    All are up to date versions.  What I don't understand is why the screen capture issue is happening in Wirecast in the browser as well as in Zoom, when the last time I used both (a few weeks ago) there was not an issue with either.

    More importantly, I don't know how to fix it and my sense is that Support doesn't have an answer either.

    Like
  • I just tried again with a new Wirecast document and was able to set up a screen capture of  a Zoom window, but still not able to set up a screen capture of a Firefox window unless I first select it as a "monitor" and then in the shot properties, change that selection to a window.  

    Like
  • Mike Grayeb 

    Wirecast 7.7, Windows 10, FireFox 54.0.1 64 bit, captured the About window and have Audio Capture enabled as well. So it's working for me.

     

     

    Like
  • Perhaps it's an Aero theme (transparency) issue. Just a wild guess.

    Like
  • But tried Chrome (save version as yours) and that did not work. I select the windows and I get blackbox as well.

    Like
  • CraigS It appears from your screen shot that you selected the window in the Shot Properties.  Did you select the window option inside the popup box that first appears when you select a screen capture and have to choose between monitor and window?  Or did you need to select monitor first and then in shot properties change it to window?  I'm unclear about your mention in this thread that perhaps its an Aero theme/transparency issue.  Is Aero a default theme/feature in Windows 10?  I haven't selected it and have been using Windows 10 since before I purchased Wirecast without experiencing this issue.

    Like
  • Mike Grayeb 

    Mike Grayeb said:
    Did you select the window option inside the popup box that first appears when you select a screen capture and have to choose between monitor and window?

     Yes. I just grabbed the screenshot after I created the shot and confirmed shot properties shows the same as the initial pop up.

    There's transparency settings but I'm not absolutely sure they'd be the cause. As you can see in my case Firefox does work but Chrome does not though. So it may be something else at issue.

    Like
  • I don't think Chrome has worked for me ever for screen capture; only Firefox.

    Like
  • I uninstalled and reinstalled Wirecast and as of now the issue is not reoccurring.  

    Like
  • Mike Grayeb That's great to hear.

    Like
Like Follow
  • 3 yrs agoLast active
  • 17Replies
  • 939Views
  • 5 Following