Video Capture Source Not Recognized.

This is really weird and I couldn’t find any similar cases in the internet. That’s frustrating. 


I had the trial version and it works great with magewell pro capture quad HDMI video card. 

I previewed my video source and recorded it and it works as it should for 30 minutes. 

I turned my computer off and comeback after 10 hours where I couldn’t get my video card in “Video Capture” submenu any more. 

Closed and reopened the application - nothing. 

Checked the card drivers - nothing 

Disconnect everything and reconnected it in every possible way - nothing. 

Delete WireCast and reinstall it again- nothing. 

I combined these steps and did it in million order and nothing seems to work.

I can see the card as an input source from other applications like OBS, but not with WireCast. 

Only that first time. 

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • The issue may well be between the computer and Magewell card if something is grabbing the input (and depending on what's grabbing the input you certainly may see it elsewhere).

    Perhaps try removing OBS and rebooting.
    Make sure your Magewell driver is up to date.
    When you reboot the computer make sure there are no background video or audio tasks running (even programs like Skype can grab a source as a camera).

  • I am having a similar issue, but don't see a thread for it. I have a new MBP, but when when i plug in my mixer or even my usb camera, the capture button doesn't see anything. I have tried various ports, and nothing happens. Everything externally works fine, as do the input ports, just not within the software. My other macbook, works perfectly.

  • noyb smoov said:
    have a new MBP

     In Mojave you must go to System Preferences Security & Privacy and Privacy settings and give Wirecast access. In fact you must do this for all programs that use cameras and mics, etc. Please see Apple's tutorials and KBase on Mojave.

  • Wirecast doesn't even show up under privacy.  If i go to accessibility and add wirecast to that field, still get nothing. 

  • noyb smoov Please provide screenshot so I can verify.

  • noyb smoov 


  • CraigS resolved, thanks 

  • noyb smoov You're welcome of course.

Replies are closed
  • 1 yr agoLast active
  • 8Replies closed
  • 237Views
  • 4 Following