0

Mouse cursor is lost in some clips

Hi there,

I've recorded four very similar clips into the same project, and for some reason two of them are missing the mouse cursor on the final recording. This has never happened to me before.

I'm aware of the 'Show Mouse Pointer' option in the Screen Recording tab, but this isn't the problem – it's set consistently across the recordings.

Any ideas if there's a way to get it back? Have I overlooked something, or should I assume that something's gone irremediably wrong?

Thanks

 

Screenflow Version: 6.2.2

OS X current: 10.13.3

OS X during recording: 10.11

All clips recorded fullscreen

65replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Greg Benz
    • Greg_Benz
    • 1 yr ago
    • Reported - view

    CraigS You were right, the external monitor is an important factor. It's very complicated. The cursor will disappear when of the following are true:

    • Using a Wacom pen
    • Using an external monitor and the display is set to mirroring
    • Click into a text entry field in PS and type something with the keyboard

    The mouse stays hidden from that point on, unless some certain condition changes it. The following all cause the mouse to re-appear:

    • typing into that field when the trackpad or BlueTooth mouse are the active device instead of the Wacom pen
    • Switching to another app and back to Photoshop
    • Clicking a Photoshop menu

    I have a screen recording that shows all this very clearly. What's the best way to send it to send it to you privately?

    Like
      • Greg Benz
      • Greg_Benz
      • 1 yr ago
      • Reported - view

      CraigS Thank you. I can confirm that QuickTime recordings also show no cursor under the same condition. So seems clearly related to either the OS or the Wacom driver. I'll mention that to Wacom as well.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Greg Benz Alas, we are just victims of Apple. 😉

      Like
      • Greg Benz
      • Greg_Benz
      • 1 yr ago
      • Reported - view

      CraigS Apparently so. I appreciate your help with this, thank you!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Greg Benz You're welcome of course.

      Like
    • Justin V
    • Justin_V
    • 8 mths ago
    • Reported - view

    Just wanted to chime in… this issue is still happening with ScreenFlow and Wacom on mac. Very frustrating. I had to downgrade my Wacom driver version back to one from 2020, which has it's own set of bugs. I fail to understand why the cursor can be seen normally on the screen but disappears in Screenflow. Lost a lot of time on this bug. 

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 8 mths ago
    • Reported - view
    Justin V said:
    Just wanted to chime in… this issue is still happening with ScreenFlow and Wacom on mac. Very frustrating. I had to downgrade my Wacom driver version back to one from 2020,

     ScreenFlow 10.0.4? Which macOS and CPU?
    It sounds like it's Wacom-related if downgrading the driver fixes it.
    What driver version isn't it working with and what downgrade works?
    ScreenFlow may dependent on the driver and macOS interaction and how the GPU handles that. ScreenFlow is handed the information from macOS.

    BTW you may want to try a screen recording in Quicktime and see how it handles the cursor.

    As you can see in other parts of this thread. This seems to be an Apple issue.

     

    Justin V said:
    I fail to understand why the cursor can be seen normally on the screen but disappears in Screenflow.

    Screen recording is not the same as monitor display as far as macOS is concerned.

    Like
      • Justin V
      • Justin_V
      • 8 mths ago
      • Reported - view

      CraigS macOS 12.1 and i9 2.4Ghz CPU. 

      Wacom driver 6.3.44-2 definitely caused a problem for me. There's a new version out 6.3.45-2 (that has a direct link, but Wacom hasn't updated their website to list it for some reason) that I have installed, but not tested, against Screenflow yet. Previously, version 6.3.42-1 had been working for me with Screenflow. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 8 mths ago
      • Reported - view

      Justin V Please do test the new driver and report back. Given the driver impacts Wacom's compatibility you may want to report the results to them as well.

      Like
      • Justin V
      • Justin_V
      • 7 mths ago
      • Reported - view

      CraigS Sorry for the delay. Can confirm that the new 6.3.45-2 Wacom driver on macOS 12.2 does NOT fix the disappearing cursor. I just recorded a new screenshare today in Lightroom (on a brand new M1 Max MacBook Pro) and the cursor disappeared while viewing an image in Lightroom. 

      Like
  • macOS 12.3 beta seems to include new APIs for screen capture. Hopefully this helps Telestream fix the pointer issue. 🤞

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 8 mths ago
      • Reported - view

      Howard Pinsky Thank you very much for that info!

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 7 mths ago
    • Reported - view
      • Justin V
      • Justin_V
      • 7 mths ago
      • Reported - view

      CraigS That is correct. Wacom 6.3.45-2 (latest driver) on macOS 12.2 has the disappearing cursor issue.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 7 mths ago
      • Reported - view

      Justin V Thanks for confirming. We're investigating. I suspect we need to determine if we can fix or Wacom should given an earlier version of the driver did work.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 6 mths ago
      • Reported - view

      Justin V We've determined the issue is macOS related and have logged the bug with them. 

      Like
Like Follow
  • 6 mths agoLast active
  • 65Replies
  • 547Views
  • 6 Following