WireCast app takes 3-5 minutes to start up; must force quit

I have WC 13.0.2 running on my MacBook Pro with Mojave 10.14.6.  I have using it for live-streaming and recording events for the past few years.  For some unknown reason I now have serious problems.  When I start WC from my dock or from the application folder the WC icon begins to bounce. After about 2 minutes of bouncing, the bouncing stops.  WC does not open. In Activity Monitor it says "Wirecast: Not responding".  If I do nothing and wait for 3-4 minutes WC will finally start up.  It seems to work fine once it starts up.  But when I quit WC, the main window closes but WC does not shut down.  After about 5 minutes of waiting I manually quit it with a forced quit.  This has been very frustrating.  Any ideas will be greatly appreciated.  


5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • That sounds like a possible issue with your config or maybe a preference setting.
    Make sure you're not running any virus checking software. It's also possible Wirecast is scanning for input devices and you have something unusual going on locally or on the network (lots of IP cameras for example).

    Test by creating a New User Admin account and trying there. That would give you both new user and Wirecast preferences. That will let us know if it's a system vs account issue.

  • Thanks CraigS.  This is what I have done to troubleshoot:  I created a new user account and had the same result running WC in that account.  This seems to show that it is not simply a problem with my user account or its preferences. I then installed WireCast on a second computer (my iMac Pro running Catalina).  I copied my two WC profiles (.wcst files) that I have been using on my MacBook Pro to my iMac. Everything runs fine on the iMac.  This seems to isolate the problem to my MacBook Pro. I have no antiviral software running on either Mac.  I do have a couple of IP cameras on my network.  But if that were to be the problem it should also affect my iMac as well as the MacBook Pro. This all seems to indicate to me that there is either something wrong  system wide on the MBPro (that might be corrected by re-installing the Mac OS) or something wrong with the installation of WireCast.   I would guess there would be someway to investigate these possibilities if I were proficient in reading error codes in Console or wherever that information might be stored. I have been running WC on this same MacBook Pro for many months without problems until just now. 

    What do you think about the following as an attempted solution:   Re-install Mac OS Mojave on the MacBook Pro ( I don't want to upgrade to Catalina on this machine because of software incompatibilities) and if this doesn't work totally uninstall WireCast and all of its components and re-install it? 

  • John Baughman Try trashing Wirecast. Deactivate it first. You may want to download the free app EasyFind and search for any other files labeled Telestream or Wirecast and delete those too. 

    Reboot the computer.
    Download Wirecast 13.0.2 and reinstall it. 
    Remove all third party devices including USB hubs.
    Disconnect the computer from the network and the internet.
    Reboot the computer.
    Start Wirecast.
    Tell me what happens.

  • I think I’ve found the problem and fixed it.  I noticed in the Console app that under “System.log” there were dozens of entries per hour for “SlinkDaemon”.  A couple of years ago I used an app called Slink to do remote connections on my Macs. I haven’t used it for more than a year since it is no longer supported.  But apparently a daemon has been running in the background.  Why it would raise its head at this time and cause trouble is not clear to me.  But I used an app to delete this daemon and everything on my computer related to it.  After I restarted my computer I no longer got anything in the system log related to slink.  And, much to my relief, it looks like Wirecast has started behaving properly once more.


    Thanks for your help in this matter.  I have live broadcasting scheduled for tonight and this is a great relief.

  • John Baughman Interesting find. Good to hear it's working now. You're welcome of course.

Like1 Follow
  • 2 yrs agoLast active
  • 5Replies
  • 65Views
  • 2 Following