Rendezvous reports "Unable to Receive Video"

Before today, I have successfully brought in guests from NYC, Medellin, and Bologna on LTE. Today I tried bringing in a guest from Berlin. The guest received the error "Unable to receive video" and I only saw a black screen / no audio from the guest in wirecast. The guest had 2 i-devices and both gave the error. However, both worked when the guest switched to his local WiFi. Unfortunately, WiFI will not be an option for the final broadcast.

 

Speedtest revealed 15 down & 6 up for the guest on LTE. My guess is that the LTE network is blocking rendezvous. Is there a way prove this? Any suggestions to get it working?

 

HOST:

MacBook Pro 2017

Wirecast: 11.1.1

MacOS: 10.14.2

 

Remote:

iPhone or iPad

IOS: ??

Wirecast Go: 2.1.2

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • My other question would be, does anyone have a suggestion for an alternative to Rendezvous?

    Skype recently added a nifty NDI out option. That was my backup plan. However, there's a known issue with MacOS 10.14.2 where the local video fails. My Mac is running into this.

    What else do people use and how do you pull the remote video into wirecast?

    Reply Like
  • remote iOS: 12.1.1

    Reply Like
  • Jacob Gauthier - I currently use Rendezvous every week. For me, it works... There are a couple of issues outstanding.

    1. Some users disconnect and reconnect repeatedly. Even when the user has no network issues. The same user can connect to vmix remote guest services without issue. Planning on doing some more webrtc testing later this week. This appears to be OSX specific (remote guest).
    2. Sometimes, we have issues with some users coming in as black or jumbled screen. No pattern observed for remote users. But when this happens, wirecast also has difficulty disconnecting those users. Disconnecting in the UI fails to disconnect.

    There are other design related issues, but those are being tracked and worked on elsewhere.

    GK

    Reply Like
  • Jacob Gauthier First as at test try Wirecast Go on iOS locally to make sure there's no issue local to you.

    One caveat on any bandwidth test is that it's hitting a specific destination server. It's possible that hitting a different server may result in much lower speed and/or much greater packet loss.

    Perhaps to see if location vs destination is a potential issue would it be possible for your guest to download the free trial of Wirecast to a local computer and try calling to in via Rendezvous on LTE. I know that's a lot to ask of a guest though.

    Since Wifi worked and LTE did not it does seem to be an LTE specific issue but one has to test to see where the point of failure might be.

    Reply Like
  • CraigS  - Thanks for the help. I tested wirecast go locally and it works. 

    I had the remote guest connect to a VPN while on LTE and now his wirecast GO is working. The LTE provider must be blocking rendezvous. I know rendezvous uses WebRTC. What port(s) are used?

    Also, is there a way to control data usage and/or to prioritize frame rate over picture quality?

    Reply Like
  • Greg Kuhnert - I've run into both issues.

    RE #1 - it was Mac OS 10.14.2 and we were not able t resolve it. We're going to try again, or switch a different machine.

    RE #2 - I've noticed this behavior on Android. I send the rendezvous link over FB Messenger. If my guest opens it from there, we see this behavior. If they copy the link and paste into chrome, they can connect without issue. Perhaps your guests are doing something similar?

    Reply Like
  • Here's another tip. You can easily run your own speed test server: https://hub.docker.com/r/adolfintel/speedtest/

    Then you can check speeds from the remote guest to the wirecast system.

    Note: if you're behind a firewall, don't forget to port-forward to the docker container.

    Reply Like
  • Jacob Gauthier said:
    I know rendezvous uses WebRTC. What port(s) are used?

     Rendezvous is supposed to find an available port somewhat dynamically. If all else falls. Port 443 may work.

    Reply Like
  • Jacob Gauthier - Dont use messenger client for receiving Rendezvous URL's. The messenger app has embedded web browser that is not WebRTC compatible.

    GK

    Reply Like 1
  • Jacob Gauthier said:
    I send the rendezvous link over FB Messenger. If my guest opens it from there, we see this behavior.

    Yup. FB Messenger can be a problem. If someone's on mobile I just send a text with the Rendezvous link. 

    Reply Like
  • Reply Like
Like Follow
  • 2 mths agoLast active
  • 11Replies
  • 181Views
  • 3 Following