0

Video Input freezes on Mac Studio

Just purchased a brand new Mac Studion with the M1 Max chip, 32 GB ram, and an upgraded GPU. I bring in my video via SDI into Magewell USB Capture plus. Been using this same process on iMac previously with no issue. Now every 20-30 minutes the video feed freezes on either feed. Have to unplug USB and plug back in to get it to unfreeze. What could be causing this?

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 6 mths ago
    • Reported - view

    That may be a USB bus issue.
    Please remove all other USB devices and test only with the Magewell connected directly to the computer (no docks or hubs).
    Confirm you are using Wirecast 15.0.3, macOS 12.4 and a new blank document with only the Magewell shot.
    If you still see the issue quit Wirecast and test in Quicktime as a camera source and see if it happens there.

    Like 1
    • CraigS tried the USB Bus process you described and it led me to a fix! Thanks for the help! Once all inputs were removed, the feeds never froze. From there I added inputs as I went but was unable to get all my inputs back in. It was at this point I took my Magewell inputs from their USB-A into a USB-C adapter and into the Thunderbolt 3 connections in the back of the Mac Studio instead of the USB-A inputs. After this, I was able to plug in all my inputs back in, and the feeds never froze. I essentially am using all of the I/O on the MAC Studio and sending a 1080P feed out to YouTube and Facebook, and the CPU averages around 40%-50%. Thanks!

      Like
Like Follow
  • 6 mths agoLast active
  • 3Replies
  • 55Views
  • 2 Following