2

Decreasing the file size does not work

Hey there!

I am trying to decrease the size of several screenflow-files by deleting unused videos within in the media library.

After doing so, I saved the file (or within a new file by saying "save as") with the hope, that the file size decreased, but: The size of the file after deleting several videos is the same as before?!

What am I doing wrong? How to get rid of unused stuff.

Thanks for your help!

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • See if this works.
    Remove All Unused Media

    Like
  • Like
  • Ok, thank you CraigS, as always, you helped me perfectly!

    Like
  • CraigS I've just tried this.. But this doesn't work.. :(

    1) I've deleted the medias I don't need any more in the "Media Library" => they disappear in the timeline and the library.
    2) Afterwards I've clicked on "Remove All Unused Media"

    3) Then via "Save as"  Ive saved it in another file..

    The old one with the clips and the second one without the unused clips have still the same size..
    What am I doing wrong?

    Like
  • Armin said:
    3) Then via "Save as"  Ive saved it in another file..

     Save not Save As. Save should change (delete) the files in that document.

    Like
  • CraigS Unfortunately, the deletion of the unused clips does not work, even if I use only "Save" not "Save as".
    Any further suggestions? :/

    Like
  • Armin That's odd since we have no other reports of this. I've tested this on my own system and confirmed that it does work.

    ScreenFlow 9.0.3 on macOS 10.14.6 or 10.5.5? 
    Can you confirm that?

    Like
  • Mh. Very strange.
    Screenflow Version "9.0.3 (31523)"
    Mac 10.15.5

    Like
  • Armin You could send me one of your projects (smallish) via a link and I can test on my system.

    Like
  • Armin I looked at the file you sent which includes screen recording and webcam. The media folder shows only the .scc file so there's nothing to delete.

    Like
  • Armin 
    I did my own test.

    1. Open ScreenFlow and do a Screen Recording.
    2. Save.
    3. .scc is in the Media Folder.
    4. Do a Second Screen Recording adding to the current document.
    5. Save.
    6. Both .scc are in the Media Folder
    7. The Second Screen Recording is not in the timeline. I use Delete Unused Media and a popup window shows the Second Recording and on Delete confirms it can't be undone and I delete the Second Screen Recording.
    8. Save.
    9. Quit ScreenFlow
    10. Check Media Folder and Second Screen Recording .scc is still in the Media Folder (along with the original).
    11. Conclusion: Unused media was not deleted.

    This is an issue.

    Like
  • Second test with imported media

     

    1. Open ScreenFlow and do a Screen Recording.
    2. Save.
    3. .scc is in the Media Folder.
    4. Imported MP4 file
    5. Save.
    6. scc and MP4 are in the Media Folder
    7. The MP4 is not in the timeline. I use Delete Unused Media and a popup window shows the MP4 and on Delete confirms it can't be undone and I delete the MP4 file
    8. Save.
    9. Quit ScreenFlow
    10. Check Media Folder and in addition to the .scc file the MP4 file is still present
    11. Conclusion: Unused media was not deleted.

    This is an issue.

    Like
  • Armin I can confirm your report is correct in that ScreenFlow does not delete Unused Media from the Document. It makes no difference whether the unused media is a screen recording or imported file.

    Please do fill out the form and also mention that I've tested and confirmed the issue as well.

    Like
  • CraigS Hey there. Thank you for testing and confirming..

    Couldn't you report the bug, please? I am only a simple user, nothing more.

    May I further ask, where the differences was between your first tests (where you meant, that everything works fine) and the latest test?

    Thanks for everything.

    Like
  • Armin said:
    Couldn't you report the bug, please? I am only a simple user, nothing more.

     The engineers may want to contact you. Different systems behave differently. If they fix it for my system it may not be fixed for yours.

    Armin said:
    May I further ask, where the differences was between your first tests (where you meant, that everything works fine) and the latest test?

     I'm not sure which is why they may need to speak to you. They may need to see if there's another variable.

    If you fill out the form, you'll get a case number. You can post that here. Then I can add details from my testing to your case.

    The engineers tend to want to hear from customers or they may feel it's a low priority if customers haven't reported this.

    Like
  • CraigS Case number: 00751692

    Like
  • Armin said:
    Case number: 00751692

     Thanks for that. I'll track and make clear my verification.

    Like
  • Has this ever been addressed? I am having the same issue.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 mths ago
      • Reported - view

      Sam Smyers Yes. Issue FLOW-10446 was fixed in ScreenFlow 10. Current version is 10.0.5 so you'd need to upgrade.

      Like
Like2 Follow
  • 2 Likes
  • 2 mths agoLast active
  • 19Replies
  • 37Views
  • 4 Following