1

Audio not recording after updating to Ventura

Hi guys, I've been loving your software for over 10 years now. 

Today I hit a stumbling block, when going to record screen audio for a client the audio isn't recording. I've made sure to select record computer audio yet only the video source comes through. I have updated to Screenflow 9.09 and no change. 

I noticed that when I hit record, my sound icon in my mac top tool bar flashes to mute and then back to on again. 

Please help :)

34replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 9 days ago
    • Reported - view
    Liz Gallagher said:
    I have updated to Screenflow 9.09 and no change. 

     What macOS and what program is the computer audio coming from?
    Some programs need to be pointed to the Telestream Audio Capture driver manually. 
    You should have seen this popup explaining that.
     

    Like
    • CraigS I’m using the latest Ventura.

      I’m recording a web browser and there was definitely no pop up. 
       

      Any ideas?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 9 days ago
      • Reported - view

      Liz Gallagher Thanks for that info. Which Web Browser, version, and what's playing (Youtube, something else)?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 9 days ago
      • Reported - view

      Liz Gallagher Also go to ScreenFlow > Preferences > Advanced > Computer Audio
      Does it say Install Driver or Uninstall Driver? 

      Like
    • CraigS I’m running google chrome Version 107.0.5304.121

      I also tried recording various other things and it isn’t working - not even videos from the photos app.

      It says uninstall driver 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 9 days ago
      • Reported - view

      Liz Gallagher 

      ScreenFlow 9.0.9, Ventura 13.0.1, Chrome 107.0.5304.110  playing a YouTube video.
      I had no issues recording video and audio from Chrome.

    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 9 days ago
    • Reported - view
    Liz Gallagher said:
    It says uninstall driver 

     Try uninstalling.
    Reboot the computer.
    Go back to that Preference and it should say Install.
    Install the audio driver.
    Reboot the computer.
    Try playing a video in Quicktime and capturing video and audio.
    You should get the popup I posted previously when you set computer audio.

    Like
  • I'm still having issues after unistalling / reinstalling and restarting etc. I see that you have no issue which is awesome, though unfortunately it's not working for me. It was working right before I updated and there is no other change that I have made. Any other ideas?

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 8 days ago
      • Reported - view

      Liz Gallagher Perhaps something is conflicting. 
      Go to
      Macintosh HD/Library/Audio/Plug-Ins/HAL
      and take a screenshot of what's in the HAL folder
       

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 6 days ago
      • Reported - view

      Liz Gallagher Please do post a screenshot of the HAL folder as Juan did so we can determine if there's a potential conflict.
      Please remove the other contents of the folder, reboot, and test.

      Like
  • For the record, Loom is working fine

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 days ago
      • Reported - view

      Liz Gallagher Another thing to try is the following Terminal command

       

      1) Make sure ScreenFlow is not open.
      2) Open Terminal and copy and paste this command and press Enter:
      To open "Terminal" (Finder > Applications > Utilities > Terminal).

       

      sudo tccutil reset All net.telestream.screenflow9

       

      3) Reboot the computer and test.

      Like
  • I have the same issue. Not being able to record audio from computer since updating to macOS Ventura 13.0.1. 
    I use ScreenFlow9. I have 2 Macs, so I tried in the one with macOS Monterey, i recorded the same youtube video and was able to record the audio from computer with no problem.

    Like
  • This is from my computer with Ventura

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 7 days ago
      • Reported - view

      Juan Chavez (Coach) Thanks for that screenshot. It's exactly what I needed.
      Please make sure you've updated to ScreenFlow 9.0.9 as that fixed a previous audio issue.

      Let's determine if there's a driver conflict.

      • Remove all the drivers and plugins in the HAL folder except TelestreamAudioCapture.driver.
      • Reboot the computer and confirm all the other drivers are no longer in the HAL folder.
      • Please make sure you set the Mac's audio monitor output to its internal speakers (if MBP or iMac) or to the speaker jack (don't use USB or Bluetooth speakers).
      • Then start ScreenFlow and use Computer Audio to record the YouTube video
      Like
  • No luck. I still cannot record. However I noticed that the Telestream Audio Capture is not listed in the device sound output list.

    Like
  • BTW, I am having audio issues with another software I use as well. 

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 6 days ago
      • Reported - view

      Juan Chavez (Coach) Telestream Audio Capture is an "audio hijack" type device so it works similarly to other "audio hijack" software. 

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 6 days ago
    • Reported - view

    Liz Gallagher Confirm you are using Built-in/Internal Speakers to monitor and not Bluetooth or USB headphones or speakers as Juan did. 
    Juan Chavez (Coach)

    Started investigation FLOW-11640
    Developers will likely have questions. Please be ready to respond ASAP for the fastest investigation.

    Other tests you can perform in the meantime.

    • Create a New User Admin account and test by playing a video in Safari. This will determine whether it's a user or system-based issue.
    • Download and install the free trial of ScreenFlow 10.0.8. You can put it in a separate folder in Applications so it doesn't overwrite 9.0.9. Test using that version to determine if it's specific to 9.0.9

    Please run this test as soon as possible so I can give this information to the developers.

     

    Like
    • I downgraded to macOS Monterey. Problem solved.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 6 days ago
      • Reported - view
      Juan Chavez (Coach) said:
      I downgraded to macOS Monterey. Problem solved.

       Alas, we still need to look at the cause. At least you can get work done for the time being.

      Like
      • Jeroen Ov
      • Jeroen_Ov
      • 4 days ago
      • Reported - view

      CraigS installed the trial, uninstalled the telestream driver and installed, after that audio in 9.0.5 recorded again as usual. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 days ago
      • Reported - view

      Jeroen Ov 9.0.5 has Ventura compatibility issues you may soon run into. You should update to 9.0.9.
      Was it the trial version 10.0.8? Now try 9.0.9 and see if it works.

      Like
    • Jeroen Ov
    • Jeroen_Ov
    • 4 days ago
    • Reported - view

    Same situation here: Screenflow 9.0.5 and Ventura 13.0.1 and no sound anymore!

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 days ago
    • Reported - view

    Another thing to try as we do think it may be an odd Privacy & Security issue

    Sorry to hear you are running into some issues with macOS permissions, they seem to get more interesting each OS. Can I have you try the following:

    1. Open Privacy and Security and place it on the left side of your screen.
    2. Open Finder, and put it on the right hand side of your screen.
    3. In Privacy and Security, go to the Accessibility permission and highlight that.
    4. Drag and Drop the entire ScreenFlow App to the Accessibility permission.
    5. In Privacy and Security, go to the Screen Recording permission and highlight that.
    6. Drag and Drop the entire ScreenFlow App to the Screen Recording permission.
    7. Reboot your mac and try to record audio from a web browser or QuickTime.

    Like
Like1 Follow
  • 1 Likes
  • 4 days agoLast active
  • 34Replies
  • 35Views
  • 7 Following