3

Using Zoom with Virtual Camera

This isn't a question, but a heads up to anyone using Wirecast virtual camera with Zoom.

I've been tearing my hair out all morning because Zoom suddenly stopped recognizing the virtual camera output from WC with the same setup I've been using successfully for weeks.

Turns out that Zoom released an update (version 4.6.9) that disables the use of virtual cameras. It's part of a security patch intended to prevent Zoom-bombing, and it's unclear if breaking virtual camera input was intentional or not. The most reliable fix for this at present is to roll back to a previous version of Zoom.

There's a helpful Medium post about it here.

Just posting here in case anyone else is currently going insane with suddenly not being able to use Wirecast with Zoom.

-David

27replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Zoom says they will put back support for virtual cameras, but as of 4.6.12 it has not re-appeared yet.

    Like
  • And no mention about it in their announcement for Zoom 5.0 either.
    Keep in mind that these issues are likely related to Zoom's work on security issues.

    Like
  • Zoom 5.0 has been released and virtual cameras still don't work.

    Like
  • CraigS Interestingly... I am absolutely able to get it working...

    I had to restart Zoom once I enabled it but it absolutely shows up. I was trying it out in order to do a demo of using NDI out then using virtual camera from NewTek but didn't need to. Zoom 5.0 picked up the Wirecast virtual camera.

    The only issue I really found was that virtual camera scale was greyed out if NDI output was enabled, meaning if I want NDI out at 1080p30 and Virtual Camera out at 720, I cannot do this.

    Like
  • Had trouble locating an installer for Zoom 4.6.8 for mac, but eventually I found it in the trash of one of our machines. You can download this installer here :

    https://spaces.hightail.com/receive/gDKSgtPXzB

    This restored Virtual Camera functionality.

    TIP: indicate the version of the various zoom apps on your machine (They will all look alike otherwise.)

    Like
  • Matthew Potter Tested Zoom 5 on Windows 10 with Wirecast 13.1.2

    Start Wirecast
    Start Virtual Camera Out
    Start Zoom.
    Virtual Camera not an option.
    Interesting that I see Decklink option which is also supposedly broken.
    NDI Scan Converter showed black.

    Like
  •  CraigS

    You shouldn't need to start Wirecast first at all, the virtual camera driver that gets installed is available all the time, even without Wirecast open.

    The Decklink options are available however unless you're specifically driving  720p30 or 1080p30 input (not dropped frame based 39.97 / 59.94), most applications like Skype, Zoom, WebRTC cannot read the input video and error out internally.

    Scan Converter's input never shows up here, as it is Virtual Input you need to run and then select the NDI input from there. This also works as it does a frame lock and resolution lock at 1080p30, 720p30 or 480p30 based upon the settings you enable in the taskbar config menue.

    As I'm not seeing the virtual camera installed there in that Zoom list, I would recommend re-installing the Wirecast Virtual Camera.

    Note that the OBS virtual camera does perform the exact same manner HOWEVER it does not contain audio, only the Wirecast virtual camera and the NDI virtual input have audio input available as selectable microphones for various applications. Yet another reason I want Telestream to FIX YOUR BUGS PERTAINING TO INPUT SCALING!

    Like
  • Matthew Potter Zoom 5.0.1 was released today and it now works. Apparently they had another bug to catch. Perhaps something impacting some systems given how quickly they turned it around.

    This is Windows 10. 
    For those following along, still not working on Mac but perhaps given this I'm more optimistic they'll have a macOS fix at some point.
     

    Like 1
  • I got 5.0.1 to work on my Mac, but I had to use some Terminal commands.

    First, install Zoom 5.0.1 and launch it. Then quit it.

    Next, make sure you have the Xcode Command Line Tools installed. You can check by opening a Terminal and typing

    xcode-select --install

    If they are not installed, it will prompt you to do so.

    Finally, unsign the application. This will remove any restriction to load the drivers needed to support virtual cameras.

    codesign --remove-signature /Applications/zoom.us.app

    Launch Zoom and the virtual camera should reappear!

    My guess is the virtual camera capability has been present all along (since 4.6.9) but due to application signing changes the drivers couldn't be loaded.

    Like 1
  • Barry Brown Yes there are "hacks" but they present security issues.  I suspect Zoom will develop an official solution in compliance with Apple's security (and Zoom's own security).

    Like
  • Zoom Release notes for macOS
    4.6.10
    Removed virtual camera support
    Zoom has temporarily removed virtual camera support.

     

    Like
  • I can confirm Virtual Cam is back in Zoom 5.0.1 for Mac after doing the code-sign Barry Brown shared:

    codesign --remove-signature /Applications/zoom.us.app
    Like
  • Hey, I was just wondering what resolution you guys get transmitted to zoom when using the virtual camera?

     As far as I can see, it seems to be capped at 720, which isn’t great for what I’m trying to do. 

    Like
  • I believe Zoom is the one that's capping it, unless you have one of their higher end plans: https://support.zoom.us/hc/en-us/articles/207347086-Group-HD

     

    If you need 1080p I'd suggest using a streaming service, like twitch.

    Like
  • Sebastian Beca interesting to know that, thanks for the link. But I don’t think it’s limited to zoom. Using webcamtests.com I can only get it to detect a maximum resolution of 720. OBS virtualcam on Windows and mimolive on OS X both get detected at 4K output, if I set them to output at that.

    Like
  • Barry Brown's terminal command process worked for me also, great fix. Thanks man.

    Like
  • Zoom has stated they should reintroduce virtual camera support on macOS by the end of the month.

    Like
  • hello I use ScreenFlow 9 and the camera no longer appears there ... what could I type in the terminal to solve?  This code don't work: codesign --remove-signature /Applications/ScreenFlow 9.app/

    Like
  • Corrado Cocco Are you saying the Wirecast Virtual Camera wont even work as an input to ScreenFlow? Did it work before? What has changed, and/or when did it stop working?

    Greg Kuhnert

    Like 1
  • usually use my canon camera with the software camera live + camera twist and in ScreenFlow you could use this as a webcam now it is no longer possible ..?!  Is there a way to use my Canon camera as a webcam in screenFlow?  Thnx

    Like
  • Zoom 5.0.4 was released today and Virtual Camera is once again working on Mac.

    Like
  • CraigS Great news. Thanks, Craig.

    Like
  • Corrado Cocco 
    Wirecast Virtual Camera does work in ScreenFlow 9.0.3
     

    Like 1
  • CraigS Thanks for your answer .. Sorry I don't understand very well .. are you saying that to use my canon camera as a webcam in Screen Flow I have to buy Wirecast? 

    Like
Like3 Follow
  • 3 Likes
  • 2 mths agoLast active
  • 27Replies
  • 652Views
  • 11 Following