0

Wirecast Virtual Camera - not working on clean install

I installed wirecast 9 beta 2 onto my laptop (before using it on my usual streaming workstation). As part of testing, I tried to enable wirecast virtual camera. The reboot failed after about 5 minutes - I did a manual powerdown.

I tested it after reboot, and it failed to function.

Can you advise a process to do a clean uninstall of the virtual camera, and I will try to replicate the reinstall to see if it fails again.

14replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Bump

     

    I already reinstalled wirecast. How can I specifically uninstall the virtual camera and reattempt a clean install.

    Like
  • Greg Kuhnert

    Are you on a Mac? 

    Like
  • Hi Rory Maloney .

    Yes, I am on a mac. I have already uninstalled wirecast and reinstalled. That failed. I have also deleted the directory suggested by Craig here https://telestreamforum.forumbee.com/t/h4k9d0/uninstall-wirecast-virtual-camera but that failed as well. Yes - I did reboot after deleting that. Still no good.

    I am on High Sierra, running the latest version of Skype. Interestingly, this works on a Sierra machine with the same version of Skype.

    GK

    Like
  • Greg Kuhnert said:
    How can I specifically uninstall the virtual camera and reattempt a clean install.

    As per my initial post, my Mac running High Sierra failed to reboot after virtual camera install for reasons unknown.

    It failed to work with ANY applications. And before anyone says it is caused by "sandboxing", camera drivers (virtual or physical) use the same operating system libraries to provide a video feed. The fact that apple provides app isolation is totally unrelated.

    I have uninstalled wirecast, and followed some unsupported procedures to uninstall the virtual camera... and reinstalled later. However, still not working with the latest Skype, or indeed any other apps. https://telestreamforum.forumbee.com/t/h4k9d0/uninstall-wirecast-virtual-camera

    Basically, I deleted that directory and rebooted. Yes, it appeared to be uninstalled - but cannot confirm if there are any other artefacts that needed removal.

    This worked on 8.x - and only had problems after upgrading to 9 beta. Suggestions?

    Like
  • Tested Wirecast 9 beta 2, macOS 10.13.4, Skype 8.19 and now 8.20 and Virtual Camera works. 
    Greg Kuhnert  perhaps you have other virtual device software that's interfering with Wirecast 9's virtual camera?

    Like
  • CraigS Greg Kuhnert (Rory Maloney I've now re-installed Wirecast current version and attempted to install virtual camera 20 times with no luck of working. this is crippling a project for next week.

    Like
  • George E. Kennedy, Jr 

    Its been a long time since this thread. Realistically, Telestream need to provide uninstall instructions or an uninstaller app. But failing that, we're left to do it ourselves.

    I've learned of a good tool after my previous post a year ago. Assuming you are Mac based, I'd suggest looking at LaunchControl. Its a nifty app that lets you peek under the hood at OSX startup devices, including the Virtual Camera etc. You can easily enable/disable using this tool... and/or find out where the files are installed to help with manual uninstallation.

    I hope that helps.

    GK

    Like
  • Greg Kuhnert It’s extremely frustrating that the team doesn’t have a fix for this. I hate the thought of having to use OBS for one project just to be able to run Skype over NDI. My next solution is to figure returning program to SKYPE guess without using virtual camera

    Like
  • George E. Kennedy, Jr Mojave and Catalina have new security issues that may result in additional challenges so it may be a different issue than posted here.

    Like
  • CraigS I don’t no longer what to say here, I’ve been on Wirecast since version 1, and I’m left feeling sometimes like I’m still on V1. Problems get fixed and then the break again. 
     

    I keep saying I don’t want to loose faith in Wirecast, but things just need to work. I agree it could be a iOS issue, but this doesn’t help for know.

    Like
  • George E. Kennedy, Jr Ideally there should be a permissions popup when installing on Mojave or Catalina. Please make sure you're on Wirecast 13.0.2 and note the version of the OS. Since there are many more combinations and third party programs that can run interference we need the specifics. Also troubleshooting can pinpoint the issue. Keep in mind programs that interfere with Wirecast may genuinely be out of control.

    Like
  • CraigS So, I wanted to mention  each time the install happens. I can see it in the plug in folder. The problem is when I return to Wirecast and attempt to start Virtual Camera Out Wirecast tells me I need to install it. It almost seem Wirecast is ignoring the installation or can’t find it. 

    I’ve gone so as to in install Wirecast and RE-Install, sams issue.

    Like
  • George E. Kennedy, Jr I'd need details to troubleshoot. This wouldn't be a beta issue at this point. This was an issue with Wirecast 9 beta. We're now on 13.0.2 public release. Note the comment about other software that may interfere with access.

    Like
Replies are closed
Like
  • 4 days agoLast active
  • 14Replies closed
  • 868Views
  • 4 Following