0

Problems Upgrading to 8.3

Started Wirecast and noticed that an upgrade was available.  Was previously on 8.2.  Started the install, it almost completed and then reported an installation error (a program part of this install package did not finish as expected).  This happened a couple times and I even tried to download again to no avail.

 

The machine was due to install a windows update and when I first clicked on the 8.3 installer, it restarted the machine and installed the update without starting Wirecast (I'm guessing that's expected)?

I then tried to fall back to 8.2 and that failed also in the same way.

Edit: Tried to go back to 8.1 and that failed also.

Any idea what I can do to get a functional copy of Wirecast back on the machine?

23replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Also, I noticed the 8.3 installer is much larger than the 8.2 installer.  Is this intentional?

    Reply Like
  • Dug through the Windows Event log.  Looks like there's an issue with DirectX Setup

     

    Product: Wirecast -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action Action.DirectXRedist, location: C:\Program Files\Telestream\Wirecast\rsrc\DirectXInstall\DXSETUP.exe, command: /silent

    Reply Like
  • Linden deCarmo 
    Windows 10? Another Windows OS?

    Can you run Windows Control Panels Program Remover? Please make sure Wirecast is uninstalled.
    Wirecast requires the DirectX 11 so make sure you're not on an older version.
    Make sure you're installing in an Admin account.

    Try installing again.

    Reply Like
  • Hi CraigS ,

     

    Sorry, Win 10.  Very latest maintenance release.

     

    When the install aborts, it uninstalled the previously installed version so I can't fall back or even uninstall.

     

    I ran dxdiag and this is what it reports

     

    DirectX 12

    Reply Like
  • CraigS

     

    Can I manually copy the files over from another installation if Wirecast has been installed on that machine?  I even tried renaming the program files directory to see if there was something in there that was problematic and that didn't work.

    Reply Like
  • Linden deCarmo said:
    Can I manually copy the files over from another installation

     I wouldn't recommend that.

    Have you run Windows Update to make sure your system is current?
    What GPU do you have?

    Reply Like
  • I have an NVidia GTX 1060.

     

    My system is current (see first post).  Just installed the latest Windows service pack prior to installing Wirecast.

    Reply Like
  • Linden deCarmo Do you have Virus Checking software? Try Disabling it.
    Just in case there's an issue with installer itself, download a new copy of 8.3 from our site.

    Reply Like
  • Before I posted, I disabled both Firewall & Virus Checkers.

     

    What's interesting is I just tried to install 8.3 on a second machine.  Like the first machine, it rebooted the first time I ran the install.  Second time, I installed 8.2 and that worked (it previously had a copy of 7.7 on it).  Didn't try an 8.3 install yet while I try to narrow it down.

    Reply Like
  • Linden deCarmo 
    Microsoft has this for troubleshooting/fixing potential install Issues.
    https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

    Reply Like
  • CraigS didn't help.  Fails in the same spot after running the Microsoft tool.

     

    Is it expected that the 8.3 install would be 100MB bigger than 8.2?

    Reply Like
  • Linden deCarmo said:
    Is it expected that the 8.3 install would be 100MB bigger than 8.2?

     Yes, it's certainly larger than previous versions in that series.

    Fill out the form and we'll get you a case number and investigate some other routines to run. It's definitely and Installer based issue.

    Include the things you've already tried so they don't recommend them again.

    Wirecast Support Form

    Reply Like
  • CraigS I know you said it wasn't recommended, but we're streaming this weekend so I had to get the system into a functional state for a test stream tonight to ensure this weekend will be ok.  I manually copied 8.2 from the machine I mentioned earlier and it seems to be working ok.  I know this isn't a long term solution but its working for now.

    Reply Like
  • Linden deCarmo There's always some risk with copying files given the potential for bringing over "hidden" issues. I'd test very thoroughly beforehand. That the 8.3 install failed repeatedly may mean there's a problem that the installer is finding which may well impact the current install as well at some point.

    Reply Like
  • CraigS I understand there are risks, but at this point, I don't see an alternative.  Can't install any version of wirecast now on the machine and we've got to stream tomorrow.  I streamed for about 30 minutes last night after just copying over the binaries and didn't see issues.

    I opened a ticket too.  We'll see what support says.

    Reply Like
  • Linden deCarmo Since 8.2 with copied components is working, the issue really looks to be something specifically blocking install. That it's not only 8.3 installer that won't install it seems something about your config (OS settings?) is blocking it.

    Reply Like
  • CraigS We streamed this weekend without incident with the binaries copied over from another machine.  I then examined the DirectX installation error logs to see what was failing in the Wirecast install.

     

    Others have reported the exact same issue with Windows 10 Creator Studio and DirectX redistributable failing to install. Their solution was to patch the install to ignore the DirectX install error and run the app.  This matches my experience with Wirecast.  Wirecast actually works fine and DirectX is properly installed on Windows 10 Creator Studio .

     

    I then downloaded the official Microsoft DirectX SDK Redistributable/Web Downloader and this installed without a problem.

     

    This appears to be a bug in the Wirecast Installer and Windows 10 Creator Studio.  Since I'm able to download and install the official DirectX redistributable from Microsoft, I'm suspicious that a newer redistributable needs to be packaged with the Wirecast installer.  I posted the same thing in the ticket I opened so we will see what they say.

     

    Here's the thread I found on the Microsoft Forums about this

     

    https://social.technet.microsoft.com/Forums/en-US/108f4a07-c0f9-4902-9035-2b271bbed09e/directx-unable-to-install-90c-runtime-d3dx924x86inf-the-file-may-be-damaged?forum=win10itprogeneral

    Reply Like 1
  • Linden deCarmo Since it may be an issue with the Wirecast 8.3 installer and Windows 10 Creator Studio, certainly fill out the support form. Include a description of what you found out and the steps you had to take.

    Wirecast Support Form

    Reply Like
  • Hi Craig, 

     

    I opened a ticket last week.  You may have missed my blurb where I mentioned I updated it yesterday with the same details I posted here.  I will update the thread if/when we find out anything interesting in the ticket.

    Reply Like
  • Linden deCarmo said:
    will update the thread if/when we find out anything interesting in the ticket.

     Thanks for that. Interested in hearing about the resolution of the installer issue.

    Reply Like
  • Linden deCarmo Thank you for your sharing. You are right on it! And the trick fixed my problem. I had 100% exact problem.

    Reply Like
  • Eagle Huang 

     

    Hi. I ran into the same problem installing 12.0.1 today. What exactly did you do based on the Microsoft Forum thread? appreciate any feedback.

     

    thanks,

    Domenic

    Reply Like
  • Domenic Preta said:
    Hi. I ran into the same problem installing 12.0.1 today.

     Domenic Preta That certainly isn't the current version which is 12.1. Please install only the current version.

    Reply Like
Like Follow
  • 7 days agoLast active
  • 23Replies
  • 672Views
  • 3 Following