audio not working from headphones in WC only

Greetings. We just set up WC 8.2 on a new iMac (Retina 4K, 21.5", 2017) (model iMac 18,2). Intel quad core i7 CPU 7700 Kaby Lake 3.6 GHz, 16 GB RAM; Graphics: Radeon Pro 560 4 GB. 

Capture card is BMD Intensity Pro 4K in a Sonnet Echo Express box connected to the iMac via Thunderbolt 3.

Recording to Thunderbolt 3 7200 rpm mechanical disks.

The system came with High Sierra installed so that is what we are running. 

New WC installation with WC 8.2.0

Thus far we are very pleased. We did a clean, fresh installation of everything with the exception of a bunch of AppleScript automation scripts we brought over from the old Mac Pro this new system replaced.  

The only problem we have is we are not getting any audio through the internal speakers or through the headphone jack in Wirecast. Audio from those sources works with safari, etc., only Wirecast seems to be affected. We ARE getting audio on our streams and recordings, so that is good, but it is difficult to monitor what we are sending out!  I have toggled the headphones icon on/off and between preview and live. Still no joy.

Any suggestions?

Thank you as always for your excellent product and support. This particular installation got to go from Yosemite and WC 4.3.2 on the MacPro to this new setup. NICE!

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Please check System Preferences Output Sound so the computer is sending to the appropriate output. Avoid having an Bluetooth or USB audio output devices hooked up.

    Reply Like
  • CraigS Thank you, Craig S.  We have no Bluetooth or USB audio devices hooked up. Again, this problem is specific to Wirecast only. Clearly the audio is getting into Wirecast. 

    Reply Like
  • We had a similar problem with our recent games. All other system audio works fine.

    Reply Like
  • You may also want to check Wirecast > Preferences >  General > Audio Interface and toggle it just in case the preferences might be "stuck."
     

    Dee Dee Sommers  and Rob Munzing  I really need output system settings details in order to help.

    And please make sure you're using Wirecast 8.3.

    Reply Like
  • CraigS Thank you, CraigS. I will get that information back to you. 

    Reply Like
  • Dee Dee Sommers Thanks.

    Reply Like
  • CraigS Here are the output settings on the iMac that doesn't like me to be able to actually monitor the sound in Wirecast:

    Wirecast 8.2.0 

    Output settings: Canvas size: Default 1280x720

    Stream: RTMP server to a Wowza Streaming Engine with AWS cdn

    Stream settings: custom Apple H.264 1280x720p30; 1250 Kbps Main profile; Key every 240 frames. Audio: Stereo 128 target bit rate 44.1 MHz

    Record to disk: 

    - HD mp4 Default Apple H.264 1280x720p30; 3 Mbps Main 240 Stereo 128 44.1 MHz

    - SD mp4 Default Apple H.264 640x360p30; 1 Mbps Main 240 Stereo 96 44.1

    - LD mp4 Default x264 426x240p30; 0.45 Mbps Main 240 Stereo 96 44.1

    - audio mp4 Mono 24  8.0 MHz

    We also occasionally use a MOV record to disk:

    - Default ProRes 1280x720p30 Medium ProRes, etc.

     

    Thanks!

    Reply Like
  • Dee Dee Sommers I'd need your computer audio sound settings. This would be a computer monitoring issue if Wirecast is otherwise streaming and recording audio without issue.

    Describe it as if you wanted someone to match the computer sound settings.

    Reply Like
  • CraigS Hi CraigS. I am attaching the computer sound control panel settings.

    Reply Like
  • Dee Dee Sommers Thanks.
    In Wirecast go to Preferences > General and make sure and make sure it says the same next to Audio Interface.

     

    Quit and start Wirecast and make sure this preference setting holds.
    The I suggest testing by importing a known good Quicktime video and playing that making sure you see the meters move and the Wirecast speaker and headphone icon both on.

     

    Reply Like
  • What worked for me is to check if Mix Minus is disabled (looks like a little mixing board) under your source's level.

    Reply Like
  • Yes, disabling these would remove the audio source from the monitoring (headphones or speakers) but wouldn't impact streaming/recording.

    Reply Like
  • CraigS Thank you, CraigS.  Okay so in Preferences->General, I should have the Audio interface set the same as my system's output setting?  Because I have the Audio interface set to what my input is. (Intensity Pro 4K).

    I did as you suggested: set audio interface to Built-in Output.  Saved. Quit Wirecast. Restarted Wirecast and yes, it is still set at Built-in Output.

    Also, the monitor is clicked on (bright orange).

    Unfortunately, the computer lives 55 miles from me. I will not be able to visit it until Friday afternoon. So now I wait...

     

    Thank you so much for your time. I will reply back to report.

    Reply Like
  • Deborah T Thank you for this. Yes, mine is active. But I am hopeful I had the audio interface setting wrong. 

    Reply Like
  • Dee Dee Sommers said:
    I will not be able to visit it until Friday afternoon. So now I wait...

     No problem. I understand the logistical issues with troubleshooting long distance. 

    Reply Like
  • CraigS Thank you, CraigS.  Hey, I want to clarify: in Wirecast Preferences:General -- the Audio interface should be set to Built in Output? (As opposed to the input)

    Thank you again for your help. I really appreciate you!

    Reply Like
  • Dee Dee Sommers It would be set to Built in Output.

    You're welcome of course.

    Reply Like
  • CraigS You are a genius!  Yes, the Audio interface setting in Wirecast Preferences is exactly the answer. I switched it from our input (Intensity Pro 4K) to the output (Built in Output). Bingo.  Thank you so much again, for your patient help.

    Reply Like
  • Dee Dee Sommers You're welcome of course.

    Reply Like
reply to topic
Like Follow
  • Status Answered
  • 8 mths agoLast active
  • 19Replies
  • 562Views
  • 5 Following