1

Wriecast Rendezvous / Wirecase Go connection issues

I am currently running Wirecast Pro 8.2.0 on a MacBook Pro with Sierra Version 10.12.6. I also am using an iPhone 6s with 11.2.2. I have downloaded the Current Wirecast Go App on it.

I am trying to use the iPhone camera as a source in Wirecast utilizing either Rendezvous or the iOS Cam feature. Neither are allowing me to connect.

With Rendezvous, in Wirecast, I never get any previews to show up on the bottom of the screen and in the Wirecast Go app, it just constantly says "Waiting to Join...".

If I try the iOS Cam option in Wirecast, I type in the IP address I get from the Wirecast Go app and click connect both nothing happens.

I have tried with the iPhone on LTE with no luck and when both are connected to the same network with no luck.

I am not sure if I am running into a network issue within our companies firewall or if I am doing something incorrect in my process. Any insight would be appreciated.

21replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Try uninstalling Wirecast Go on the iPhone. Hard Power Off the iPhone. Turn on the iPhone. Download and install Wirecast Go again making sure it gets access to the camera and mic. Quit and Start Wirecast. Send a New Rendezvous link to the phone and see if it works.

    For Wirecast Go using the Cam feature try lowering the Maximum Bitrate and set Direct Cam To Wirecast to Always Allow.

    For the Cam features, the Firewall can certainly be an issue. Also the iPhone, when using wifi should be on the same LAN and Subnet.

    LTE shouldn't be a problem if you have enough bandwidth (that can be an issue).
    If you're seeing Waiting to Join then the Wirecast computer should see a red dot requiring to Accept the Guest caller.

    Like
  • Do watch this Rendezvous tutorial

    Like
  • And this Wirecast Go Cam tutorial.

    Like
  • CraigS I have uninstalled the app on my phone and restarted. I made sure the camera and microphone were enabled. Had the same results. Even with the lower bitrate and Always Allow settings.

    I looked at the Cam option again and ensured that the laptop and the phone were both on the same LAN and subnet. However when I enter the IP address in and click connect, the preview window on the right just shows black. After watching the tutorial again I noticed it did the same thing there so I thought maybe I just need to close it and it will show up as a shot in Wirecast. It doesn't pass video though. No live feed from my phone. It does appear to be connecting because if I try to add it again it says it is already connected.

    I am starting to think there is something in our firewall or VPN client I am using that won't let me pass video.

    Like 1
  • Zach Hullinger Can you try taking down your Firewall temporarily? Perhaps a port is blocked that Go might use.

    Like
  • Could be tough to do here at work. I will look into it further. Just wanted to make sure there was nothing else I was doing wrong. Thanks for the info.

    Like
  • Zach Hullinger The Firewall can certainly be an issue for both iOS Cam use and Rendezvous. Although using LTE for Rendezvous shouldn't be affected since that isn't using your LAN.

    Like
  • I have almost the same experience as  Zach Hullinger .  I was just testing out Wirecast 8.2 and hadn't used an iOS cam for a while with this version.  Installed the Wirecast Go app on iPhone 8 running latest iOS.  Got the request to access and it connected and was a live shot in Wirecast.  Then I don't know what happened, as I was exploring it, and after adding some layers to a shot, the shot went black on the iPhone, and stopped passing video.  I tried quitting, app, restarting iPhone, restarting mac. I uninstalled Wirecast Go on iphone.  Wirecast recognizes my phone but when I click "Connect" nothing happens.  The preview window shows a selected object as if there were a signal coming through but there is no video.   I must say I'm not getting my head arount the UI on that iOS app particularly well.  It worked for a while, now it doesn't....  Weird...???

    Like
  • I was able to get my Wirecast Go to connect and display in wirecast. I wish I could say exactly which step I took was what did the trick (and also that I'm not concerned it will happen again when I "need" it not to...) but I did disable my firewall on my mac running wirecast, deleted any previous shots/references to iOS cams in wirecast, powered down the iPhone and the mac.  Started wirecast up first then Wirecast Go and then Wirecast started recognizing the iPhone again and asking for permission. Then it was viewable in Wirecast. But I don't know exactly which of these steps or combo of them did the trick.

    The reviews in the App store certainly tilt towards terrible, with several weird problems noted.  Sounds like the app needs more work.  Hard to call it a reliable second camera input at this point.

    Like
  • Ken Adams Firewall will be a problem with Wirecast Go on LAN. In those cases using Rendezvous with LTE may be better.

    Like
  • CraigS Craig, can you provide any information about which port it is that Go uses?

    Like
  • Zach Hullinger Go generally doesn't use a specific port (it'll vary).

    Like
  • I'm having a similar issue.
    I'm operating on a Macbook Pro 2016. I create my Wirecast session, and then create a new Rendezvous session. I then send out the Rendezvous session link to my clients' assistant. The assistant joined the Rendezvous session via a desktop computer with a webcam, but I only saw black. The assistant also only saw black, but she said that she could see her own webcam feed on her end. I tried the basic re-starting of Wirecast, creating a new Rendezvous session and starting over, etc. to no avail.

    We then wrapped up that attempt and I repeated the process but with somebody on our staff in my physical building. When they joined via their desktop computer and webcam, it worked totally fine.

    What could be my problem? Is it most likely my client's computer? They performed a speed test and had ample internet speed. Could it be their system hardware requirements not being up to scratch? Or is it more likely their firewall / my firewall? Your input is appreciated.

    Like
  • Derrick Minyard said:
    he assistant joined the Rendezvous session via a desktop computer with a webcam, but I only saw black. The assistant also only saw black, but she said that she could see her own webcam feed on her end.

     It might depend on the browser. I've seen issues caused by browser updates and then later fixed by another browser update. 

    You could test locally to see if there's an issue on your end.

    One should test in both Chrome and FireFox to see if it works in either.

    Like
  • CraigS thanks Craig.

     

    how might I test locally? I’ve already invited my co-worker to join the rendezvous session on their computer using a webcam and it worked.

    I can also confirm my client was using the most updated version of Chrome.

    Like
  • Derrick Minyard said:
    I’ve already invited my co-worker to join the rendezvous session on their computer using a webcam and it worked.

     Which may indicate that the remote guests may have some compatibility issue with the browser. Was your local co-worker also using Chrome. Same version? Same OS?

    Like
  • CraigS My co-worker was also using Chrome fully updated. We haven't tried Firefox on my clients' computer yet.

    If that doesn't fix it, would the next option be to check my client's company firewall settings? How would we fix a firewall issue?

    Like
  • Derrick Minyard said:
    Chrome fully updated.

     Need specific version number of Chrome and OS.

    Derrick Minyard said:
    How would we fix a firewall issue?

     They can disable the firewall even if it's just a test to see if that fixes it.

    You may want to test to see if you can test with them using this.
    Testing to you with this can indicate if the Firewall is the issue as you won't see them here either.
    https://appear.in/telestreamtest

    Like
  • Derrick Minyard 
    In addition to testing above have them try this in FireFox and Chrome. Most important is Connectivity.
    https://test.webrtc.org/

    Like
  • Turns out it worked for my client in Firefox. Problem is solved now. Thank you.

    Like
  • Derrick Minyard Great to hear. Sometimes one or the other browser works better depending on browser updates.

    Like
Like1 Follow
  • 1 Likes
  • 1 yr agoLast active
  • 21Replies
  • 852Views
  • 5 Following