0

XKeys sometimes requires second press

Wirecast 15.0.3 on MacOS 12.4, Mac mini M1 with two monitors.

We use an XKeys device, and previously had been using it with Wirecast on the Windows platform. Moved to a Mac about six months ago.

Ever since the move to the Mac, we're noticing that actions on XKeys sometimes require a second keypress to be recognized. This happens about 10% of the time, with so far no recognizable sequence of steps that can reproduce the problem reliably. We notice this most often on the Go key -- the first press does nothing, a second press executes the action. This problem was never noticed when we were on Windows with a PC laptop.

Is this is a familiar/known problem? First thought was some kind of focus issue with application windows, but this doesn't seem to be the case.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 mth ago
    • Reported - view

    Please update to macOS 12.5 as that can impact XKeys.
     

    Make sure the XKeys is directly into the computer and not through a hub or dock. For testing make sure there's no other USB device on the same bus (which may well be another port) that might interfere with the XKeys signal. Then start Wirecast and use a new document and test.

    Like
    • CraigS Thanks, I've made those changes and will monitor for any improvements.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Jonathan Taylor Thanks for doing that.

      Like
Like Follow
  • 1 mth agoLast active
  • 3Replies
  • 6Views
  • 2 Following