Many clips selected when I drag!

I did a quick search for an answer but nothing. I'm on SF6 (can't update yet as it is a work installation). MacBook Pro. Sierra. If I have one clip selected in the timeline and I then drag along the time ruler to get to a different location, most times multiple clips get selected. Sometimes I can have one clip active and just clicking elsewhere selects many clips (no shift key). I thought it was my mouse but I've tried both my Apple Magic Mouse and a regular cheap wired mouse. Here is a link: https://vimeo.com/273491022 .

Is this designed behaviour or operator error? It's maddening! Thanks.

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I don't recall any other reports of an issue like this. It looks like you might be grabbing or lassoing all clips at the scrubber. I can't duplicate the issue with 6.2.4.

    Reply Like
  • If you viewed the video, that's what happens a lot. I may be working too fast but I can't see how I'm selecting multiple items as I deliberately click and drag on the time ruler which should avoid such a situation. It happens less often with my HP wired mouse than the Apple mouse but it's happened a few times this morning!

    Reply Like
  • And sometimes one click on the time ruler does this ... see screenshot.

    Reply Like
  • Since 6 was released in June 2016, is this the first you're experiencing this? I haven't seen any other similar reports in two years. Are you on the last version of ScreenFlow 6 which is 6.2.4?

    It looks almost as if you're triggering the All Clips after current Clip selection

     

    Reply Like
  • Roger Shufflebottom I'd suggest creating a New User Admin account and go into that account and start a new project and screen recordings and test there. That will determine if this a user or system issue.

    Reply Like
  • I thought I'd replied but I can't see it ... anyway, I've gone in as a different Mac user account and things seem OK. I can't upgrade to v7 yet (work issues) but I'd like to reinstall as 6.2.4 (I am on 6.2). Is that version available on the Telstream site?

    Reply Like
  • Also, the 'All Clips' thing doesn't seem relevant as I'm getting c;lips on multiple tracks.

    Reply Like
  • Reply Like
  • CraigS Thanks. I will try that.

    Reply Like
  • Roger Shufflebottom 👍

    Reply Like
  • CraigS OK - I have installed 6.2.4 on my existing Admin account. The issue still occured. I then created a new admin account, as you suggested. This seems to have eliminated the issue but I can't keep switching accounts, just to use Screenflow! I really like Screenflow but this is a major irritation. Are there any preference or other files I can delete from my existing account to fix this? Thanks. I did find an older copy of Screenflow (5) in my Applications folder - might this have caused issues (I have deleted it now)? I've also got an app called Magicprefs which works with a Magic Mouse but I'm using a regular mouse at the moment.

    Reply Like
  • Roger Shufflebottom said:
    Are there any preference or other files I can delete from my existing account to fix this?

    If the steps below don't fix it, it may be an issue in the User Account's own preferences or settings.

    Delete ScreenFlow Cache:
    1) Make sure ScreenFlow is not open. (save any work in progress)
    2) Open a new Finder window.
    3) Select the "GO" menu top of screen, Hold "Option" key with menu open, and select the "Library" that appears.
    4) In the Library folder open Caches folder.
    5) Delete ALL folders that start with “net.telestream.screenflow(4/5/6)”
    6) Empty trash.

    Part 2:

    Reset ScreenFlow Preferences:
    1) Make sure ScreenFlow is not open.
    2) Open Terminal and copy and paste this command and press Enter:To open "Terminal" (Finder > Applications > Utilities > Terminal).
    defaults delete net.telestream.screenflow6

    Reply Like
  • Thanks. I followed those steps and things seem more stable but still not right. I'll get rid of Magicprefs and see if that helps.

    Reply Like
  • Roger Shufflebottom There's some variable that's different between your normally used account and the new account. Another place to look might be Accessibility or any programs that might impact the timing of mouse or keyboard/keystroke use.

    Reply Like
  • Hi - update. I removed Screenflow 6 from the Applications folder and then followed your steps again. I then looked in the main Library (not my User Library) and found a net-telestream item in there which I deleted. I then deleted the MagicPrefs app and cache or plist (I forget which). I then re-installed Screenflow and so far so good. So, it may have been Magic Prefs (extra features for the Magic Mouse) that may have been the culprit. Thank you for your patience!

    Reply Like
  • Roger Shufflebottom You're welcome of course and good to hear you solved the riddle. It may help other users with equally perplexing issues even in method of troubleshooting such.

    Reply Like
reply to topic
Like Follow
  • 2 mths agoLast active
  • 16Replies
  • 93Views
  • 2 Following