0

ScreenFlow 8 - Font rendering issues...

I've been using ScreenFlow since V2. (Currently 8.2.3) In the last 2 versions (7 and 8) I've been having consistent font rendering issues, currently creating open captions using Arial Narrow and using the same font, format, size and settings for years on a client video series. Lately when rendering, it's like each character of the font is incorrectly rendered. It displays perfectly in ScreenFlow and used to render perfectly as well. Any insight as to what has changed with how fonts are dealt with? Image attached showing the appearance of type in SF Interface, current render, and former render. The spacing difference is that in order to try and resolve the issue, I was messing with kerning to no avail. (That's why the old render appears wider, but the kerning makes NO difference in the render issue...) any help would be appreciated. I'm having this issue on about 80 videos at the moment, that I will need to fix and re-render.

I'm hoping the image I upload doesn't get too much additional compression and can be viewed at 100%.

Thanks for any insight and suggestions... I'm on Mac 10.14.6, but this has been a problem since prior to Mojave and is STILL a problem on my machines that are running the Catalina beta as well. I'm flummoxed.

33replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    Also, to follow up, this happens with different fonts as well, not just Arial Narrow. I'm currently using 36pt for the size, which has been consistent for years, however at larger sizes like 72 or higher, it is not an issue.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    You mention rendering but I assume you mean exporting. Export settings may be a factor. 
    Please test with a ProRes export and show us how that looks

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    HeyJoe  

    Just a quick comparison. Left ScreenFlow, Right ProRes 422 export.

    Arial Narrow 36pt

     

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    HeyJoe  screen cap from the 1080 export so you can see the actual size.

    Looks OK. Nothing like yours.

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    Also - all MY files are 800 x 768 all the way through the system - SF project, renders, etc., Somewhere a few versions ago the issue started up...

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    CraigS I've tried PR422, 2 different h264 and many more...

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    CraigS I've tried PR422, 2 different h264 and many more...

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    HeyJoe  800x768 ProRes422  Arial Narrow 36pt ScreenFlow 8.2.3 macOS 10.13.6

    Sorry but I'm not seeing the issue. Perhaps we can look at your project on our computers.

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    Here's a sample file for you! I've tried rendering in PR422, h.264 in several output options. I've re-installed Arial Narrow. Running 10.4.8 on a Core i9 MacBook Pro 32 GB ram, Radeon 560x (and also tried with my eGPU)

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view
    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    Wow, ScreenFlow files or ZIP files are not supported for upload. Try this?

    https://we.tl/t-nyad3ETtnh

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    It also appears to be specific to THOSE text boxes. If I create a NEW text box with the same font and same settings and type into it it renders fine. Can't figure out any specific settings on the text boxes I have for my open captions - no funky scaling or anything like that. They look PERFECT in the SF editor - ONLY when rendering do they get all crusty. (Again, in prior versions they didn't...)

    I'm sure someone is saying; "no big deal, grow up, quit whining and just make a new text box." The problem is that there are 1000's of these text boxes across well over 500+ videos. The task is profoundly daunting for something that changed with a software upgrade... Ugh.

    Like
    • HeyJoe
    • HeyJoe
    • 3 yrs ago
    • Reported - view

    I can basically put ANY font in my existing text boxes and it now looks crappy on render...

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    HeyJoe  Yes, I see the same problem on my system. Exported ProRes 422 and took a screenshot.

     

     

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 yrs ago
    • Reported - view

    HeyJoe  I even experimented by repositioning it. It still looks bad. It's as if the text box is itself the problem. yet it looks fine in ScreenFlow. 

    Fill out the form and include the link to the project. You can link to this forum thread as well so they can look at the screenshots too. You can mention that I verified the issue and seems specific to the text box.

     

    ScreenFlow Support Form

    Post your case number hear when you get it and I'll help them verify and investigate.

    Like
    • Mike BW
    • Mike_BW
    • 1 mth ago
    • Reported - view

    Has a solution been found to this issue?  I am running into the same thing now.  I have 6 video projects all using the same animated text as a lower 3rd element.  I didn't notice it until the last video but all of them seem to have some irregular scaling in the final exported version versus when viewed within ScreenFlow.  I've also tried ProRes 422 output, to no avail.

    ScreenFlow 10.0.6, macOS 12.12.1, 16" MacBookPro M1Max, 32GB, 2TB.

    Screenshot showing exported video on top, and video within ScreenFlow on bottom.

      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW Sorry about that. Keep in mind no one has posted on this thread in three years and the last poster never included a case number for me to investigate.

      If it looks good in ScreenFlow it might be an export issue. We need the exact setting including font, font size, Canvas size, and export setting including frame size.

      Like
      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS Helvetica Neue, 36, Align Left, Bold.  Solid Color Fill (white).
      Canvas preset- 1080p. (1920x1080, 30 fps)
      Export - 1920x1080, 100% of original, *
      H.264 @ 6Kbps, and ProRes 422.

      * Note I've also tried a 1280x720 with similar results.  Scaling 1080p by 101% on Export yielded slightly better text but still not as good as in Screenflow.

      When I export to 3840x2160 the rendered output file looks perfect.  So I can do that and run it down to 1080p with Media Encoder, or even ScreenFlow I suppose.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW 
      If you're willing to zip a copy of your document (place it in folder and zip it to keep it intact), I can test it on my systems. You can attach it here

      Like
      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS See attached project file with the text box in question, along with a 1080p and 4K export directly from Screenflow.

      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 mth ago
      • Reported - view

      Mike BW Thanks for the project although the School Address shows as Helvetica, not Helvetica Neu and that may change the kerning.

      Like
      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS That is really strange.  I can see when I open that project and select that text layer for the first time it does indeed say Helvetica in the Text Inspector, but then if I deselect the layer and then immediately select it again, now the font is shown as being Helvetica Neue in the Text Inspector.  Can you confirm that on your end?

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 mth ago
    • Reported - view
    Mike BW said:
    Helvetica Neue, 36, Align Left, Bold.  Solid Color Fill (white). Canvas preset- 1080p. (1920x1080, 30 fps) Export - 1920x1080, 100% of original, *

     When I use your settings and export, the "i" in Smithsburg is not clipped.
    This is a screenshot of the exported file in Quicktime.
    The softening is normal given the compression.

     

    This is how it appeared in ScreenFlow with your settings.
     

    Like
      • Mike BW
      • Mike_BW
      • 1 mth ago
      • Reported - view

      CraigS Thanks for trying to reproduce the issue. 

      Which codec did you use?  I am not too concerned about the softening.  What stands out to me in your example is how the kerning seems to have changed,
      EDIT- especially between the "i", "t" and the "h", in Smithsburg.  /EDIT
      It's almost as if the text in the box is being rendered at a different resolution and then scaled back up to fit the rest of the project.

      As I said in my last post, I can get it to where I like by exporting to 4K and then transcoding to 1080p.  Not ideal, but a functional workaround at least.  

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 mth ago
    • Reported - view
    Mike BW said:
    Which codec did you use? 

     Automatic Normal (6000kbps H.264) 100% of the original. 

    Mike BW said:
    between the "i", "t" and the "h", in Smithsburg.

    Perhaps it's perception given the screenshots are different sizes although I do see a difference in "mi" and maybe the "i" and "t" crossbar for example.
      

    Like
Like Follow
  • 6 days agoLast active
  • 33Replies
  • 64Views
  • 4 Following