Trouble with Logitech HD Pro Webcam C910 and Webcam Settings Version 2.3 together with Wirecast.

 I suddenly encountered problems with the HD Pro Webcam C910 USB along with Wirecast in a Macbook with OS X El Capitan version 10.11.6.
The image is unclean and fuzzy, but in Logitech's own Logitech Webcam Software application the image is sharp, as it was previously on the same computer, and Wirecast, but with OS X Maverick 10.9.5
Any idea?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • It's not clear what version of Wirecast you're using.
    I have C910 and Webcam Settings 2.3 as well. I don't really need Webcam Settings in Wirecast 7.7 as Wirecast allows me to chose the C910 codec, frame size, frame rate and also allows me to use Shot Layer Properties, Color to further modify the look.
    Webcam Settings hasn't been updated for well over three years so it may be developing compatibility issues.

    Reply Like

  • Hi CraigS

    Nice to meet you again in this new forum.

    In the old I had my profil and did the same in the new forum:

    Wirecast 4.3.2 upgraded to 6.  Sony PD170 via Firewire and USB Logitech HD Pro Webcam C910 with Webcam Settings Version 2.3.  Sony XDCAM EX3,   Macbook Pro 15" Retina, Late 2013, Haswell 2.6GHz Intel Core i7, 16GB RAM, GeForce GT 750M, OS X 10.11.6 El Capitan.

    Reply Like
  • Robert Berthagen Hi, make sure you're on Wirecast 6.0.8 which was the last in that series.


    I did a cursory test using Wirecast 7.7, Logitech C910, macOS 10.12.6 and Webcam Settings 2.3 and was able to use it to change various aspects of the C910 without issue. The image resolution and frame rate were very good.

    Reply Like
  • Hello, I am having the same problem with my C920. It was working fine and now it does not. It is fussy and the image is bad.

    I have Wirecast Version 7.7.0 (31342)

    MacBook Pro (Retina, 13-inch, Early 2015) with MacOs Sierra 10.12.6

    Please help!

    Reply Like
  • Stacey Scannell Saldarriaga There's no reported issues with the C920 and Wirecast. I have two of them myself. You have control of the settings in Wirecast, System Device Properties pane Video Settings. USB buses can run into bandwidth limits so it's best to use it on a bus with no other devices on it.

    Reply Like
login to reply
Like Follow
  • 1 mth agoLast active
  • 5Replies
  • 90Views
  • 3 Following