0

Mac OS compatibility

Hi Guys, just want to ask if the latest switch 5 pro can run in Mac OS high sierra and lower version of Mac Os? Thanks

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 mth ago
    • Reported - view

    Switch 5 series needs at least Big Sur. You'd need Switch 4.1.1 ideally for High Sierra and 4 for Sierra. You can try Switch 5 but it's possible some (newer) features might be "wonky" (that's a technical term) or features moved to depend on newer OS functions (not sure which because we don't test that for older OS). It might be possible that a current license might run the older versions for you (or we might be able to assist in that).

    Like
  • Thanks Craigs, That's the other one I also want to ask, if the current license can run on the older version. just want to be sure before we purchase the latest version.

    Like
Like Follow
  • 1 mth agoLast active
  • 3Replies
  • 9Views
  • 2 Following