1

Wirecast Virtual output to Skype, not available in calls

  • Windows 7 (7601)
  • WirecastPro 6.0.8
  • HP Zbook17 i7-4930MX @3.00GHz 32Gb ram
  • Wirecast Canvas size 720p

I am trying to send my Wirecast output into a Skype call. I have the Wirecast virtual camera out set to HD720p with Virtual Microphone enabled as well.

 

In skype the settings I see look good and I have picture.

Even when I'm starting a call I can see the Virtual Camera before the call answers.

But when the call connects the virtual camera feed stops and goes away and the enable video icon turns to this and I cant start it back up.

The virtual microphone still works and I can hear the Wirecast output but don't have video.

 

Is this even a Wirecast problem? Is this a Skype issue? I don't think it is a bandwidth issue the other end of the call is able to send video back. 

116replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This may be unrelated, but still worth noting - the Microsoft Windows 10 Anniversary Update contained code that attempted to allow multiple programs to share a webcam stream. But, since no good deed goes unpunished, this caused other problems (the link goes to a report on Thurrott.com), and the fix for those problems was to disable streams from devices using h.264 or MJPEG. Oops - that 'broke' things like Logitech C-920 cameras using Skype. (I don't know how or if a Wirecast Virtual Camera feed was affected). 

    This happened last August with the initial run of Windows 10 Anniversary Updates, and it was fixed before my machines saw the update in early October. 

    I don't know what the fix included. It looks like it didn't include the original plan - the ability to share cameras. Skype still reports that it can't use my Logitech cameras when Wirecast has hold of them first.

    Again, it may be unrelated, but the timing seems right, especially if this is only happening on Windows 10 machines that have the Anniversary update. I don't have anything with 7 anymore to test it. 

    And for what it's worth, the Thurrott article notes a Registry edit that made Logitech cameras work again before the Microsoft update fixed the problem. I tried that just now, and it did not fix the Wirecast/Skype problem.

    My workaround (using Skype's Share Screen feature) continues to work, though it's a few clunky extra steps, and the person I'm calling can't see my video until I go through the steps. 

    Reply Like
  • Gary Pearce thanks for that. We continue to investigate.

    Reply Like
  • @Gary Pearce I first encountered the problem when I was running Windows 10 (pre-Anniversary edition). It was the 11/2015 build. So I don't think anything in Anniversary specifically broke this - at least for me. My PC now has Anniversary on it (darn those auto updates) and the problem continues for me. I am going to give the screen share option a try since there doesn't seem to be an ETA on a fix. 

    FWIW, I also tried a version of Skype from March when I know this was working and I even went as far as reverting to WC 6.06 (the version I had in March) but this didn't fix it. Knowing Microsoft's track record for not cleaning up registry entries, shared DLLs and the like, I realize that uninstalling and downgrading doesn't necessarily always get you back to exactly where you were.

    Unfortunately, I'm not up to trying to rebuild my PC from scratch with pre-Anniversary edition, old Skype, old WC, so I'm either stuck on somebody releasing a fix or trying your workaround (thanks for that, by the way!). I fear this is such a niche problem that we will have a long wait for a resolution.

    Reply Like 1
  • Let's hope Microsoft addresses this sooner rather than later. 

    Reply Like 1
  • Experienced same problems that all of you, solved uninstalling skype and installing previous version, 7.0 from this link. Hope this helps you while skype fixes the issue. https://software.com/windows/social-networking/skype/7.0.0.102

    Drum!

     

    PS. Uncheck automatic upgrades in advanced skype options

    Reply Like
  • juan cruz Thanks for that. 

    Reply Like
  • np craig, you helped me hundreds of times... glad I could help.

    Reply Like 1
  • Thanks. 

    Reply Like
  • Hi everyone...this issue is still not resolved...and to add to my misery, Skype just locked me out of the legacy version I was using (6.21.0.104). Once again, I have found a workaround by using the legacy version 7.0.80.102; but it's only a matter of time before it too becomes obsolete. Wirecast...this is a pressing matter. Please fix.

    Reply Like
  • Daniel Kay Please test with current versions.
    Wirecast 7.4
    Skype 7.47 on Mac
    Skype 7.33 on Windows

    Reply Like
  • CraigS Already tested...that's what motivated my update...very frustrating!

    Reply Like
  • Daniel Kay Using your case number report that you've tested naming Wirecast and Skype version and it still fails on the call.

    Reply Like
  • CraigS Where will I find a 'case number' Craig?

    Reply Like
  • Daniel Kay When submitted the issue (about 5 months ago?) to our support we'd send you a case number. 

    Reply Like
  • CraigS I've raised a new ticket...

    Reply Like
  • Daniel Kay Thanks for that. I don't doubt they'll find that you've reported before so they might combine them.

    Reply Like
  • CraigS Cool. 

    Reply Like
  • Ive upgraded skype on windows 7 and could use wirecast as normal IF I call to another account with mac LION... but when calling to another windows user... im same as you... im about searching that legacy version 7.0.80.102

    Reply Like
  • coud someone that has legacy version 7.0.80.102 provide me a link to download? every version I try is 7.33...

    Reply Like
  • version 7.0.85.100 is working. ive downloaded from a site called uptodown. 

    hope it helps you

    Reply Like
  • Sounds like it really is something Microsoft has done to Skype. Make sure you use the support form and report to us as we do let Microsoft know. You may want to report to Microsoft as well as a Skype user.

    Reply Like
  • OK, everyone. Here is the reply from support: 

    "...After testing other units, and not finding a similar trend, I contacted my development team, and they have been working with Skype on the issue. The latest update was that Skype 7.16.0.102 was the latest version that did not encounter a problem. I will add your case to the bug report, and let you know when we have an update."

    ...and so we wait!

    Reply Like 1
  • Daniel Kay  On versions 7.0.85.100 and 7.16.0.102  im experimenting problems sending messages to skype windows users. Anyone else with same issues? Any way to solve this?

    Reply Like
  • juan cruz I'm not experiencing that issue...

    Reply Like
  • im on windows 7. which OS r u using? thanks!

    Reply Like
Like1 Follow
  • 1 Likes
  • 2 yrs agoLast active
  • 116Replies
  • 3794Views
  • 11 Following