1

Wirecast Virtual output to Skype, not available in calls

  • Windows 7 (7601)
  • WirecastPro 6.0.8
  • HP Zbook17 i7-4930MX @3.00GHz 32Gb ram
  • Wirecast Canvas size 720p

I am trying to send my Wirecast output into a Skype call. I have the Wirecast virtual camera out set to HD720p with Virtual Microphone enabled as well.

 

In skype the settings I see look good and I have picture.

Even when I'm starting a call I can see the Virtual Camera before the call answers.

But when the call connects the virtual camera feed stops and goes away and the enable video icon turns to this and I cant start it back up.

The virtual microphone still works and I can hear the Wirecast output but don't have video.

 

Is this even a Wirecast problem? Is this a Skype issue? I don't think it is a bandwidth issue the other end of the call is able to send video back. 

116replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Thanks. So far in our testing it does seem to be a Skype issue. 
     

    Have you tried Skype with other virtual camera software such as Manycam?
    We did a quick test and that didn't work either so it does seem to point to Skype as the issue.

    Like
  • I haven't tried sending my manycam video but I have received video from skype when having the caller in a skype shot; that user having the same setup as me, windows 7 ultimate and skype 7.26. In fact, they are using manycam to send video to me; when I try and send them MY wirecast virtual cam so they can see the live show, which obviously they can't thus the above issue.  So is this skype's problem or manycam's just to make things even MORE confusing. lol

    Like
  • Tested on our end with Manycam with mixed results.
    I am suspecting it was recent Skype update that created the issue because I'm also seeing it in Wirecast 6.0.8 which previously worked.

    Like
  • With yet another skype update to 7.27 I just got today. lol Maybe skype solved it for us, I'll test it later tonite with my callee.

    Like
  • I tested on 7.27 earlier today. It didn't work for me.

    Like
  • okee dokee. Thanks:)

    Like
  • We are investigating this of course.

    Yvilene  Fill out the form as it may help us work on the particulars.
    Wirecast Support Form

    Like 1
  • OK, CraigS  . Here's my update...

    I decided to try rebuilding my Wirecast file...and to my delight (using 7.1) I have regained control of Skype. Interestingly, though, despite the fact that the virtual camera output is working, when I call someone they cannot see me. But when we hang up and they call me, it all works.

    I can work with this annoyance...but it certainly does suggest that the glitch is on the Skype end of things.

    Like
  • Daniel Kay I've noted the same issue. Which direction the call comes from is a factor. Making the call seems to be the issue. Please fill out the form or respond by email with your case number with that information if you've already filled out the form.

    Like 1
  • Is there a way I can switched the thread back to unanswered for now. It looks like you guys are are digging up some more unsolved issues and I just got lucky with the problem for myself resolving.

    Like
  • Set back. I do think it may be a Skype issue though since Virtual Camera does show up. We'll find out.

    Like
  • I got this today from support: 

    Our developers are aware of the issue, and have identified it as something that was broken by an update to Skype. We are contacting Microsoft to resolve the issue.

    In the meantime, we can suggest a workaround of rolling back to a previous version of Skype, which you can download here:https://web.archive.org/web/*/http://download.skype.com/msi/*
     

    Like 1
  • Yvilene thank you very much for that information. As suspected, Microsoft Skype changed something.

    Like
  • Any update on this issue? It's preventing me from using WC and Skype to record my video.

    Like
  • Mike K we're still working on it. Keep in mind it may involve Microsoft doing some work. We'd have no control over that. Do fill out the form I posted previously. That way we'd have your information just in case we need to contact people to check some things.

    Like
  • I have had this problem for the past two months.  After several calls to Skype I found out it was an error caused by their update.  They rolled me back to 7.0 and I have not had the problem since.  Just make sure you disable "auto-updates" otherwise it will only work for your first call and then autiouodate and you'll think it's broken again like I did.  Hopefully Skype fixes this soon!

    Like
  • Could you please post a link to download the specific version of Skype that works for you? There are several 7.0.blahblah versions online but which version exactly, for Windows and what's the full version number? A direct link would be great if you can, thanks!

    Like
  • Craig, I submitted the form per your request. Thanks, Mike

    Like
  • Mike K Thanks 
    Moxu can you include the full version number of Skype that's working for you (7.0.xxxx)? I think many users would be most grateful for that info.

    Like
  • WORKAROUND: I have an external, full-screen monitor (Output/External Display Output), so I tell Skype to Share Screens (Call/Share Screens, then it opens a box to choose the screen. I choose my Full Screen external monitor). The result is the same as if Virtual Camera was working - the other party sees my Wirecast output.

    I have the problem exactly as others described it. I see the Virtual Camera in Skype Tools/Video, but when the connection starts, I can't send video. A few times the Virtual camera worked when I received a call... sometimes. That didn't work tonight. I had also been making calls to an Android phone and tablet (Nexus devices running Nougat). So tonight I also tried calling another PC - same failure. Didn't matter who called who.

    I shut down Wirecast and let Skype take one of my Logitech 920 webcams, and that worked fine. Only the Virtual Camera failed.

    Wirecast Pro 7.1.0 on Windows 10
    Skype 7.28.80.101 on both ends

    The Share Screens workaround keeps me going, but it would be good to get a fix.

    I just submitted the form to add to the record.

    Like
  • Thanks Gary Pearce for that workaround. 

    There's an issue with Wirecast Virtual Camera and Skype when making calls with Skype from Windows 10. It seems a Skype update broke compatibility. We are investigating but it may require a fix by Microsoft Skype.

    Like
  • Any update on this issue? My Logitech C920 USB webcam works fine in Skype. But when I use it as a source in WC, it stops sending video once the call connects (even though it shows in Skype in preview and when the call is initiated). Same holds true for my camcorder through an Intensity Pro and WC. 

    I confirmed that this behavior is also an issue in WC 6.06. I've also tried with an older version of Skype that I know used to work. So my guess is there was something in Windows 10 and not necessarily Skype (?) that broke this. I don't have a Windows7 system to try this out on unfortunately.


    Thanks, Mike

    Like
  • Mike K you should fill out the support form that I previously posted if you haven't already. It may be an issue that Microsoft has to fix though. Keep in mind that Microsoft is both the OS and Skype so it may involve elements of both.

    Like
  • CraigS I filled out the form when you originally asked. Understood on Microsoft's role. But this problem doesn't occur in Skype when using the webcam without Wirecast. So they will need a push from you folks to make sure they know that there is an issue with virtual camera output. 

    Like
  • Mike K Microsoft is aware of the issue. We can't speak to how they prioritize issues though.

    Like
Like1 Follow
  • 1 Likes
  • 2 yrs agoLast active
  • 116Replies
  • 3853Views
  • 11 Following