Wirecast 8 Multi-Viewer Output only working on 1 Screen

Hello,

On my PC I have 2 external TV's connected via DisplayPort (to HDMI conversion).

When enabling Multi-Viewer Output, I can only ever get one of the screens displaying it, despite selecting either in the dropdown and assigning shots to them.

Is this a known issue? I cannot find anything to remedy this online.

Thanks in advance,

Chris

26replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • What OS and, more importantly, GPU are you using?

    Reply Like
  • Windows 10 64bit and Geforce 1080ti

    Reply Like
  • Chris Trott Thanks for that. Do file out a report for this issue and we'll investigate to see if there are any GPU or equivalent limitations to MultiViewer

     

    Wirecast Support Form

    Reply Like
  • I am also having this issue on a Mac.  Strange thing is, it worked correctly the first time I tried it.  When I connect an external monitor to my mac, then configure the display with layouts and assign shots, then select the monitor to output to, it appears on the main mac monitor and not the one I selected.  Very strange.

    So now I have the selected monitor output overlaid the main display and when I select Identify displays, both 1 & 2 appear on the same monitor.

    Wirecast 9.0.1

    Mac OSX 10.13.6

    16GB Ram

    2.2 GHz i7

    Intel Iris Pro 1536 MB Graphics

    Reply Like
  • Exact same issue here.  

     

    Wirecast 9.0.1

    Windows 10 Home

    16GB Ram

    Core i7 8700K

    Gigabyte 1050Ti

    Two identical (Sceptre E24) monitors. Monitors identify themselves correctly as 1&2 even with the multi viewer configuration utility.  Wirecast shows both.  When I select #2 and enable the display it always shows on #1 regardless.  

    This is a dealbreaker for our setup.  Any help appreciated.  

     

    Thanks!

    Reply Like
  • Ob coc said:
    Two identical (Sceptre E24) monitors

     I wonder if this is the cause in your case. Wirecast not properly differentiating between two matching monitors. Fill out the previously posted form and we'll investigate.

    Reply Like
  • Tony Darnell What monitors are you using? If you reboot the computer and start Wirecast and use a New Document do you still have the issue?

    Reply Like
  • CraigS I'm using a mac cinema screen on a mini display port and the second monitor is the HDMI out going into a Star Tech USB3HDCAP video capture box.  The second monitor (the vid cap box) works just fine, I can see my mac desktop on the Wirecast instance on a Windows machine.

    I'm running a zoom meeting and wirecast on a mac (using a screen capture shot), then outputting that meeting into my Wirecast instance on a Windows laptop (to reduce the workload on one laptop). 

    Since this issue started, I've stopped using the wirecast instance on a mac and just output the zoom meeting directly into the vid capture box, then use that as a shot in Wirecast on my windows laptop.  This isn't ideal since I can't use my good camera anymore, but it's better than nothing.  I really wish Rendezvous worked.

    Reply Like
  • CraigS Oh forgot to answer the other part of the question. Yes, I've rebooted, restarted wirecast, started a new document, all of those things and issue persists.  The mac OS certainly shows the monitor but when I go do setup the monitor output, it just goes to one monitor, the cinema monitor.  Both 1&2 are overlaid on Wirecast when you select the output monitor.

    Reply Like
  • Ob coc Tony Darnell Do you have your monitors set to "extend" or "duplicate?" What happens if you try outputting to the "wrong" monitor? Does it show up on the "correct" monitor? The multi-viewer should give you the option to output to either monitor.

    Reply Like
  • Ob coc Looks like your graphics card has three HDMI outputs and one DVI. Have you tried switching the graphics card outputs around?

    Reply Like
  • Sean iiams the desktop is set to extend.  No matter which monitor I select it shows on the #1.  I don’t have a dvi cable to try that output.   I have tried different combinations of hdmi outputs on the graphics card.

    Reply Like
  • Sean iiams .  Also I even tried changing the Friendly Name of one of the monitors in the registry so they wouldn’t have the same name.  Still didn’t work.  Although the name was only changed in device manager and not within Wirecast or the multiviewer window.  Not sure where to do that in a the reg.

    Reply Like
  • Tony Darnell said:
    the second monitor is the HDMI out going into a Star Tech USB3HDCAP video capture box.

     Perhaps this is somehow impacting MultiViewer function. Can you hood up an HDMI monitor directly and reboot the computer?

    Reply Like
  • Tony Darnell said:
    I really wish Rendezvous worked

     If you're having problems with Rendezvous please post a new topic about the issue. It does generally work although there are some caveats.

    Reply Like
  • Ob coc said:
    Two identical (Sceptre E24) monitors.

     There might be an issue with Wirecast identifying the monitors independently using Multi-Viewer. To test that theory, do you have a different monitor to test with. That can help verify if that's the case or, at least, confirm that's not the issue in this case.

    Reply Like
  • CraigS .  Thanks for the reply.  I have upgraded to 10.0 and also tried a different Dell HDMI monitor and the issue persists.

    Reply Like
  • Ob coc Then it's possible it may be GPU related. Can you check and update your GPU drivers if necessary.

    Also make sure your monitors aren't in mirror mode but I'm sure you checked that already.

    Reply Like
  • CraigS .  I do have the latest drivers as well.  Like I said the system sees both monitors as extended in all other programs.  Thanks.

    Reply Like
  • Ob coc Still not hearing other reports of this so I can't help but suspect a system specific issue.

    As a test create a New User Admin account. Reboot and log into the new account and test. That will tell us whether it's a user based issue or a system issue.

    Reply Like
  • I have Wirecast 10 an windows 10, experiencing exact same issue as (ob coc). wasthere a resolution.  I had this working in September. and now Firing up wirecast gear for new event and Monitor 1 shows display even when i select monitor 2.  Rebooted opened default document. logged in as different user. Nothing changes Monitor 1 always the output.

    Reply Like
  • thomas Isole Wirecast Gear. Please update to Wirecast 11.1 which is the current version. Are both monitors same model?

    Reply Like
  • But he dell monitors different sizes same generation. I'm doing major fundraiser event tomorrow so reticent to upgrade now with everything tested.

    Reply Like
  • thomas Isole I've seen cases where Wirecast couldn't differentiate between two of the same model monitor.

    A quick test might be hooking up a different brand monitor and reboot the computer to see if that's the issue in this case. It wouldn't require an upgrade to test this.

    Set Multi Viewer Out to something simple like just the Program out (just in case you're otherwise attempting to display multiple sources) when testing. That will eliminate possible load issue with the integrated GPU.

    Reply Like
  • Unfortunately I did fix it but only through using “window manager”. A $10 program that manages windows and where and how they open.  I then selected the Multiviewer window in it and told it to full screen to monitor 2 by default and it works like a charm.  The program works in the background and is totoally transparent.  You can still open and close the multiviewer window like normal and really have no way to know the program is even running.

    Reply Like
reply to topic
Like Follow
  • 2 wk agoLast active
  • 26Replies
  • 649Views
  • 6 Following