Episode 7.4 broke video levels

I generally export ProRes 4444 out of Autodesk Flame to compress with Episode.

Today I 'upgraded' to Episode 7.4 (Windows) and immediately noticed that when I made some MP4 files for client approval, the video levels were wrong; raised blacks and crushed whites, like it did a 0-255 -> 16-235 conversion twice. These were using my exact same presets from 7.3, no changes.

To verify I un-installed 7.4 and re-installed 7.3 and it went back to looking correct fine.

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • It's possible the update may require re-creating the custom settings. Can you give that a try? Just use the same settings but create a new preset.

    Reply Like
  • I made a completely new preset from scratch and it's no different. To clarify my original post a little as well, I am coming from ProRes 4444 and going to MP4 using x264 as the encoder.

    I also discovered some additional things:

    1. The source file is 1920x1080 ProRes 4444. My 'approval' preset has a Resize on it to 1280x720 which is where I get the bad levels in Episode 7.4. But if I remove the Resize to make a 1920x1080 file, the encode immediately fails with:

    Failed: initialization failed (no importer found)

    This works fine in 7.3 however.

    2. I tried a DNxHR 444 Quicktime as a source and got incorrect levels in the result too, but differently from the ProRes 4444 source.

    3. To see if the encoder was broken or just the reader, I tried from an RLE Quicktime ('Animation' codec) as well as from an uncompressed 8-bit RGB ('None' codec some call it) and those levels turned out correct -- and, they compressed in 1/4 the amount of time! A :22 source took ~:20 to compress from RLE or Uncompressed, but ~1:15 from ProRes 4444 or DNxHR 444. In 7.3, the same ProRes 4444 source with the same encode settings takes ~:36.

    Is Episode still using the Quicktime API for some of its I/O? IE is it using the installed Quicktime codecs to decode or does it have some codecs built-in? Clearly something significant has changed between 7.3 and 7.4 but I don't find anything obvious mentioned in the release notes.

    Reply Like
  • Bob Maple No importer found is usually related to the source codec. Was the ProRes 4444 created with a licensed encoder or an ffmpeg or an encoder not licensed for ProRes by Apple?

    Episode no longer uses Quicktime installed codecs. It has its own codec decoders built in.

    Fill out the form and note the issues you're having and ask about any changes made to our internal decoding engine. You can link to this forum thread as reference.

    Episode Support Form

    Reply Like
  • Yes, it's from a licensed application (Autodesk Flame.) It's just odd that at native resolution it fails with the importer error, but putting a Resize on it works.

    Thanks, I will fill out a bunch of support forms.

    Reply Like
  • Bob Maple Do report back any interesting comments from our engineers. If it's an exported self contained file it normally wouldn't generate a "no importer found" message.

    Reply Like
  • CraigS Unfortunately I've heard nothing since the end of July when I originally submitted the case.

    Reply Like
  • Bob Maple Follow up by email with your case number in the subject field and as for a status update.

    Reply Like
reply to topic
Like Follow
  • 9 days agoLast active
  • 7Replies
  • 170Views
  • 2 Following