0

Can't record from Sony camera into Screenflow 10

Hey Guys,

Here are the stats:

Sony A7R4 connected via usb C cable

M1 MacBook Pro with Mac OS 12.1

Screenflow 10.0.4 (31881)

I installed the Sony Imaging Web Cam software.  The camera works in other apps like Zoom, however, I can not get it to record in Screenflow.  The Sony Imaging app appears as a camera, but there is no preview.  When I record, nothing records (except my mic, video screens, etc.) 

I've tried resetting permissions, running in Rosetta, etc.  Nothing seems to work.

 

Please help!  I'd love to use my Sony camera to record directly into Screenflow! 

 

Rob

28replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 10 mths ago
    • Reported - view
    • Can you test in Quicktime as well? 
    • This should be fixed and working as per our FLOW-10634. Did this work previously for you in 10?
    • There's an issue where it shows no preview but it does recording FLOW-11206 so we know about the lack of Preview but it did record in our testing.
    • Please confirm the version of Sony software as well.
    • Please clarify that you mean M1 13" MBP and not M1Mac/Pro 14" or 16"

    2021-12-16  Imaging Edge Webcam 1.1.00 (Mac) has been released.
    This is very recent so Sony may well have fixed some issues. Please install and test with this version.

    We need to consider whether ScreenFlow update, driver update or OS update are factors. Testing in Quicktime might indicate the issue is part of an Apple update that affected ScreenFlow for example.

    Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    Hi Craig,

    -The camera does NOT appear in Quicktime, nor in Photo Booth, however, it does work in Zoom.  In Screenflow, I see the camera listed as my video recording, but the preview doesn't work, and nothing will record.

    -What is FLOW-10634?  This is the first time I've tried to use the Sony camera with Screenflow, so not sure about older versions.

    -Sony software is 1.1.00, and firmware on the camera is 1.2. (The latest)

    -I'm musing a 16 inch M1 MAX. (64 GB of ram and 2 TB hard drive)

    Thank you for any help!

    Rob

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 10 mths ago
    • Reported - view
    Rob Sigler said:
    What is FLOW-10634?

     This means it was fixed previously and was working (except for preview) when ScreenFlow 10.0 was initially released. Something may have broken it again. We're starting a new investigation FLOW-11414.

    Possible causes could be ScreenFlow update, Image Edge update, macOS update, M1Mac/Pro specific issues. 

    Are you on Monterey 12.1 or 12.0.1?
    Do you have a different model Mac you could test on?

    Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    I am on 12.1. I do have another Mac...will test in the morning.  Thanks!

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      Rob Sigler Thanks. When I try to run it on my 13" M1 MBP in ScreenFlow, Activity Monitor shows it as Intel and not Universal or Apple Silicon. But you confirmed running ScreenFlow in Rosetta didn't fix the issue. 

      Rob Sigler said:
      do have another Mac...will test in the morning.

       Thanks very much for doing that. Please do include software versions and whether it's an Apple Silicon or Intel Mac.

      Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    Tested on a non-m1 MacBook Pro from 2019.  Still doesn't work, however, after recording, instead of 'nothing' being recorded, I see the Sony webcam logo where the video should have been.  I also do NOT see the camera in Quicktime.

     

    Thanks for any help!  I'd love to get this working.

     

    Rob

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      Rob Sigler need to know the Sony driver version and macOS version on that MBP as well.
      If you're seeing the logo you may want to check camera settings since it's recording the logo.

      Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    I'm using the latest Sony driver, MacOS 12.0.1.  

    Here's a twist...I tried using OBS to create a virtual camera (on my M1 MacBook) and selecting the virtual camera in Screenflow, it worked.  :)

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      Rob Sigler I think the issue is specific to Sony's driver it seems. Many virtual webcams do work with ScreenFlow (and this did at one time when 10 came out as well).

      Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    Any guess on what to do?  I'd love to be able to use this feature.

     

    Rob

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      Rob Sigler We're working on it. Some of these third-party drivers have some issues with how they are written vs what we need from them so there's investigation involved.

      Like
  • Have have also same issue - but my issue is video recording get stuck in screen flow after 3 minutes and more first it become slow then at end at 15 minutes range it is getting stuck what will be the solutions? I am using Sony ZV1 with Screen flow latest version 10

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      Vipin Nayar Since your issue seems different we need more info. Exact version of ScreenFlow (people do miss updates so we always need version number) macOS, Sony driver version. whether connected directly or through hub/dock, mac model including the processor.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 10 mths ago
    • Reported - view

    There may be issues with the newest Sony driver. 
    Can you try rolling back to the previous Sony driver version?

    Like
    • Rob Sigler
    • Rob_Sigler
    • 10 mths ago
    • Reported - view

    Do you know how to do that?

    Like
  • Any updates on this? Camera works in zoom, shows up as option in screenflow, but no preview, no recording. Doesn't show up as an option in photobooth/quicktime.

    M1 Pro MacBook Pro (14" 2021), macOS 12.0.1, Screenflow 10.0.5, Sony driver: IEW110_2111a

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view

      Michi Huber Sorry but not yet. I'll give the developers a nudge on this.

      Given you're on the oldest version of Monterey and it's not working in Quicktime either, you may want to consider updating the macOS to 12.4 to see if that changes. Sometimes macOS fixes give us an opportunity.

      Like
  • Feels like another thing broken in screenflow.  The Imaging edge webcam driver works in all of my software apart from Screenflow...

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 mths ago
    • Reported - view
    David Samuel said:
    Feels like another thing broken in screenflow. 

    As noted in the thread. We're already investigating.


    We're starting a new investigation FLOW-11414.

     

    David Samuel said:
    The Imaging edge webcam driver works in all of my software apart from Screenflow...

     Have you tested in Quicktime? It's not working there either unless you can confirm otherwise.
    This would mean it's probably not working in Facetime or Photobooth either. You should have these as part of macOS. You mentioned "all my software." If you can confirm it working in Quicktime that would be most interesting and useful to us.

    See below.

    Michi Huber said:
    Doesn't show up as an option in photobooth/quicktime.
    Like
  • Hi, no it does not work in Quicktime.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view

      David Samuel Thanks for that. That's why it's important to include specifics rather than "all my software." If it doesn't work in Quicktime it's possible that we may not be able to fix in the Mac App Store version due to Apple's "sandboxing" (security) requirements. Our own webstore version doesn't have such restrictions so we are focusing on fixing that.

      Like
    • CraigS Understood.  I meant that it works in Zoom, Vidyo, Teams, Google Meet.  Didn't really think about Quicktime as don't really use it.  So is there any way to refund the Mac App Store version and then re-purchase your Webstore version? Cheers.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 mths ago
    • Reported - view
    David Samuel said:
    it works in Zoom, Vidyo, Teams, Google Meet. 

     With that, we are hopeful we can get it working in our webstore version of ScreenFlow.

    Like
  • If that is the case, can I get a credit fr my app store product and then purchase your webstore version as I didn't even think that they would be different.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 5 mths ago
      • Reported - view

      David Samuel  email DesktopSales explain the issue (sandboxing blocks virtual webcams) and include a screen shot from the Mac App Store—view your account's list of Purchased apps showing ScreenFlow.

      Like
Like Follow
  • 4 mths agoLast active
  • 28Replies
  • 138Views
  • 5 Following