0

Wirecast Recording to Disk - Choppy video

Since updating to the latest Wirecast version, I've noticed that my disk recordings have really choppy video.  

Some info:

I use Wirecast as a means to have a multicam setup for teaching music lessons via skype/zoom/etcetera.

I have a MacBook Pro 15" - using the Default 720p30 (2mbps) x264 H264 preset to record directly to MP4.. I tried changing the encoding speeds to "super fast", but that just made it worse.  Right now it's set at "very fast"

I also recently updated to Big Sur, and I kinda regret it.  I feel like that also could be part of the problem?

FWIW I've been using this setup for about 5 years and never had any issues with choppy video until now.

I tried making some videos using QuickTime and they were smooth...

Could it be that my CPU is dying? I recently had my MacBook cleaned and also had the battery replaced, but I had the same issue today.

 

Any help is appreciated! Thank you,

Tim

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • MacBook Pro 15" has been around for years. Older ones may have issues. What year model (look at About this Mac)?
    What is Wirecast version specifically?
    What is CPU% shown in Wirecast?
    Are dropped frames being reported in Wirecast?
    How much free drive space is available?
    Quicktime do you mean MOV (Apple ProRes)?

    Like
  • It's a mid-2014 MacBook Pro 15", Wirecast 14.2.1.

    The CPU% will be at 10% when Wirecast is open, but as soon as I hit record it spikes upwards of 80% and even 90%..I have the canvas size set also to 720p, it matches the output settings.

    Nothing being reported in Wirecast that I can see though, it still says 30FPS in the indicator... although that's just when I tested it now.  When I am in lessons with Skype or Google Meet I'll pay attention to the FPS and see what it says.

    I have 85GB free so that shouldn't be the issue either.  

     

    With QuickTime, I just tested it in QuickTime with the quality setting set to "high" instead of "maximum"... I'm not sure what the Codec is for that - I guess that would be Apple ProRes, right?

    I wonder if it's just Big Sur that is causing this.  Everything worked fine until I updated (only a month ago).

     

    Thanks for your help,

    Tim

    Like
  • Tim Collins said:
    but as soon as I hit record it spikes upwards of 80% and even 90%.

     Try resetting Wirecast Preferences. Wirecast > Help > Send Support Information but click on the Reset Preferences and then restart Wirecast.

    In a New Blank Document with no sources at all use the setting you used before and record to disk.  Take a screenshot of CPU% shown in the Wirecast interface.

    Tim Collins said:
    I have 85GB free so that shouldn't be the issue either.  

     A drive should have 20% free space because there are temp functions from the OS and various apps that need to use free space on the drive.

    Like
  • Tim Collins said:
    With QuickTime, I just tested it in QuickTime with the quality setting set to "high" instead of "maximum"... I'm not sure what the Codec is for that - I guess that would be Apple ProRes, right?

     If you mean Apple Quicktime, they use their own H264 codec so it's not directly comparable. Please don't compare.

    Like
  • OK thanks.  I followed your instructions, here's the screenshot of the CPU% recording a document with no inputs to MP4 at the Default 720p30 (2Mbps) setting:

    Like
  • Tim Collins said:
    I followed your instructions,

     Please confirm. State specifically what you've done. 
    Instructions often get misinterpreted or steps are missed.
     

    Tim Collins said:
    here's the screenshot of the CPU% recording a document with no inputs to MP4 at the Default 720p30 (2Mbps) setting:

     That's a fairly high CPU use for an empty document just recording.
    Since it's displaying System  CPU please consider what else might be running. Anything using CPU is going to impact Wirecast's performance.

    You may want to take a screenshot of Apple Activity Monitor looking at everything using CPU resources.

    Like
  • CraigS said:
    Please confirm. State specifically what you've done.

     I went into Wirecast > Help > Send Support > Reset Preferences.

    Then I created a new blank document with no sources at all and used the setting I used before to record to disk in MP4 format. (Default: 720p30 2Mbps). 

    Here is a screenshot of the CPU% within Wirecast, as well as a shot of the activity monitor:

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Tim Collins Thanks for those important details. Investigation WIRE-18920

      Can you tell me exactly which version of Big Sur are you using?

      Like
  • Sure - it's Big Sur 11.3.1

    Thanks

    Tim

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Tim Collins Thanks. We're looking at if a specific version of Big Sur impacted this.

      Like
  • Thank you! 

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Tim Collins We may have follow-up questions as we track down the cause and fix. Thanks for providing good evidence for us.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Tim Collins can you create a support document for us?
      Wirecast > Help > Send Support Information... then Save Report button. Then attach it to a forum post.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Tim Collins Given the CPU which shows in Activity Monitor we'd like you to run a deeper report.
      Select Wirecast and using the gear icon select Sample Process. That will open a separate window. Save that and attach to the forum. That will tell us how Wirecast is utilizing the CPU.

       

      Like
    • CraigS Hi Craig,

       

      So I did both of those things and have attached the relevant files.  I went to Wirecast > Help > Send Support Information > Save Report (I didn't enter anything into it though).

      I also went into Activity Monitor and got a "Sample Process" from Wirecast as it was recording to disk.  Both files are attached here.

       

      I should also mention that yesterday I had to do about 4 hours of live streaming - I decided to switch the encoder preset to the Default 720p30 Apple H.264... this worked perfectly - I was streaming AND recording AND running replay the whole time and CPU% never went much higher than 35% or so.

       

      All of the above mentioned problems were with the x264 encoder - which is what I had always used.  I just tested it again and it definitely is a problem with the x264 vs. Apple H.264.  I feel kind of silly that I didn't try this earlier - I just didn't see what should have changed with the updates.  Anyway - I hope this information helps you guys solve the issue with x264.  Thanks as always for your amazing support.

      -Tim

      Like
  • Tim Collins said:
    I decided to switch the encoder preset to the Default 720p30 Apple H.264... this worked perfectly

     Apple H264 usees less CPU by design 

    Tim Collins said:
    never went much higher than 35% or so.

     that gives us something to compare it to. Thanks.

    Like
Like Follow
  • 11 mths agoLast active
  • 16Replies
  • 41Views
  • 2 Following