0

Screenflow Not Recording Audio from a DAW!

I just purchased ScreenFlow for the purpose of recording my workflow on my DAW (stands for digital audio workstation - essentially, place in which audio is compiled, composed, mixed, and mastered.)

I was informed that ScreenFlow (through Soundflower on older versions, but now with its own audio telestream plugin ScreenFlow has you download), was able to do this. 

It seems that the audio can not be recorded for ScreenFlow in my computer because it has to run out to an AD/DA audio interface. This is imperative for my computer and program to work, so not utilizing it is not an option. It essentially plays an in between of "audio in -> interface -> mac -> daw -> mac -> interface -> audio out" 

I'm not sure where the ScreenFlow app comes into play. The odd thing, is I have an external microphone that is attached into the interface that is utilized as my voice over mic for what's recording. This is picked up through the ScreenFlow application, and recorded under 'microphone audio', yet computer audio running through the interface is not - even when 'computer audio' is checked. It's almost like the daw has to send the signal to the mac that it's sending out this audio, but along the way, the audio signal can't be solely highjacked by Soundflower. When you're recording, you think this is happening, because you hear all of your audio, but that's only because the audio out is going daw-> OSX -> interface -> my headphones. 

 

I have a really whack work around that I'm trying to use for picking up the audio signal, but it's in no way my preferred method due to quality, limitations, and usability. 

If anyone has any suggestions whether they know DAW's better than I do, or knows the ScreenFlow software better than I do - both are highly likely, please let me know!!

Also, for what its worth, I'm using Cubase 9.5 as my DAW and My iMac is running Mojave 10.14.2.

This is probably much more irrelevant to the audio situation, but I'm using an Audient ID22 as my interface, but have a Universal Audio Apollo x6 arriving next week. 

41replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    You must set your DAW to the ScreenFlow Audio Driver. Please Read.
    Please read this to understand why.

    Apple is making changes to the OS and some Mac hardware that has created these challenges. 

    Like
  • CraigS Hey Craig, thanks for your response! 

    I have actually tried this as well. 

    What happens is it creates a feedback loop between the computer's DAW and the audio interface in which as soon as sound occurs, it creates immediate feedback that maxes out the 'db's. 

    It also loses the ability to route the microphone through the preamp/audio interface. There is no standalone software for the interface, so it relies on the DAW to route the inputs and outputs. If I select the DAW to ScreenFlow Audio driver, its not sure how to route all the inputs and outputs. In the (older and probably outdated) tutorial I watched about doing this, the person was utilizing SoundFlower and routing the input's through that, but I can't find a way to setup the routing through Audio Driver. Is this possible? Maybe I can record the audio through a 3rd party and record the video with ScreenFlow? 

    Thank you for your time, knowledge, and assistance on the subject!

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Nick Allinson We're aware of many of these issues. You may try Dante Via or Rogue Amoeba Loopback but can say for certain it'll help. They are much better supported than SoundFlower though.

    Apple would need to develop an API and, since introducing the T2 chip in late 2017, hasn't to date. That macOS is going to stop using .kext driver compounds the issue. 

    Like
    • Mark
    • Mark_Levy
    • 2 yrs ago
    • Reported - view

    I'm having a similar problem. This is such a painful experience :-(. I'm trying to record in my DAW (Logic Pro X) and route the output (while recording) to screenflow so it can record my VID and Screen while I play live music. I start screenflow and then change the output driver in my DAW to the telestream driver. I record with "Record with Computer Audio" and nothing. The DAW records and plays back fine but Screenflow has no sound. Now if I restart the Screenflow recording again and reset the DAW output driver and just play the track that I previously recorded, Screenflow captures the sound. It just does not capture it when I am recording.  Any guidance would be greatly appreciated.  I've had tried many difference configs (with soundflower.etc) and its really a bit frustrating so hopefully someone can help. I'm running Screenflow 9.0.3 on a 2016 13" macbook pro running the latest version of OSX..I'm really hoping this is user error and someone can help..thanks

    Like 1
  • I know this isn't the most popular solution, but version 9 introduced way too much latency, and it messes with the audio, so I rolled back to 7.2 on my little MacBook Air, and???  Everything is back to normal. I get a perfect sound, and I don't select any particular driver. So if you are not on one of the latest Macs, I say roll back to version 7.2 as it just works.

    Like
  • Mark Levy I think that there is an issue, but hopefully, it will get sorted out. Version 9 did not fix this one for me. I went back to 7.2 and can record the output of Reaktor, Ableton, etc. And also have the built-in mic. With 9, the "new" driver adds way too much latency.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view
    Claudio Marcelo Strilio said:
    but version 9 introduced way too much latency, and it messes with the audio, so I rolled back to 7.2 on my little MacBook Air,

    That will likely break at some point. The old driver won't work in Macs with T2 chips (MBP 2018 forward) and Apple will eventually end support for that driver type (it may be soon). Apple hasn't introduced an API for a driver. In short, using 7.2 is a temp solution at best. Please read. Again this is Apple's decisions, not ours.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Mark Levy Please make sure you follow our instructions.

     

    Launch the Audio Application first and setup the project(s) that will be recorded by ScreenFlow

    1. Launch ScreenFlow
    2. Change over to the TAC within the audio application. Some applications will auto switch or show a message asking if you would like to switch over to the TAC, select use if this is the case. For the apps that do not show a message or that don’t auto switch, manually going into the preferences will be needed to switch over to the TAC
    3. Make sure Record Computer Audio is selected in the New Recording tab in ScreenFlow’s Welcome Window; along with any other options selected that will be used for the recording
    4. Create a short test recording; start the recording and record for roughly 30 seconds
    5. Playback the project in the Audio Application, making sure audio can be heard on playback in the currently used output device (headphones, DAW device, speakers…etc)
    6. Stop the recording after 30 seconds or so
    7. Once a project shows, playback within ScreenFlow to confirm that the audio was captured correctly
    Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      CraigS My DAW audio is finally being recorded by following your suggestions, however the TAC samplerate is set at 48 kHz and I don't see a way to change it so my audio is being sped up because my existing project was recorded at 44.1 kHz. Any suggestions? Fyi, I downloaded the latest free trial of Camstasia and it works flawlessly with. I'm on a Mac Pro running latest version of Catalina. Cheers! 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Al The sample rate conversion should be on the fly. Camtasia uses similar technology. Check both drivers sample rates in Apple Audio Midi Setup utilty.

      Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      CraigS Here's a screenshot. There is no option to change samplerate. My audio interface and project is at 44.1

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Al Hmm don't see Camtasia driver at all.

      Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      CraigS Correct. I have a Mac mini running same setup as my Mac Pro with latest version of Screenflow and when Audio Devices is open there are no TAC drivers to be found and it works as expected. 

      Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      Al Here's my Mac Pro specs in case it's helpful.

      Like
    • Mark
    • Mark_Levy
    • 2 yrs ago
    • Reported - view

    I followed those instructions but still no go with recording. The interesting thing is that I put the metronome on in Logic (DAW) and that was recorded but not my voice. I than play it back and the playback was recorded in screenflow. Here is the screenflow VID of the test.  

    https://youtu.be/dAoKlFrjCMg

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Mark Levy Tested in Garage Band.
    Basically it's not going to record incoming probably for the same reason you may not be able to monitor yourself while recording.

    See if you can set it you (without ScreenFlow for this test) to actually hear yourself out of the computer speakers while recording. If you can't send your voice to computer speakers while recording it's not going to go to ScreenFlow either. 

    Of course, after recording, you can play back the recording out of computer speakers so at that point ScreenFlow would hear it through it's TAC if sent there.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Mark Levy 
    If the DAW is muting the audio during recording it's not being sent to TAC either.
    If you enable monitoring while recording it will send the sound through the system and, therefore, to TAC as well.

    Like
    • Mark
    • Mark_Levy
    • 2 yrs ago
    • Reported - view

    CraigS ok..think I found the issue. there is an option in logic pro x called "software monitoring" (different from input monitoring). By default its not checked. I checked it and it now records in screenflow. I still have a bit of an issue since my monitors are driven from my audio interface and it sounds like I'm getting two signals and with the slight latency of the Telestream driver I hear a bit of out of phase condition but I think I can work around that. I'll play with it some more..I think I'm pretty close..thanks for the help

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Mark Levy Good to hear you're making progress. It may require a bit more experimentation.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    Al said:
     My DAW audio is finally being recorded by following your suggestions,

     Are you playing a file in your DAW or using a live input?
    Can you provide a screenshot that shows your DAW is 44.1kHz?
    Can you change your DAW and Audio Interface to 48kHz and verify it is then recorded correctly in ScreenFlow?
    That would verify the  Telestream Driver sample rate is the issue.
    Which Mac Pro, 2013 or 2019?

    Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      CraigS I am playing back recorded audio in my DAW as well as using a live microphone for narration as I produce. Screenflow only captures the mic and not the audio playback. 

      When I change my project and audio interface to 48kHz it does playback in the correct speed, however I have to convert all my files to new sample rate and some things don't line up. In other words, it is not a good solution. 

      Mac Pro 2019.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Al Our internal investigation reference FLOW-10614

      Like
      • Al
      • ruby_sail
      • 1 yr ago
      • Reported - view

      CraigS Not exactly sure what FLOW-10614 means, but I'm hoping it means that a solution is in the very near future. Thanks for your help!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Al That number means the engineers are investigating the issue. If there are any interesting findings I can come back here with questions or findings as they progress.

      Like 1
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Al Can you tell us what DAW and Audio Interface you're using?

      We'd like to test with a close match. 

      Like
Like Follow
  • 2 mths agoLast active
  • 41Replies
  • 448Views
  • 7 Following