0

PTZ Optics NDI jumping/jittery video

Also See Case#00673809, WIRE-16381, and Case #00645656.

Tried the 13.1 Beta with NDI 4.1 and still have jittery, pausing NDI video from PTZ Optics 30x camera every few seconds.  The motion of just doesn't look natural and its as if frames are "skipped" every so often.  I have documented lots of testing with support over nearly the last year.  All other programs work fine.  Only combination that works is 11.1.2 and NDI 3.5.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • PaulMEngineering
    • Software Engineer, Telestream
    • PaulM
    • 2 yrs ago
    • Reported - view

    Have you reviewed the PTZOptics NDI Troubleshooting guide?

    https://help.ptzoptics.com/support/discussions/topics/13000023246

    In particular, have you disabled multicast and ensured that each camera has a unique IP address?

     

    How many NDI sources are on your network?  How many are you attempting to bring into Wirecast?

     

    What resolution and frame rate are the PTZOptics camera(s) running at?

     

    What kind of network connection do the NDI camera(s) and your Wirecast computer have?

     

    Are you seeing the jitters in the preview / live area in Wirecast or only after viewing the stream from your destination and/or recording?

    Like
    • Ob coc
    • Ob_coc
    • 2 yrs ago
    • Reported - view

    PaulM,

    I have reviewed all of those documents.  Multicast is disabled.  Only one NDI camera and a scan converter capture.  Both have unique IP's.  There are two other Scan converter sources for other purposes on the network but I have disabled those and tested also.  1080p30 for the camera.  It is a dedicated network solely for NDI and has been tested with nothing but the camera and the PC connected.  The Wirecast PC has two NICs with the other being for internet connectivity.  I have tested with this other NIC disabled also.  The problem shows in the preview and live area in WC as well as in the output.

    Like
    • PaulMEngineering
    • Software Engineer, Telestream
    • PaulM
    • 2 yrs ago
    • Reported - view

    Ob coc Thanks for the feedback. 

    If you do an ISO recording of the NDI camera source, do you still see the jitters when you play the recorded file in an app like Telestream Switch, Quicktime Player, or VLC? 

    ISO recordings in Wirecast bypass the render engine and can give us a clear picture of what we're receiving from the source.

    Like 1
    • PaulMEngineering
    • Software Engineer, Telestream
    • PaulM
    • 2 yrs ago
    • Reported - view

    Ob coc Do sources other than NDI exhibit the jittery playback in Wirecast?  For example, if you capture the SDI or HDMI output from the PTZOptics camera, does that jitter as well?

    Like 1
    • Ob coc
    • Ob_coc
    • 2 yrs ago
    • Reported - view

    PaulM,

    Doing an ISO now with the working config for control.  Ill do the updates and test and let you know.  Also I do have an SDI to HDMI source from another PTZ Optics zcam that has none of these symptoms.  It comes in through a Blackmagic Intensity Pro 4k. 

     

    ETA:  Also this is a new camera.  Last one had same issues.  Same model PTZ Optics

    Like 1
    • Ob coc
    • Ob_coc
    • 2 yrs ago
    • Reported - view

    PaulM

    Tried an ISO recording with NDI 4.1 and WC 13.1 Beta today.  The ISO is MUCH BETTER!  It still seems to have a "strobing" effect during rapid movement that is more noticeable than with 11.1.2, but the jittery, laggy video is gone!  No more missing frames.  Hope this helps finally find a solution.

    Like
Like
  • 2 yrs agoLast active
  • 6Replies closed
  • 142Views
  • 2 Following