1

Chroma key select color not working.

I'm clicking like crazy with the mouse cursor to pick a color but it doesn't work.
On one of the clips I can click a purple color and all the black  (background) is instantly gone.
It looks like the color picker is picking up a wrong color or spot...

Wirecast 7.1 Windows 10. 

48replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Here's a clip of me clicking like crazy :-)

    Like
  • What is your computer GPU?
    Can you send me your foreground and background for one of those shots so I can test on my system?

    Like
  • I have it both on my broadcast pc and my laptop (both win10).
    The pc has a NVidia Quadro K620 2GB, the laptop has a build in Intel HD Graphics 4600.

    The background I'm using to test is just a solid background created in Wirecast.
    I'm having this with wmv, mp4 and mov files.
    It seams to respond to some colors (blue?) but others not. 

    Like
  • I can't get it to key correctly with the WMV with black background. See my example with green background. It keys automatically just by enabling chroma key.

    Like 1
  • Here's my test file. It's an H.264 .mp4.
    You can download and test on your system to make sure the chroma key is working with that.

    Like
  • Yesterdazy I changed some some of my vids I need next weekend to .mov and a green background. Thats is working like you state above.
    But I just tested and old WMV with green background and that one is not working. Not with enabling not with mouse click.
    I added a screencap and the old wmv file I'm talking about.
    That file used to work in Wirecast v6 but I believe with a mouseclick on the color.
     

    Like
  • Ah sorry, misread. The MP4 file you gave me does work to instantly when activating Chroma key. But also here the select color with the mouse does not work.
    I need that, I have some broadcasts I use that to create a psychedelic effect...
    Looks like a bug to me.

    Like
  • I converted your logo to H.264 .mp4 and used in Wirecast 7.1 on Windows 10 and it worked just by turning on Chroma Key.

    Please try converting your .wmv to H.264 .mp4 and test.

    Like
  • And I use the Color Picker to select blue/purple type color in the logo instead and that works as well.

     

    Like
  • Hi Craig, I understand you are trying to workaround the problem and help me but it still doesn't solve the colorpicker problem.
    I need the colorpicker also in live video for creating psychedelic  fx...
     

    Like
  • Blue / purple works but other colors not... (red, white, etc.)

    Like
  • Black and white don't work because, as per our chroma keyer, they aren't colors. That would be a feature request. I'll see if I can find something red to test with unless you have something for me.

    Like
  • Red works as well using the color picker. Red Logo before key followed by Logo with the red keyed out showing my cat pic underneath. This was just using a jpeg source. I attached the jpeg if you want to test.

     

    Like
  • Black used to work in Wirecast 6.... I used it all the time on a live camera shot.

    As you can see in the first video I posted red is not working neither is digital green with the color picker.
    But that sesms to be related with limited wmv support in Wirecast 7, I understand that now.

    But this used to work for wmv files in Wirecast 6, just like black did on a live cam.
     

    Like
  • It may be related to wmv support. As you can see it works when I use .mp4. 

    Do fill out the form and link to this forum thread so the engineer can see both my testing and yours.

    Wirecast Support Form

    Like
  • I realise now I'm mixing up things...  I used to chroma key black in a video post processing sofware not in Wirecast.

    Like
  • Regarding Chroma Key and live camera, what type of camera and input device?

    Like
  • Logitech 2xC920 and 1x C910 on a  Startech PEXUSB3S44V SuperSpeed USB 3.0 adapter met 4 seperate 5 Gbps busses.

    Like
  • Sorry for the quick and dirty but this is with a C910. I just held my fingers in front of a blue lens cleaning cloth. With proper background and lighting it would be cleaner. It certainly works though. I used the color picker to select the blue. 

    C910 attached to a TPLINK USB3 hub and into USB3 port on the computer.

    Before Key

    Chroma Key using Color Picker from Logitech C910

    Like
  • Since Chroma Keying is dependent on the GPU perhaps that's where the issue is.
    Perhaps you can force using the non integrated GPU vs the integrated GPU and see if one or the other results in different behavior.

    Except for the WMV file, I've been able to use your files as H.264 .mp4 as well as my own test files and the same webcam for live source and Chroma Key is fully functional. 

    Like
  • ok, I'll give it a go.
    Thank you.

    Like
  • You're welcome course. My hunch is one of the GPUs might be at issue.

    Like
  • I can confirm there is a big issue with Wirecast 7.1's chromakey, at least at my studio. We're using beautiful Magewell capture cards (the PCIe ones). I tested with both the 4K and the 1080p capture cards. Enable chromakey and the green screen turns blue and my face is mildly speckled with moving black dots. Hit the checkbox to select by mouse and no matter how many times I click, press, right click, middle click, double click, touch the monitor (we use touchscreen), it does absolutely nothing.

    On Wirecast 6 it would do what you expect: select the color you clicked on. So the only other option is to press "Defaults"... and then suddenly the green screen becomes green again, and I (yes, I) disappear. My skin tone (quite pale white bald guy) suddenly turns invisible. Click the defaults button a few more times and it cycles through the various hues, but none of them eliminate the green screen, which remains green and everything else on the set is affected.

    I did all the obvious stuff... system updates (Windows 10), turned off rendering from GPU (GTX 460 or 480 ... can't recall), tried with a different Wirecast file, tried two different capture cards, rebooted the computer, different exposures on our camera, tried all the available settings pertaining to GPU and/or chromakey in Wirecast... same result no matter what I do. The green screen (which worked perfectly on Wirecast 6) can't be set as the color for Chromakey (and the mouse selection doesn't do a thing, no matter where I click).

    Finding this thread here it seems I'm not the only person experiencing this, so wanted to provide my experience.

    Thanks!!
    Robbie
    Like
  • Robbie Ferguson it's possible it's specific to certain GPU types and/or drivers. Do submit the form but include GPU specs and exactly what you tried changing its settings.

    Like
  • Has this issue been sorted out yet?  We're on 7.3 and it's still not working properly.  
    Mac OS 10.10.5, Mac Pro 2008 12-core, 20GB RAM, 2GB Nvidia GPU

    Like
Like1 Follow
  • 1 Likes
  • 3 yrs agoLast active
  • 48Replies
  • 4494Views
  • 7 Following