System Audio Capture not working on MacBook Pro via Wirecast

(***NOTE: my apologies if this is a duplicate post. I had tried to make this post moments ago but it seems to have not gone through***.) 

 

Hello Wirecast team. For some reason, neither a "System Audio Capture" shot nor a "Screen Capture" shot are capturing system audio on my MacBook Pro via Wirecast. This happens regardless of what application on my computer is producing sound. It doesn't matter if it's an iTunes audio file, a YouTube video, or a Skype call - no levels, no sound captured. Note, too, that for the Screen Capture shot, I've made sure the "Capture Audio" option is enabled. 

Importantly, this issue is something specific to this particular computer and/or to a configuration on this computer, since I have no issues capturing system audio on my MacPro tower, our primary webcasting machine. 

I'm currently using Wirecast 7.7 on the MacBook Pro, but this has been a problem throughout multiple versions of Wirecast. For instance, if I revert back to Wirecast 5 and try to add a Local Desktop Presenter shot, I'm still not able to successfully capture audio (again, even after checking to make sure that the "With Audio" box is selected). 

Any thoughts?

Here are the specs on my MacBook Pro: 

MacBook Pro (Retina, 13-inch, Early 2015) 
Processor: 2.7ghz Intel Core i5
Memory: 8GB 1867 MHz DDR3 
Startup Disk: Macintosh HD 
Graphics: Intel Iris Graphics 6100 1536 MB

Please let me know what additional specs I can provide. I didn't offer anything about my Wirecast configuration, because, like I said, this has been the case for several versions of Wirecast, and multiple configurations therein. 

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • That would mean either a third party program, system setting issue or, the driver is not installed.

    If you have any audio programs that might interfere with system sound (SoundFlower or similar programs) please remove them.

    Check your System Preferences > Sound and confirm you can hear system audio out of headphone, line out jack and/or computer internal speakers.


    Another trick is to download the free demo of Telestream ScreenFlow and go to its preferences and uninstall and reinstall the sound driver. Both ScreenFlow and Wirecast use the same sound driver. If you can then capture system sound in ScreenFlow it should also work in Wirecast.

    Please respond confirming you've done each of the following and tested.

    Reply Like
  • Thanks so much! The ScreenFlow driver reinstallation did the trick! 

    Reply Like
  • Micah Bochart Great to hear. You're welcome of course.

    Reply Like
login to reply
Like Follow
  • 3 days agoLast active
  • 3Replies
  • 39Views
  • 2 Following