0

Web Stream Source Problems

Required Info:

Windows 8.1 Pro

Wirecast 9.0.1 (34305)

Custom-built computer: Asus P9X79 WS mobo / Intel i7 4930K / 16 GB memory / Nvidia GTX 660ti / Plextor M.2 PCIe SSD

Source in question: Web stream

Streaming to/from personal Helix Universal Media Server (via RTMP).

 

Description of problem:

I just upgraded to version 9 from version 8.3. In one of my streaming setups, I routinely use a Web Stream source to bring in an RTMP stream that I restream with lower thirds, etc. I set up the Web Stream source by adding a new shot using the new add shot menu. I choose the network category, choose Web Stream, give it a name “Kennewick,” then enter the RTMP URL in the URI box and check the “live stream” box. I click connect and it connects to the stream. See attached picture. No problem.

OK, now I want to add that same “Kennewick” Web Stream source as a PiP overlay in another shot (on the same or different layer, doesn’t matter). Since I named the source “Kennewick” I add a new shot using the new add shot menu. I can see the “Kennewick” web stream source listed under the Network Category. However, when I select it and press Add, a new web stream source is created instead of adding the “Kennewick” Web Stream source I already configured.

I can configure an identical (but separate) Web Stream source again, connect, and find both of them in sync. However, that would mean when I open the document, I would have to go to each shot and click Connect in the source properties.

Bottom line:

It appears something is preventing me from adding the same, previously configured, Web Stream source to other shots.

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Thanks for that description. We're looking into issues surrounding duplication of sources when one actually wants to add the original. Please do fill out the form and include the above description. We'll send you a case number. We are most certainly investigating this now.

    Wirecast Support Form

    Like
  • Thanks CraigS . I just submitted a support request and now have Case #00591819 open.

    For what it's worth, I know it worked in Version 8.3 because that's where I built the streaming document I've been using.

    Like
  • Sean iiams I'd test with a new document. Sometimes documents with older versions present issues with newer versions. We're investigating this and how we handle webstream sources used in multiple shots.

    Like
  • I did try with a brand new document and had the same problem.

    Like
  • Sean iiams Thanks for doing that. Just to confirm can you go back to 8.3 and test with a new document there. That will confirm the problem was introduced with 9.x. It'll help the coders narrow down the issue.

    Like
  • CraigS Yes, I just tried it in a new document in 8.3. Everything I was trying to do in 9.x appears to work fine in 8.3.

    Like
  • Sean iiams Thanks for confirming that. We'll investigate further.

    Like
Like Follow
  • 2 yrs agoLast active
  • 7Replies
  • 596Views
  • 2 Following