0

Audio to Video Syncing problems

I'm using screenflow version 8.2.4 on a mac running High Sierra 10.13.6. I always have an audio sync problem that I can fix with a clap of my hand and a sync up. But it seems later in the video the audio "drifts" off sync. Even if I sync the audio at the beginning of the video, at the end of the video it's drifted out of sync.

I'm running audio from a mic independently through a hub into my computer.
And I streaming video from my Canon SL2 independently into my computer using Camlink adapter.

I'm using a Heil PR40 mic.

Any solutions for this?
Does the latest screenflow fix this issue of audio sync drifting?
(I've seen other people having this problem too)
 

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • David Frey said:
    I'm using screenflow version 8.2.4

     The last version of ScreenFlow in that series was 8.2.6. Please go to the following link and use Previous Versions at the top please update and test again.

    Some sources do drift over time. Avoid Hubs and Docks. Using two separate USB sources in which the audio is not locked can be an issue  That may have improved in more recent versions of ScreenFlow. Version 9.0.5 was the last version compatible with High Sierra though. The current version is 10.0.3 and requires Catalina at a minimum. You can always test the free trial before paying for an upgrade but obviously, you'd need to test on a compatible OS.
     

    Like
  • yes i have this problem too. v similar set up with usb mic into iMac, camera plugged into computer using Nikon Webcam utility. framerate for camera is same as timeline. audio is out right from the beginning, basically after about 9 seconds it starts to drift, so I have to cut it and nudge it back quite a lot! I haven't tried putting the audio feed directly through the camera but that's the next option? 

    Like
  • gillian vann said:
    yes i have this problem too.

     If you are on ScreenFlow 8.2.4 please update to the latest version supported by your macOS.

    Generally, separate USB devices and sources have different signal paths and processing times. 
    If there's a sync offset, yes you'd have to nudge it back in sync. 
    If there's sync drift we would have you do some tests to see whether it's the mic or webcam drifting.

    Like
Like Follow
  • 5 mths agoLast active
  • 3Replies
  • 15Views
  • 3 Following