0

"Deinterlace" button throws camera shot way out of aspect

This issue affects WC 13.2.0 both Beta 1 and Beta 2. Windows 10.

When I click the Deinterlace button, the camera shot's aspect radio is very distorted. It becomes wide and 'squashed'.

This happens on all four cameras. All are Sony 1080i HDMI out, going through Blackmagic HDMI>SDI converters, feeding an obsolete (but otherwise still working) Matrox VS4 input card. The Deinterlace button has worked properly with these cameras and VS4 card up to WC 13.1.3.

Here's a link to a video demonstrating the issue in more detail: https://youtu.be/2HcXTTJo-L8

 

I've filed a bug report thru the Wirecast app.

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Gary Pearce said:
    I've filed a bug report thru the Wirecast app.

     Can you post the case number?

    Gary Pearce said:
    feeding an obsolete (but otherwise still working) Matrox VS4 input card.

     Have you tested with any other input card or device?

    Like
      • Gary Pearce
      • Host, producer, engineer
      • Gary_Pearce
      • 1 yr ago
      • Reported - view

      CraigS Here's the case: Case #00756339 13.2 Beta 'Deinterlace' throws camera out of aspect ref:_00Dd0hmeU._5000W1enYgi:ref
       

      Have you tested with any other input card or device?

      I don't have another input card. I do have one Logitech C-920 camera on the system. It's working correctly, and the Device Properties menu has a different Deinterlace option ("None" or "Blend Fields"). Selecting either doesn't seem to do much.

      Like
  • Hi Gary Pearce Thank you for this!

    Firstly, the scaling of the shot on the canvas (in 13.2 is now 66.7%)-> That is correct. Since your canvas is 720 and your incoming sources are 1080, they should show that they are scaled down. So that's working as intended now.

    Secondly: To reiterate what you showed on the video-  when you click on De-interlace, you lose the aspect ratio of your incoming source. (There are workarounds to get it back - like clicking on the center "Scale" button, which should bring it back to correct aspect ratio, full canvas, then dragging the corn to resize.) But, that does indeed look like a bug.
    Would you please email me your support information (Help>Send support information >Save report . This will save a zip file on your system. Just email that to me @lynne[at]telestream.net

    Like
      • Gary Pearce
      • Host, producer, engineer
      • Gary_Pearce
      • 1 yr ago
      • 1
      • Reported - view

      lynn_elliott - Thanks, Lynn - I've emailed the report. Please note that I also filed a Support Inquiry, assigned Case #00756339, and received an email response from Bradley at Desktop Support. I apologize if I've created overlapping and duplicated efforts. I guess I should let you guys sort out the followup and let me know. Meanwhile, I'm responding to both (I gave him a link to this thread).

      (There are workarounds to get it back - like clicking on the center "Scale" button, which should bring it back to correct aspect ratio, full canvas, then dragging the corn to resize.)

      The Scale to Fit adjusts the image to fill the canvas top to bottom, but the image is still stretched horizontally. The corns (handles?) are off screen at that point. And I note that the Stretch to Fit option is not functioning.

      Like 1
Like Follow
  • 1 yr agoLast active
  • 4Replies
  • 47Views
  • 3 Following