0

Can't stream audio input to Wirecast as stereo as mono

MacOS 10.15.5

Wirecast Pro v 13.1.3

Macbook Pro 16inch 2019

Audio input  Audiobox USB audio interface

Two microphones

 

I stream church services with a simple setup-   A camcorder and two microphones.  One mic picks up pastor's audio.  Second mic picks up congregational singing.  The mic outputs are input into my MacBook Pro via an AudioBox USB interface.  The problem is that Wirecast treats the Audiobox input as a stereo pair.  If I switch the pastor mic on and congregation mic off, the audio is streamed out over the left channel with silence on the right channel. If I switch pastor mic off and congregation mic on the audio is streamed to the right channel.  Despite much effort I can't find a way to fix this in Wirecast.  I downloaded OBS studio app to see how it handles this same audio setup.  In its default state OBS handles the audio input just as WireCast does. BUT there is a "mono" setting under "Advanced Audio Properties" that allows streaming of each microphone over both left and right channels simultaneously.  How can I accomplish this in Wirecast?

Thanks.

John

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    The interface may be muxing the channels as stereo.
    Wirecast allows you to control each channel though since it supports multi-channel devices. 
    You can use the Channels Maps
    And also set Channel 1 to LR, etc. 
    Note there's also a Pan control.

    Like
  • Craigs,

    Thanks for your reply.  The solution seems to have been a simple fix.  I had the audio streaming parameters set to Stereo. I switched this is Mono.  In the live broadcast area the audio meters continued to show an audio signal in either the right or left channel (depending upon which microphone was active), but not in both.  I had expected that both audio channels would show a signal.  When I monitored the live broadcast I was pleased to find that I was receiving audio on both channels whether I had one or both microphones active.  The fact that I only saw one of the two audio output meters showing output confused me when I expected to see both with a signal.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      John Baughman Good to hear you cleared that up. 
      I'm not sure if it would have impacted what you saw but setting 1 to L, R should result in a mono signal displayed in both L and R of the meter.

      Like 1
    • CraigS Yes.  This is indeed what I had to do to get this to display the signal in both L and R  of the meter.  Thanks for your help.  I initially thought I had solved the problem.  But your instructions did the trick.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      John Baughman You're welcome of course. I've seen this with a number of sources. It's not as obvious as a "Mono" button but visual shows what's going on (sending one channel to both Left and Right). At some point we may need to do a tutorial on audio routing in Wirecast.

      Like
Like Follow
  • 2 yrs agoLast active
  • 5Replies
  • 226Views
  • 2 Following