Uknown Component Error

I'm a new user of Episode and I've been going through the tutorial/example found through the 'episodectl --help' command.

Upon trying to submit my first workflow ("episodectl ws -f source.mov -e encoder.epitask -d output/", as per the example) I run into the following  error:

***Error: Unknown component: filter chan

I am not sure how to deal with this error, I have a suspicion that it is being caused by he encoder.epitask...Help appreciated!

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • As double check there isn't an issue outside episodectl, try using your source and the encoder through the GUI and tell me what happens.

  • Submitted the workflow using GUI and everything worked fine. Tried repeating in CLI with same command and run into same error

  • It's possible there's an issue with the syntax in your CLI commands.
    One consideration is using complete path names.

    Some things to look for:
    Folder Path
    Output Directory

    Although your error may indicate there's a filter in the epitask at issue. Can you try using an epitask without any of the filters enabled on .mov or .mp4 source file and see what happens.

  • Update:

    The error was with the epitask file. Episode 7 (the version I am using) cannot handle epitask files with the channel filter hence the  "Unknown Component" error. The sample enocder.epitask bundled with Episode 7 appears to be outdated...

  • Current version of Episode is 7.1. Make sure you're using  that.
    Please explain what you mean by "sample encoder epitask." You should either create your own epitask or, for testing, use one of our prebuilt ones.

Like Follow
  • 3 yrs agoLast active
  • 5Replies
  • 661Views
  • 2 Following