eSellerate component in Flip4Mac causes crashes

The EWSEmbedded plugin that's part of the TSLicense component in Flip4Mac is causing random crashes with mdworker (the element of OS X that indexes content for Spotlight). This is under OS X 10.11.6 with Flip4Mac 3.3.7.3.

I tried removing the TSLicense, EWSMac, and EWSMac-GC files as described on the Flip4Mac website and then restarted. I downloaded and installed the Engine Updater as indicated and restarted. At that point, the Flip4Mac WMV Preference Pane would not load. (This is because the Engine Updater doesn't include the TSLicense framework, BTW.) So, I had to reinstall Flip4Mac using the Flip4Mac installer to get the Preference Pane to reload. The intermittent crash continued.

CrashReporter notes "EXC_BAD_INSTRUCTION (SIGILL)", with Exception Codes "0x0000000000000001, 0x0000000000000000", and Exception Note "EXC_CORPSE_NOTIFY". The Application Specific Information says, "Uncaught exception: 'NSInvalidArgumentException', reason: 'launch path not accessible'". I can provide crash logs, if that would be helpful.

Technically, I suppose this is an eSellerate problem, but because it's included in Flip4Mac, it becomes a Flip4Mac problem for me.

Suggestions on how to proceed?

Thanks,
David Lawhon

17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Deactivate Flip4Mac and then

    Macintosh HD> library>Frameworks>delete :

    • TSLicense.framework
    • EWSMac.framework (if available)
    • EWSMac-GC.framework (if available)

    Also look under: ~User > Library > Frameworks folder > delete:

    • EWSMac.framework
    • EWSMac-GC.framework

    Note that two of those files are in both system and user libraries and you have to get them both.

    Reboot the computer the go to
    http://www.esellerate.net/update  and download the Engine Updater for Mac OS X.
    Reboot the computer and activate. You can try activate from FlipPlayer instead of the PrefPane. Then reboot and see what happens. I suspect reinstalling might have exacerbated the problem by reinstalling old components again.


    If you've done all that than do fill out the form listing the steps you've done and well get back to you with a workaround.
    Flip4Mac Support Form

    Reply Like
  • Thanks, Craig! I followed your instructions, and the crashes are now gone.

    Under this method, the Flip4Mac pref pane won't open afterwards; however, as you noted, the activation and preferences can be accessed through FlipPlayer.

    I was wondering why there hasn't been a new release of Flip4Mac containing the current eSellerate engine (and that resolves the pref pane issue that results). Is it that the new engine won't work on some older versions of OS X that Flip4Mac supports?

    Reply Like
  • Do you see the Flip4Mac System Pref Pane or just can't open it?


    There's some ongoing issues with eSellerate but it doesn't affect everyone so we have the workarounds as needed.

    Reply Like
  • Yes, I see it. But when I try to open it, it says, "Preferences Error. Could not load Flip4Mac preference pane."

    Here's what the Console says during launch of the Flip4Mac pref pane:
         "System Preferences[1187]: dlopen_preflight failed with dlopen_preflight(/Library/PreferencePanes/Flip4Mac WMV.prefPane/Contents/MacOS/Flip4Mac WMV): Library not loaded: @rpath/TSLicense.framework/Versions/A/TSLicense
         Referenced from: /Library/PreferencePanes/Flip4Mac WMV.prefPane/Contents/MacOS/Flip4Mac WMV
         Reason: image not found for /Library/PreferencePanes/Flip4Mac WMV.prefPane"

    Your workaround for the earlier crash removes "TSLicense.framework" from /Library/Frameworks/, but the Engine Updater doesn't reinstall it. It looks like the Flip4Mac pref pane is requiring that this framework be installed for the pref pane to launch.

    Reply Like
  • Now that it's activated try downloading Flip4Mac and installing it again.

    Reply Like
  • OK, I downloaded Flip4Mac and installed it again. Now that the TSLicense.framework is present, the crash is back. Perhaps there's a newer version of TSLicense.framework available that might not cause crashes?

    Reply Like
  • Let's see if we can break you out of this loop. Fill out the form and link to this forum thread so the engineers can read what you've tried and we'll see if we can get you the fix.

    Flip4Mac Support Form

    Reply Like
  • David, can you provide the steps to duplicate the mdworker crash.  Does it just happen by itself as mds scans the drive or is there something you do that makes this happen?  Looking in my DiagnosticReports, I can see that I've had the crash occur here, but can't seem to make it happen on command.

    Andy

    Reply Like
  • I just submitted the Support Form that Craig requested, along with detailed steps to reproduce. I have a crash log, but there was no way to upload it using the Support Form. I also mentioned a Console error message but didn't include it in the Support Form; here it is:

    System Preferences[8097]: dlopen_preflight failed with dlopen_preflight(/Library/PreferencePanes/Flip4Mac WMV.prefPane/Contents/MacOS/Flip4Mac WMV): Library not loaded: @rpath/TSLicense.framework/Versions/A/TSLicense
      Referenced from: /Library/PreferencePanes/Flip4Mac WMV.prefPane/Contents/MacOS/Flip4Mac WMV
      Reason: image not found for /Library/PreferencePanes/Flip4Mac WMV.prefPane
     

    -- David

    Reply Like
  • David Lawhon Andy may need the step by step of what you were actually doing when the crash occurs. Describe as if you wanted someone to follow your steps to cause the crash. Otherwise you can download a trial of Telestream ScreenFlow and do a screen recording so we can see the steps.

    Reply Like
  • After deleting the Spotlight index and restarting the computer, I walk away and allow time for it to fully index the drive. So, the answer is: I'm doing nothing when mdworker crashes in that scenario. And it always crashes in that scenario. Aside from that information, there's nothing to see using ScreenFlow that you wouldn't see following the detailed steps I provided in the Support Form you asked me to complete.

    As for later mdworker/TSLicense crashes (where I haven't just deleted the Spotlight index), they're not reproducible on demand. Thus, I tend to think it's better to focus on the crash that occurs sometime after deleting the Spotlight index and rebooting, because it's easily reproducible (at least for me), and resolving its cause might also resolve the later crashes that occur in a more complicated scenario. That's where the Crash Log might provide you with some insight.

    Reply Like
  • I've been able to reproduce this crash, but only once.  We have a fix and would appreciate it if you could try it out and see if it fixes the crash on your machine.

     

    Please download it from:

     

    https://www.dropbox.com/s/85971th8yonodkb/Flip4Mac%203.3.8.1-beta.dmg?dl=0

     

    and install it and let us know if you still see the problem.  This link will expire in 24 hours.  

     

    Thank you!

    Reply Like
  • I removed the two EWSMac frameworks that the Engine Updater had installed, then I restarted the computer. I installed the Flip4Mac 3.3.8.1 Beta and restarted the computer again. I then deleted the Spotlight index and restarted again. After a few minutes, mdworker crashed with a log whose details were similar to that which occurred in 3.3.7.3 when TSLicense was installed. This was a silent crash. (All mdworker crashes under 3.3.7.3 had caused a crash log dialog to display.)

    I then deleted the Spotlight index again, restarted, and mdworker indexed the drive without crashing (silently or otherwise). I deleted the index a third time, restarted, and mdworker indexed the drive without crashing. Previously, it would have crashed all three times. So, the Beta is clearly an improvement for me.

    I'll monitor it over the next few days to see whether any mdworker/TSLicense crashes occur randomly and report what I find.

    Since TSLicense is back, the Flip4Mac prefpane opens correctly again.

    Reply Like
  • After this one instance, I haven't seen another mdworker crash. I've tried deleting the Spotlight index nine times, restarting after each, and mdworker hasn't crashed--either immediately after deleting the index or at later times.

    That having been said, and me being unable to provide a new crash log, I think we should just chalk that one mdworker crash up to chance and figure that the problem in 3.3.7.3 has been fixed in 3.3.8.1-Beta. 3.3.7.3 would've crashed each of the nine times I've tried, plus a couple at other times; 3.3.8.1-Beta hasn't.

    Reply Like
  • Thanks for testing and reporting.

    Reply Like
  • I never posted the end result here--only in email--but the final version of 3.3.8.1 fixed the problem.

    Reply Like
  • David Lawhon Thanks for that update.

    Reply Like
login to reply
Like Follow
  • Status Answered
  • 1 mth agoLast active
  • 17Replies
  • 485Views
  • 3 Following