4

Mix to Mono in Screenflow 6

Just updated to Screenflow 6 and I don't see the "mix to mono" button.  I see you can adjust with this weird slider, but not input an absolute value. 

 

 

And then when I have selected multiple audio tracks, I used to be able to mix all to mono at once. Now I can't!

 

 

This is frustrating because my microphone only records one channel and I need to mix all tracks of mono. Since screenflow doesn't have an option to do this when you record like most programs, I need to do it after the fact. Now you have taken this away all together. 

How can I fix this? 

103replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • (Yes, I'll file a bug report for that...)

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    Chris Meyer Yup you can even file reports about the web page functionality.  I do all the time. 😉

    Like
  • I ran into something in Sierra that I don't recall seeing before. In the Accessibility pane it is now possible to select "Play stereo as mono" but it doesn't appear to have any effect on recording or playback in ScreenFlow. I was surprised that playback in SF was unaffected.

    When I first saw it I thought that it might provide relief for those who prefer to edit in mono. Perhaps a bug report to Apple would be in order.

    Like 1
  • CraigS I have in the past, and I just did again.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    Frank Lowney Interesting. You'd think it would impact anything using system sound. I may need to investigate that.

    Like
  • I can't tell you how much I hate this.  I have wasted hours trying to solve it.  I often import skype conversations to edit in screenflow It is one track and when one person speaks the channel is mono and the other it is stereo.

    I used to solve the problem with one click.  Now I cannot solve the problem at all.  I tried doing it on the export as reported above, but the volume levels are way off.  Is there an easy way to use version 5 again?

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    Megan Duma I'm not sure I understand your description. If the source of the audio is system sound (which Skype runs through) all the audio would be mono. If the audio came from an external device (webcam mic, etc) it could be stereo. Many webcam mics are stereo and that would be the correct way to record them.

    You may also be confusing channels and tracks. An audio source can have multiple channels. Each audio source would be on a separate track and one track most certainly can be stereo and the other mono depending on the source.

    I'd like to help but you're going to have to provide more detailed information as if you wanted someone to build a matching setup.

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    I use Tascam us-2x2 Sound Card. support two Mic, but i use only one mic.

    In ScreenFlow display two channel, but other channel is mute.

    I want  Record Audio from support one channel.

    Thx

     

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    li ScreenFlow is seeing whatever the sound device sends it. You'd have to control that in the device or, otherwise, center pan (so it is dual mono).

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS  I want Recording mono auto mix dual mono.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair Dual Mono would show two channels each with the same audio. Apparently ScreenFlow is only detecting audio in the first channel.

    Test in Apple's GarageBand and tell me what it sees (include screen shot if possible)?

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS I don't use Apple's GarageBand.

    I Hope ScreenFlow  can  one channel(mono) mix two channel (mono) in New versions.

    My Sound Card support two Mic (left Channel and  right Channel), but I use only one mic, in ScreenFlow detecting two Channel, but left channel speak,right channel mute.

    Every time, I manual operation all clip (one mono mix doual mono). I speak a clip and operate this clip. expend time.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair I'd like you to test in GarageBand to see how your card is handled by Apple's software. GarageBand comes installed free on all Macs.

    It's possible ScreenFlow is seeing the audio as it is presented to it though the driver and/or the OS sound system. If that's the case then you would have to center pan the audio after capture.

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS I don't know how to use this GarageBand. Capture two screenshots. If need more screenshots, please tell me.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair GarageBand shows a single channel, center panned. It could be GarageBand throws out the empty channel.

    Do a recording in ScreenFlow and look at Audio Mix and tell me what you see or post a screen shot like this. Does Audio Mix show 1 or 2 channels?

     
     

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS  default shot

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS i mix channel 1 center. 

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair Thanks for that. ScreenFlow is seeing it as a stereo pair with the channel 1 audio panned left.

    Fill out the form and link to both the GarageBand and ScreenFlow screenshots to show our technician how the audio is handled differently.

    ScreenFlow Support Form

     

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS Thank you.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair You're welcome of course.

    Like
    • achair
    • achair
    • 5 yrs ago
    • Reported - view

    CraigS How long reply to me, email to me?

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    achair You should get a case number in one day or so.
    For feature request it can take some time to evaluate. You can send email with case number and ask for status update.

    Like
  • Just wanted to add my bump for this feature request. In every other way, Screenflow's design and competance is a life-saver in my workflow - features, ease of use - everything is top notch, and I love the app. This, though is a true thorn in my side. The problem isn't having to set the pan mix for each take - that's doable. The problem is that Screenflow forgets this setting on a per-clip bases quite often. It seems to occur when making transition edits (dragging clips around). Naturally, I know that if a clip is removed, and later re-added, I'll have to set the Audio Mix again. But this happens with nothing more than a drag in the timeline. It wastes a lot of time checking and rechecking that all of my pan settings "stayed put". I'd estimate I have to reapply the pan 10-20 times for each screencast I do. I would be happy with just this fixed, though a "Always record as mono" preference setting would be awesome.

    Like 1
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 5 yrs ago
    • Reported - view

    Danny Hall Thanks for your description. Please do fill out the previously posted Feature Request form and include your description so the developers can decide how best to handle improving it.

    Like
  • Another bump: this is SO frustrating. When I've moved the panpot to centre, split my track into 60 separate clips, move them, then have to click on EVERY one and drag the panpot back to centre (because it's forgotten the setting), it adds hours onto large project, plus a bunch of RSI from clicking. It's incredibly annoying, and probably a deal-breaker.

    Like
Vote4 Follow
  • Status Completed
  • 4 Votes
  • 5 yrs agoLast active
  • 103Replies
  • 4653Views
  • 16 Following